Knepigt problem - USB 3.0 långsam på ny laptop?

Trädvy Permalänk
Medlem
Registrerad
Apr 2004

Knepigt problem - USB 3.0 långsam på ny laptop?

Jag har dragits med det här problemet ett tag nu och det är jäkligt underligt. Av någon anledning är USB (båda 3.0 portarna) på min laptop OTROLIGT långsamma. Det spelar ingen roll vilken typ av usb sticka jag använder, det spelar ingen roll vilken port stickorna sitter i....och det mest mystiska...det spelar ingen roll om jag är i windows eller inte.

Att boota från USB är i princip omöjligt. Det spelar ingen roll vad för något jag bootar (linux, windows installations usb etc) allt bootar så långsamt att det inte finns. Linux tails bootar så långsamt att det inte ens går att starta.

Innan ni frågar, stickorna är alla provade på min gamla laptop och på en polares nya laptop samt på en stationär dator så det är inget fel på dom.

Vad kan detta bero på? Om det är drivarna så borde det väl bara vara knas i windows? Använder förövrigt win10 64.

Börjar misstänka att något är fel på moderkortet eller nått.

Så här ser det som verkar ha något med USB att göra i enhetshanteraren:

https://ibb.co/n5rpCT

och

https://ibb.co/m9O2XT

Säg till om det är något annat ni behöver veta! Uppskattar all hjälp jag kan få!

Trädvy Permalänk
Medlem
Registrerad
Jul 2004

Alla portar testade? Det låter otroligt konstigt. Enhetshanteraren visar inget konstigt vad jag ser, ta gärna en titt i windows loggbok och se om du har USB-fel där, exempelvis drivrutinsvarningar osv.

CPU: I7 4770K Grafik: Poseidon Platinum GeForce GTX 980Ti Moderkort: Asus Maximus VI Hero Z87 RAM: 16Gb Corsair Dominator Platinum CL9 Nätagg: Corsair HX1050 Gold SSD: Corsair Force GT 240Gb SSHD: Seagate Desktop 4TB Låda: Corsair Graphite 600T

Trädvy Permalänk
Hedersmedlem
Plats
Sverige
Registrerad
Dec 2005

Vad är det för laptop? USB kanske delar resurser (som i pcie-banor t ex) med SSD eller något annat vitalt? Det förekommer ju, speciellt i lågbudgetsammanhang. Tyvärr brukar det vara rätt bökigt att leta reda på hur det är konstruerat.

Synpunkter på min moderering? Hör av dig via PM eller mail.

W7, Intel 5820K, Asus X99-S, Crucial DDR4 2133MHz 32GB, Sapphire 290X Tri-X, Intel 730 SSD, WD Black+Green+HGST, Silverstone FT02, Corsair AX1200, Corsair K90, Logitech MX518, Eizo 2736w, Eaton 5115 UPS. Huawei P20 Pro
* Stolt paragrafryttare *

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Hmm... Såg att du kör CM238 chipset.
https://www.intel.com/content/dam/www/public/us/en/documents/...
Kollade snabbt på lite info, såg sid 4 på länken ovan.

USB Ports
Up to 10 USB 3.0† and 14 USB 2.0

PCIe Gen3 Lanes
Up to 20†

Tänkte... vad är †?
-> "† Enabled with Flexible I/O"

Så man börjar söka och...
"Flexible I/O is an architecture that allows some high speed signals to be statically
configured as PCI Express* (PCIe*), USB 3.0 or SATA signals per I/O needs on a
platform.

The PCH implements a number of high speed I/O (HSIO) lanes that are split between the different interfaces, PCIe*, USB 3.0, SATA, GbE, USB Dual Role (OTG). The following figure summarizes the PCH HSIO lanes multiplexing.
The Flexible I/O is configured through soft straps

https://www.intel.com/content/dam/www/public/us/en/documents/...

Så ja... Multiman ovan har nog snubblat på det. Det verkar som att de troligen har delade PCI-E resurser, och dina USB portar måste delas med något annat, som typ PCI-E/SATA SSD eller något annat som kräver mycket, vilket lämnar ingen bandbredd till din USB.

Ovan är spekulation, men det är vad man kan göra tills man vet exakt dator.

Trädvy Permalänk
Medlem
Registrerad
Apr 2004
Skrivet av Gurk:

Alla portar testade? Det låter otroligt konstigt. Enhetshanteraren visar inget konstigt vad jag ser, ta gärna en titt i windows loggbok och se om du har USB-fel där, exempelvis drivrutinsvarningar osv.

Inget sådant

Skrivet av MultiMan:

Vad är det för laptop? USB kanske delar resurser (som i pcie-banor t ex) med SSD eller något annat vitalt? Det förekommer ju, speciellt i lågbudgetsammanhang. Tyvärr brukar det vara rätt bökigt att leta reda på hur det är konstruerat.

Skrivet av Paddanx:

Hmm... Såg att du kör CM238 chipset.
https://www.intel.com/content/dam/www/public/us/en/documents/...
Kollade snabbt på lite info, såg sid 4 på länken ovan.

USB Ports
Up to 10 USB 3.0† and 14 USB 2.0

PCIe Gen3 Lanes
Up to 20†

Tänkte... vad är †?
-> "† Enabled with Flexible I/O"

Så man börjar söka och...
"Flexible I/O is an architecture that allows some high speed signals to be statically
configured as PCI Express* (PCIe*), USB 3.0 or SATA signals per I/O needs on a
platform.

The PCH implements a number of high speed I/O (HSIO) lanes that are split between the different interfaces, PCIe*, USB 3.0, SATA, GbE, USB Dual Role (OTG). The following figure summarizes the PCH HSIO lanes multiplexing.
The Flexible I/O is configured through soft straps

https://www.intel.com/content/dam/www/public/us/en/documents/...

Så ja... Multiman ovan har nog snubblat på det. Det verkar som att de troligen har delade PCI-E resurser, och dina USB portar måste delas med något annat, som typ PCI-E/SATA SSD eller något annat som kräver mycket, vilket lämnar ingen bandbredd till din USB.

Ovan är spekulation, men det är vad man kan göra tills man vet exakt dator.

Tack för svaren båda två. Det är en alienware 17R4 så det bör ju inte räknas som en budget dator i allafall. Finns det något sätt att lösa det här själv på? Har dom fuskat när dom satte ihop den för att komma billigare undan?

Trädvy Permalänk
Medlem
Registrerad
Okt 2016

USB 1 har 35 MBps, köp bättre stickor.

Trädvy Permalänk
Medlem
Plats
Mariefred
Registrerad
Jul 2011

Har du valt bättre prestanda under disk i enhetshanteraren

╔ Corsair 32GB DDR4 CL15 3000Mhz VENGEANCE RGB ■
╠ ASUS-ROG-MAXIMUS-X-HERO ■ ASUS-ROG-STRIX-GTX1080TI-OC ■ i7 8700K
╠ DeepCool Captain 280EX RGB ■ 2x Samsung 970 EVO 500GB■
╠ Deepcool NEW ARK 90 Electro Limited Edition NR58 ■ XFX PRO1000W Limited Black Edition
╚ Samsung SE790C 34" Ultrawide 3440x1440@75Hz

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av DaXia:

Tack för svaren båda två. Det är en alienware 17R4 så det bör ju inte räknas som en budget dator i allafall. Finns det något sätt att lösa det här själv på? Har dom fuskat när dom satte ihop den för att komma billigare undan?

Det låter då lite konstigt att du får så dålig prestanda. Normalt gör de denna typ av fusk på 15W eller enklare maskiner. Men en fullskalig maskin som det borde inte ha dessa begränsningar, om de inte gjort bort sig.

Vad du kan göra är ju testa lägga in Intel chipset drivers. Detta borde ge dig USB drivare också som är optimerade för systemet. Det du kör nu är ju MS universala 1.0 drivare, och den har sina ljusa och mindre ljusa stunder. Annars får du ju kontakta tillverkaren och fråga om något är galet.