Win 10: Saknar behörighet för filer på gammal hårdisk

Trädvy Permalänk
Medlem
Plats
Tyresö
Registrerad
Mar 2004

Win 10: Saknar behörighet för filer på gammal hårdisk

Jag köpte en "IDE-grej" som faktiskt tycks fungera.

Jag kommer åt hårddisken och kan hantera alla filer (utom de som ligger under Windowskatalogen för användaren).

Jag har annan användare idag och tror inte attjag kommer ihåg lösenordet som var på den gamla.

Jag kan se allt innehåll i mappen men om jag öppnar en fil fungerar det inte och försöker jag kopiera till en annan hårddisk står det att behörighet saknas. Under enheten har jag fösökt ändra säkerhet.

Under fullständig behörighet står att åtkomst begränsas av "resurs" och jag tycks inte kunna ändra det?

Kan jag på något sätt komma åt filerna?

Gaming: ASUS Z170 PRO GAMING | Intel Core i7 6700K 4.0 GHz | iGame GeForce GTX 1080Ti Vulcan AD 11 GB | HyperX 16GB (2x8GB) DDR4 2133MHz Fury Black | EVGA Supernova G2 750W | Samsung 850-Series EVO 500GB | 640GB WD, 7200RPM | | 2TB WD Caviar Green Power | FD Define R4 | Philips Brilliance 40" BDM4037UW | Acer Predator X34A

Filserver: MK Asus E35M1-I Deluxe | ASUS GeForce GT 710 2GB LP | Corsair 4GB DDR3 | WD, Caviar Green Power 2TB | WD Red 8TB | WD Caviar Black 640 GB| FD Array R2 300W

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Det är alltså din gamla disk... hade ironiskt nog exakt samma problem igår själv.

Vill du bara komma åt filerna och kopiera ut det du vill spara?
Starta om i felsäkert läge, kopiera det du vill ha, sen formatera disken.
https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows...
Rekommenderar alt 2... enklaste som inte kräver trix. Bara välj starta om, och håll nere skift när du gör det. Sen bara klicka dig genom menyerna.

Det verkar att som i felsäkert läge, struntar Windows i alla filrättigheter och bara kör. Så du kan komma åt diskar du normalt inte borde. Sen när du är klar och har allt kopierat till en annan disk, formatera den externa disken (snabb räcker väl), och sedan starta om igen som vanligt.

Om du desperat vill behålla filsystemet (inget jag rekommenderar på gammal disk med Windows partition dock), så kan du i felsäkert läge ta full äganderätt över filerna också.

Trädvy Permalänk
Medlem
Plats
Austrått, Norge
Registrerad
Sep 2005

Du kan också gå in på behörighet på disken och välja din användarprofil och "nherit". Kör engelskt os och är inte hemma nu men kan slänga in en skärmdump ikväll om du inte löser problemet.

Mvh

Fractal Design Define R6, Asus P9X79, Xeon E5-2670@3150Ghz (30*105Mhz), 32gb Corsair Vengeance@1866Mhz, EVGA 780GTX Hydrocopper, Nvidia Quadro 5000

Stacker STC-01, Asus Rampage, Xeon 5460@4.20Ghz, 8gb RAM

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Jun 2004

Är du administratör på datorn vilket jag antar att du är så är det bara att gå in i egenskaper på den disk du inte kommer åt och sen in i säkerhet.
Klicka på Avancerat och sen på Ändra behörighet.
Lägg sedan till dig som ägare av disken med fulla rättigheter genom att klicka på Lägg till och sedan på Välj ett huvudkonto.
Klicka sedan på avancerat och sedan sök nu.
Dubbelklicka på Administratörer ock sen på OK. Klicka i full behörighet och sen OK.

Låt datorn ändra behörigheter för alla filer och mappar. Kan ta ett tag om disken är stor. Sen så äger du hela disken med din nuvarande administratör. Lycka till.

Trädvy Permalänk
Medlem
Plats
Tyresö
Registrerad
Mar 2004

Lyckades nu. Angav "användarnamnet" manuellt, men var tvungen att söka och välja det rätta. Då fungerade det.

Tack för engagement.

Gaming: ASUS Z170 PRO GAMING | Intel Core i7 6700K 4.0 GHz | iGame GeForce GTX 1080Ti Vulcan AD 11 GB | HyperX 16GB (2x8GB) DDR4 2133MHz Fury Black | EVGA Supernova G2 750W | Samsung 850-Series EVO 500GB | 640GB WD, 7200RPM | | 2TB WD Caviar Green Power | FD Define R4 | Philips Brilliance 40" BDM4037UW | Acer Predator X34A

Filserver: MK Asus E35M1-I Deluxe | ASUS GeForce GT 710 2GB LP | Corsair 4GB DDR3 | WD, Caviar Green Power 2TB | WD Red 8TB | WD Caviar Black 640 GB| FD Array R2 300W

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Apr 2010
Skrivet av Alfa347:

Är du administratör på datorn vilket jag antar att du är så är det bara att gå in i egenskaper på den disk du inte kommer åt och sen in i säkerhet.
Klicka på Avancerat och sen på Ändra behörighet.
Lägg sedan till dig som ägare av disken med fulla rättigheter genom att klicka på Lägg till och sedan på Välj ett huvudkonto.
Klicka sedan på avancerat och sedan sök nu.
Dubbelklicka på Administratörer ock sen på OK. Klicka i full behörighet och sen OK.

Låt datorn ändra behörigheter för alla filer och mappar. Kan ta ett tag om disken är stor. Sen så äger du hela disken med din nuvarande administratör. Lycka till.

Hoj, menar inte att hijacka den här tråden men jag har samma problem och försökte just göra nästan samma sak med en hårddisk från en trasig laptop som jag kopplad in via esata nu. Den är mappad till "D:"

Problemet för mig nu är dock att jag ändrade rättigheterna enbart på "Documents and Settings" katalogen till "Allow" på allt för grupp/user "Everyone", tyckte det verkade enklast.
Och när jag applyat så verkar det som att windows helt enkelt skapade någon slags symbolisk länk/junction till min vanliga "c:\users" på något djävligt mysko sätt.

Alltså i utforskaren får "D:\Documents and Settings" en sådan "shortcut" ikon (transparant mapp + shortcut pilen). Och dubbelklickar jag på den så visar den mig innehållet ifrån min "C:\users".

Så err... ja, är lite lost. Några tips anyone?

[Update]
Hrrm om jag förstått det rätt efter lite läsning är "documents and settings" länken bara en symlink till typ users för bakåtkompabilitet med xp?
Så det fanns mao inget där från första början, frågan är ju då var fan users foldern som borde vara på D: är någonstans, ugh

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Jun 2004

@flexm: Har du fulla rättigheter för D:? annars så börja med att fixa det genom att göra så som jag skrev i mitt förra inlägg.

Vad exakt är det du vill rädda från den "externa" disken?

När du har fulla rättigheter så ska det bara vara att gå in på D: och till user/användare-mappen och kolla på den gamla användaren som du víll åt. Kan vara bra att slå på så du ser även dolda mappar m.m.

Kan hjälpa dig via Teamviewer i morgon kväll om det skulle behövas.