Ubiquiti UniFi linux management controller

Trädvy Permalänk
Medlem
Registrerad
Feb 2009

Ubiquiti UniFi linux management controller

Hej! Jag beställde en Ubiquiti AP för några veckor sedan men jag har dock stött på ett problem. Jag har installerat unifi-beta (har även testat unifi) men inget händer när jag försöker nå den med localhost:8443 (127.0.0.1:8443 eller 192.168.1.148:8443)

Distrubitionen jag försöker köra detta på är Arch Linux.

3 aur/unifi-beta 5.9.16-1 [installed] (15) (0,03) Controller for Ubiquiti UniFi accesspoints

Jag startar tjänsten med systemctl start unifi.service och sedan kör jag systemctl status unifi.service.
När jag kör status så får jag detta:

● unifi.service - Ubiquiti UniFi Server Loaded: loaded (/usr/lib/systemd/system/unifi.service; disabled; vendor preset: disabled) Active: active (running) since Fri 2018-08-03 14:30:16 CEST; 4s ago Main PID: 8232 (java) Tasks: 853 (limit: 4915) Memory: 391.5M CGroup: /system.slice/unifi.service └─8232 /usr/bin/java -jar /usr/lib/unifi/lib/ace.jar start aug 03 14:30:16 laptop systemd[1]: Started Ubiquiti UniFi Server. aug 03 14:30:17 laptop java[8232]: WARNING: An illegal reflective access operation has occurred aug 03 14:30:17 laptop java[8232]: WARNING: Illegal reflective access by org.springframework.cglib.core.ReflectUtils$2 (file:/usr/lib/unifi/lib/spring-core-3.2.18.RELEASE.jar) to method java.lang.ClassLoader.defi> aug 03 14:30:17 laptop java[8232]: WARNING: Please consider reporting this to the maintainers of org.springframework.cglib.core.ReflectUtils$2 aug 03 14:30:17 laptop java[8232]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations aug 03 14:30:17 laptop java[8232]: WARNING: All illegal access operations will be denied in a future release

.

Är det något paket jag saknar? Någon annan som löst detta problem? Tack på förhand.

( jag har tidigare testat windows versionen på en windows dator och det har fungerat! )

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

De där varningarna har med Java att göra, inte unifi. Fungerar det inte eller har du bara hakat upp dig på att du ser varningsmeddelanden?

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

De där varningarna har med Java att göra, inte unifi. Fungerar det inte eller har du bara hakat upp dig på att du ser varningsmeddelanden?

Jag är ingen expert på området. Vet du vilket java paket som ev. saknas?

edit: Det fungerar inte att ansluta.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Jag är ingen expert på området. Vet du vilket java paket som ev. saknas?

Det är inget som saknas utan det verkar vara något allmänt problem i Java 9. Varningar kan ignoreras såvida de inte orsakar problem och det där är något för utvecklarna att kika på, inte du som användare.

Har du problem med att få igång programmet så tvivlar jag att de där varningarna har något med saken att göra.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Plats
falkenberg
Registrerad
Jan 2002

kör du https ?

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av toben:

kör du https ?

Hej! Jag har prövat både http och https men ingen sida hittas tyvärr.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Hej! Jag har prövat både http och https men ingen sida hittas tyvärr.

Klistra in innehållet ur /var/log/unifi/mongod.log.
Det är möjligt att det har något med IPv6 att göra enligt denna källa.

edit: Klistra in innehållet i din hostfil också /etc/hosts

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

Klistra in innehållet ur /var/log/unifi/mongod.log.
Det är möjligt att det har något med IPv6 att göra enligt denna källa.

Pastebin

edit:

/etc/hosts

# Static table lookup for hostnames. # See hosts(5) for details.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Pastebin

edit:

/etc/hosts

# Static table lookup for hostnames. # See hosts(5) for details.

Hostfilen är tom alltså?

Peta in följande där och se om det blir någon skillnad:

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

Hostfilen är tom alltså?

Peta in följande där och se om det blir någon skillnad:

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

Hej!
Testade precis men det fungerar tyvärr inte heller.

Webbplatsen kan inte nås localhost avvisade anslutningen.

Webbplatsen kan inte nås 127.0.0.1 avvisade anslutningen.

Webbplatsen kan inte nås 192.168.1.148 avvisade anslutningen.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Hej!
Testade precis men det fungerar tyvärr inte heller.

Webbplatsen kan inte nås localhost avvisade anslutningen.

Webbplatsen kan inte nås 127.0.0.1 avvisade anslutningen.

Webbplatsen kan inte nås 192.168.1.148 avvisade anslutningen.

Okej, få se vad som står i /var/log/unifi/server.log också då.
Sen verkar det nästan som att det saknas en portöppning i brandväggen i.o.m. att anslutningen blir avvisad... vad skriver du för URL när du försöker ansluta och försöker du från en annan enhet än din Arch-maskin?

edit: vad får du för svar om du kör följande kommando?:

# netstat -nap | grep 8443

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

Vilken version av mongodb kör du? Tänk på att du behöver köra version 3.6 som max.

This is not the place for mindless aggression
NAT är fel!
https://getgeek.se

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

Okej, få se vad som står i /var/log/unifi/server.log också då.
Sen verkar det nästan som att det saknas en portöppning i brandväggen i.o.m. att anslutningen blir avvisad... vad skriver du för URL när du försöker ansluta och försöker du från en annan enhet än din Arch-maskin?

edit: vad får du för svar om du kör följande kommando?:

# netstat -nap | grep 8443

Jag testade att ansluta med en annan dator (https://192.168.1.148:8443) men får tyvärr inget svar där heller (windows dator).

/var/log/unifi/server.log

sudo netstat -nap | grep 8443 ger inget svar?

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av Veidit:

Vilken version av mongodb kör du? Tänk på att du behöver köra version 3.6 som max.

6 community/mongodb 4.0.0-1 [installed] A high-performance, open source, schema-free document-oriented database

edit: Är detta en för ny version då?

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Jag testade att ansluta med en annan dator (https://192.168.1.148:8443) men får tyvärr inget svar där heller (windows dator).

/var/log/unifi/server.log

sudo netstat -nap | grep 8443 ger inget svar?

Det betyder att tjänsten inte är startad, annars skulle du ha sett den som att den är uppe och lyssnar på port 8443.
Din server.log pekar på att det blir ett NoClassDefFoundException när unifi försöker starta. Detta förklarar även varför mongodb såg ut att stänga ner direkt efter uppstart.

Eftersom du kör v 4.0 av mongo och @Veidit nämner att endast upp till 3.6 stöds så bör du nog försöka nedgradera mongodb.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

Det betyder att tjänsten inte är startad, annars skulle du ha sett den som att den är uppe och lyssnar på port 8443.
Din server.log pekar på att det blir ett NoClassDefFoundException när unifi försöker starta. Detta förklarar även varför mongodb såg ut att stänga ner direkt efter uppstart.

Eftersom du kör v 4.0 av mongo och @Veidit nämner att endast upp till 3.6 stöds så bör du nog försöka nedgradera mongodb.

Förlåt om jag låter lite tjatig men hur bär jag mig åt för att hitta och installera ett äldre paket manuellt? (antar att det är det som måste göras?)

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av llxt:

Förlåt om jag låter lite tjatig men hur bär jag mig åt för att hitta och installera ett äldre paket manuellt? (antar att det är det som måste göras?)

https://wiki.archlinux.org/index.php/Arch_Linux_Archive#How_t...
https://wiki.archlinux.org/index.php/pacman#Skip_package_from...

Men gör dig själv en tjänst och dra igång en LXC-container med debian istället (där paketet finns officiellt). När något program kräver specifika versioner av olika beroenden blir det lätt totalt kaos eller till och med omöjligt att köra det på samma system som massa annat utan enormt mycket onödigt arbete.

förtydligande

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Förlåt om jag låter lite tjatig men hur bär jag mig åt för att hitta och installera ett äldre paket manuellt? (antar att det är det som måste göras?)

Skrivet av LemonIllusion:

https://wiki.archlinux.org/index.php/Arch_Linux_Archive#How_t...
https://wiki.archlinux.org/index.php/pacman#Skip_package_from...

Men gör dig själv en tjänst och dra igång en LXC-container med debian istället (där paketet finns officiellt). När något program kräver specifika versioner av olika beroenden blir det lätt totalt kaos eller till och med omöjligt att köra det på samma system utan enormt mycket onödigt arbete.

pacman -U kräver att en tidigare version av paketet varit installerat på systemet tidigare (så vitt jag förstår det) så om detta är en nyinstallation kommer det troligtvis inte att fungera.

I sådant fall får du först avinstallera paketet:

# sudo pacman -Rs mongodb

Sedan får du klona git-repot för en äldre version från AUR och installera det manuellt:

# git clone https://aur.archlinux.org/mongodb-3.4.git # cd <den path dit repositoryt har klonats (står som output när du kör ovanstående kommando)> # makepkg

Efter detta bör mongodb v.3.4 vara installerat istället.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Plats
umeå
Registrerad
Jun 2005
Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av noMad17:

pacman -U kräver att en tidigare version av paketet varit installerat på systemet tidigare (så vitt jag förstår det) så om detta är en nyinstallation kommer det troligtvis inte att fungera.

Nej, gamla paket finns i arkivet precis som det står i min länk. Det är inte nödvändigt att kompilera själv för att få en äldre version.

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av LemonIllusion:

Nej, gamla paket finns i arkivet precis som det står i min länk. Det är inte nödvändigt att kompilera själv för att få en äldre version.

Ah, blandade ihop det med vad som stod i wikin för pacman. Missade att det var en path till arkivet med i det du länkade till, verkar ju väldigt smidigt.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2001

Då du inte är så bra på Linux så kanske det är enklare att du köper dig en Cloud Key?
Alternativt att du kör Ubuntu Server 16.04 som stöds av Ubnt.
Kort och gott, att inte göra det för avancerat för dig.

This is not the place for mindless aggression
NAT är fel!
https://getgeek.se

Trädvy Permalänk
Medlem
Registrerad
Feb 2009

Det känns som att detta börjar bli lite off topic kanske.

Om jag installera unifi och försöker ta bort mongodb så vägrar den fortsätta med borttagningen.

FEL: Kunde inte förbereda transaktionen (kunde inte tillfredsställa beroenden) :: unifi: Att ta bort mongodb kommer att förstöra beroendet "mongodb"

Installerar jag mongodb-3.4 åvanpå mangodb så installeras paketet utan fel. Startar jag därefer unifi så använder den sig av den nyaste versioen. Hur kan jag tvinga bort den senaste versionen?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2001
Skrivet av llxt:

Det känns som att detta börjar bli lite off topic kanske.

Om jag installera unifi och försöker ta bort mongodb så vägrar den fortsätta med borttagningen.

FEL: Kunde inte förbereda transaktionen (kunde inte tillfredsställa beroenden) :: unifi: Att ta bort mongodb kommer att förstöra beroendet "mongodb"

Installerar jag mongodb-3.4 åvanpå mangodb så installeras paketet utan fel. Startar jag därefer unifi så använder den sig av den nyaste versioen. Hur kan jag tvinga bort den senaste versionen?

Gör som du blivit tipsad, antingen en vm/container med någon annan dist (debian, ubuntu, etc) eller om du inte är supertaggad på arch helt enkelt köra någon av dom distarna rakt av.

Argaste

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

@llxt:

Läs igenom svaren här, varför kör du inte Windows om det funkade?

https://community.ubnt.com/t5/UniFi-Wireless/UniFi-Installati...

sudo service mongod stop
sudo apt purge mongodb-org*
sudo rm -r /var/log/mongodb
sudo rm -r /var/lib/mongodb
sudo apt autoremove

Asus P8P67 | i7 2600k | Corsair H80 | Asus GTX 770 OC | 8GB | Corsair TX650W | Fractal Design R3 | Intel 520 240GB

Macbook Pro Retina 15'' 2.6Ghz | 16GB | 512GB Late 2013

Trädvy Permalänk
Medlem
Registrerad
Feb 2009

@joeldeluxe: Hej! Jag kör windows på en av mina datorer men skulle var skönt om det fungerade på min main laptop. Den där lösningen gäller väl Debian?

Jag får kanske ta steget att köra igång en virtuell maskin då.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av joeldeluxe:

@llxt:

Läs igenom svaren här, varför kör du inte Windows om det funkade?

https://community.ubnt.com/t5/UniFi-Wireless/UniFi-Installati...

sudo service mongod stop
sudo apt purge mongodb-org*
sudo rm -r /var/log/mongodb
sudo rm -r /var/lib/mongodb
sudo apt autoremove

Det där fungerar bara på Debian-baserade distros, inte på Arch Linux.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Det känns som att detta börjar bli lite off topic kanske.

Om jag installera unifi och försöker ta bort mongodb så vägrar den fortsätta med borttagningen.

FEL: Kunde inte förbereda transaktionen (kunde inte tillfredsställa beroenden) :: unifi: Att ta bort mongodb kommer att förstöra beroendet "mongodb"

Installerar jag mongodb-3.4 åvanpå mangodb så installeras paketet utan fel. Startar jag därefer unifi så använder den sig av den nyaste versioen. Hur kan jag tvinga bort den senaste versionen?

Det är inte helt lätt (eller säkert) att ta bort paket som andra har beroenden till, men ett sätt är att ta bort utan att köra en beroendekoll:

# sudo pacman -Rdd mongodb

Läs mer i svaret på en liknande fråga.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Registrerad
Feb 2009
Skrivet av noMad17:

Det är inte helt lätt (eller säkert) att ta bort paket som andra har beroenden till, men ett sätt är att ta bort utan att köra en beroendekoll:

# sudo pacman -Rdd mongodb

Läs mer i svaret på en liknande fråga.

Så om jag tar bort mongodb med -Rdd och sedan installera mongodb-3.4 så bör det generelt fungera? Men det fungerar dock inte. Är det säkert att det är just mongodb som är problemet? Jag är inte någon expert när det gäller att föstå långa log-filer.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av llxt:

Så om jag tar bort mongodb med -Rdd och sedan installera mongodb-3.4 så bör det generelt fungera? Men det fungerar dock inte. Är det säkert att det är just mongodb som är problemet? Jag är inte någon expert när det gäller att föstå långa log-filer.

Du har alltså lyckats avinstallera v.4.0 och istället installerat v.3.4 och det fungerar ändå inte?

Helt säkert att det är mongodb är det inte, men det blir fel just när den försöker ansluta till mongo, så det pekar på det.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W