Permalänk

Memory leak non-paged pool "NDnd"

Hej!

Jag har en ganska irriterande läcka sen ett par veckor tillbaka. Läckan händer mest när jag laddar youtube videos och allt minne som läcker hamnar under taggen NDnd "non-paged" och processen "Ndis.sys". Jag har redan provat att uppdatera mina nätverkskort via enhetshantaren, provade även att hämta senase "Killer network" programvaran, men det resulterade bara i en permanent 1.8Gig non-paged även efter omstart, så jag avinstallerade. sedan dess så startar datorn med en ganska normal 170Mb non-paged, men stiger när jag laddar media via internet browser. Min flickvän har samma problem på ett annat system med annan hårdvara.

Operativsystem: Microsoft Windows 10 och senaste drivrutinerna
Processor: Intel Core i7 6700K
Processorkylare: 3rd party torn av fancy slag
Moderkort: Gigabyte g1 gaming Z170
Minne: 2x 8 GB HyperX 2133 MHz
Grafikkort: MSI GTX 1080 gaming X
Hårddisk: En ssd av märke jag inte kommer ihåg + vanlig HDD

tacksam för hjälp!

Permalänk
Permalänk

Har märkt att det slutar läcka när jag stänger av AVG, så det är en grej.

Permalänk

Har installerat BitDefender och det läcker inte på samma sätt längre, återkommer om det inte funkar.

Permalänk
Medlem

Hallå! Jag vet inte svenska men jag hoppas du förstår mig. I have exactly the same issue appeared recently. When I watch the video on YouTube, the non-paged pool is gradually growing, only restarting the computer helps (not shutting down though). Using Poolmon.exe, I came to the NDnd tag and ndis.sys causing the problem. I have very similar hardware to yours, except the motherboard (mine from Asus) and i'm using Avast Free Antivirus instead of AVG. All the drivers are up to date, Windows 10 was updated on August 14.

Have you solved your problem? And if so, how? Could it be Avast Antivirus (it was also updated recently)? The problem appeared out of nowhere, do not know what to do exactly.

Hope you write back, thank you!

Permalänk

Try disabling your antivirus and see what happens. I'm running bitdefender now and I haven't had any leaks since.

Permalänk
Medlem

Hello again! The culprit is indeed the last version of Avast. AVG and Avast use the same engine and so they share this problem. I already reported the problem to developers. Thank you for your reply!