Nybygge - Raven Ridge - Xubuntuinstallation

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

Nybygge - Raven Ridge - Xubuntuinstallation

Hejsan!

Jag har precis fått ihop min dator (se signaturen nedan). Torrstart för att komma in i UEFI har gått finfint så hårdvaran verkar fungera och vara korrekt inkopplad. Tangentbordet är ett trådlöst Logitech K400+ (står också i signaturen) och fungerar i UEFI.

När jag sätter i ett USB-minne med Xubuntu 18.04.1 syns bara vänstra halvan av startbilden, fast två gånger (både på vänstra och högra halvan av skärmen). Tangentbordet fungerar inte.

I uppstarten får jag någon form av felmeddelande där det står något om "ACPI" och "Already exists". Är det någon som har en aning om vad som kan vara fel?

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

Mindre uppdatering: Jag provade med Ubuntu 18.04.1 också och fick i princip samma fel. Enda skillnaden var att tangentbordet fungerade.

Felmeddelandena från uppstarten lyder något i stil med:
ACPI Error: [SMIC] Namespace lookup failure, AE_Already [...]

ACPI Exception: AE_ALREADY_EXISTS, During name lookup/[...]
ACPI Exception: AE_ALREADY_EXISTS, /SSDT: AND P[...]
ACPI Error: 1 table load failures, 7 successful (20170[...]
ACPI Error: [PTOS] Namspace lookup failure, AE_NOT_FOU[...]
ACPI Error: Method parse/execution failed \. AE_NOT_FOU[...]

Ska prova med Open Suse också bara för att se vad som händer (har aldrig testat den disten förut).

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001

Börja med att uppdatera BIOS till senaste versionen. Se till att BIOS är ställt till att boota UEFI och sätt secure boot till "other OS".

Om inte det hjälper prova boota med 'acpi=off'.

Problemet är relaterat till effekthanteringssystemet för hårdvaran. Ubuntu tycker inte om hur ditt moderkort hanterar det. Därför är det bra med senaste versionen av BIOS. Sätter du 'acpi=off' blir du av med sleep/wake/hibernate, C-states, P-states osv. Ingen bra lösning alltså, men det borde låta dig boota.

Frågan är vilken del av hårdvaran som skapar problem. SMIC och PTOS torde ge ledtrådar, men jag lyckas inte googla fram vad de pekar på. Jag hittade inte heller något när jag sökte igenom ACPI-specifikationerna. Å andra sidan är jag svårt onykter och borde egentligen sova...

Kan du spåra vilken hårdvara det är relaterat till bör det gå att hitta lösningar.

En möjlig lösning är som sagt att uppdatera BIOS. En annan lösning är att uppdatera och/eller konfigurera om Linux-kärnan. ACPI är ett lager mellan operativsystemet och BIOS, så istället för att prata direkt med BIOS kommunicerar operativsystemet med ACPI-lagret som i sin tur pratar med BIOS. Därför kan både en BIOS-uppdatering och en uppdatering av kärnan lösa problemet.

I värsta fall behöver du en patchad DSDT för att få allt att funka. Det är en tabell som beskriver hårdvaran för operativsystemet. Det är tyvärr en svår lösning, om du inte hittar någon på forumet med god vana för det som kan hjälpa dig. Förhoppningsvis hittar vi en enklare lösning.

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

Jag har provat att uppdatera BIOS till P.470. Secure boot har alternativen Aktiverat och Inaktiverat (Enabled och Disabled). Som standardläge är det inaktiverat.

Att bara uppdatera BIOS resulterade i att inte ens installationsbilden för Xubuntu dök upp.

ACPI HPET Table kan aktiveras eller inaktiveras. En inaktivering tog bort lite text (antagligen felmeddelanden) men i övrigt ingen förbättring.

Vad menar du med "Se till att BIOS är ställt till att boota UEFI"?

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Medlem
Registrerad
Jun 2006

Har du prövat en äldre *buntu, typ 16 eller kanske en annan dist? Testa Debian kanske. Även Arch kan ju vara värt att testa då det inte är en Debianbaserad dist.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2008

Jag kör Debian Sid med egenkompilerad Linux 4.19-rc4 på min 2400G, du vill nog ha minst 4.18 för Raven Ridge. 4.15, som Ubuntu 18.04.1 kommer med, har många problem med Raven Ridge när den ens bootar.

Det du kan göra är att boota med "nomodeset" tills du har installerat en nyare kernel, då är det CPUn som ritar grafiken via UEFI-framebuffern istället.

Mjölnir: AMD Ryzen 5 2400G | Gigabyte GA-AB350N | Crucial Ballistix Sport 8GB | Sapphire RX 580 8GB NITRO+ | IKEA Knagglig
Server: Intel i7-2600 | ASRock Z68 Fatal1ty (defekt men bootar) | Corsair XMS 32GB | Sapphire HD 5850 1GB | NZXT Switch 810

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

@Defcon: Man kan säga såhär: Jag kör Linux eftersom jag ogillar Windows och heller inte är särskilt bra på datorer. Med ett antal års mellanrum har jag installerat någon *buntuversion (Ubuntu, Lubuntu och nu senast Xubuntu) och sedan har datorn i stort sett fått tuffa på.

Gällande äldre versioner av *buntu har jag läst att Ryzen 2400G tarvar nyare linuxkärnor och att mixtra en "gammal" dist med en ny kärna är inget jag har någon vidare koll på.

Däremot försökte jag med Open Suse men då hittade moderkortet inte ens ISO-filen.

Det senaste försöket är Manjaro och då kommer jag så långt som att installationsbilden visas korrekt, jag kan ställa in tidszon, välja tangentbordslayout och språk, samt välja öppna eller proprietära drivrutiner. Jag kunde till och med sätta igång ett memtest (körde bara igenom en full runda men inga fel där). Däremot går det inte att boota själva operativsystemet.

Det är fortfarande samma ACPI-fel men skillnaden nu är att det dyker upp ytterligare felmeddelanden:

AMD-Vi: Unable to write to IOMMU perf counter.
Error: '/dev/disk/by-label/MJR17112' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs]#

Edit:
@Djhg2000: Vad är "nomodeset" och hur fixar man det?

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001
Skrivet av LaoLao:

Jag har provat att uppdatera BIOS till P.470. Secure boot har alternativen Aktiverat och Inaktiverat (Enabled och Disabled). Som standardläge är det inaktiverat.

Att bara uppdatera BIOS resulterade i att inte ens installationsbilden för Xubuntu dök upp.

ACPI HPET Table kan aktiveras eller inaktiveras. En inaktivering tog bort lite text (antagligen felmeddelanden) men i övrigt ingen förbättring.

Vad menar du med "Se till att BIOS är ställt till att boota UEFI"?

Det kan se lite olika ut beroende på BIOS men någonstans under CSM brukar det finnas alternativ som "auto", "legacy" eller "UEFI". Sätt det till UEFI.

Skrivet av LaoLao:

Det är fortfarande samma ACPI-fel men skillnaden nu är att det dyker upp ytterligare felmeddelanden:

AMD-Vi: Unable to write to IOMMU perf counter.
Error: '/dev/disk/by-label/MJR17112' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs]#

Testa VT-d på eller av i BIOS.

Sista raden indikerar att det kan vara problem med just KMS (Kernel Mode Set). Edit: Syftar på "sh: can't access tty", vilket kan vara att kärnan inte får access till grafikkortet och därför inte kan öppna en terminal.

Citat:

Edit:
@Djhg2000: Vad är "nomodeset" och hur fixar man det?

KMS är ett sätt för Linux-kärnan att kommunicera direkt med grafikkortet för att sätta rätt upplösning m.m - "nomodeset" stänger av det. Om det hjälper dig boota kan du senare konfigurera kärnan och installera de drivrutiner som behövs, för att få det att funka igen.

När du bootar ska du först få upp en liten Grub bootmeny. Där ska också finnas något alternativ liknande "Grub boot command line", det kan också vara någon knapptryckning för att få upp det - du får googla på hur du gör med just din version (jag minns inte exakt och det där kan se lite annorlunda ut).

Där ska du sen kunna hitta 'GRUB_CMDLINE_LINUX_DEFAULT=' alternativt 'linux boot vmlinuz-yadayada root=UUID=yadayada ro quiet splash". Där lägger du till 'nomodeset' och du kan som sagt även testa 'acpi=off'.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2008

@LaoLao: Se inlägget från @DasIch för en bra beskrivning för hur du aktiverar "nomodeset". Det är mycket riktigt så att det avaktiverar KMS, vilket betyder att grafikkortet fortsätter köra i samma läge som UEFI lämnade det när datorn startade. Du kommer antagligen att köra skärmen i någon låg standardupplösning men det är ju bättre än inget.

När installationen är klar och datorn startar om utan installationsskivan måste du följa instruktionerna igen för det installerade systemet. När den har startat behöver du uppdatera din kernel, till exempel med denna guide: http://ubuntuhandbook.org/index.php/2018/08/how-to-install-li... .

Efter det ska datorn gå att använda som vanligt.

Mjölnir: AMD Ryzen 5 2400G | Gigabyte GA-AB350N | Crucial Ballistix Sport 8GB | Sapphire RX 580 8GB NITRO+ | IKEA Knagglig
Server: Intel i7-2600 | ASRock Z68 Fatal1ty (defekt men bootar) | Corsair XMS 32GB | Sapphire HD 5850 1GB | NZXT Switch 810

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001
Skrivet av Djhg2000:

@LaoLao: Se inlägget från @DasIch för en bra beskrivning för hur du aktiverar "nomodeset". Det är mycket riktigt så att det avaktiverar KMS, vilket betyder att grafikkortet fortsätter köra i samma läge som UEFI lämnade det när datorn startade. Du kommer antagligen att köra skärmen i någon låg standardupplösning men det är ju bättre än inget.

När installationen är klar och datorn startar om utan installationsskivan måste du följa instruktionerna igen för det installerade systemet. När den har startat behöver du uppdatera din kernel, till exempel med denna guide: http://ubuntuhandbook.org/index.php/2018/08/how-to-install-li... .

Efter det ska datorn gå att använda som vanligt.

Precis. Om nomodeset fixar problemet, vilket det verkar som att det kan göra, är det bara att bita i det sura äpplet och lära dig konfigurera din egen kärna. Det borde finnas bra guider till det, anpassade för din hårdvara. Om det saknas kan du kolla guider från Gentoo och Arch. De funkar kanske inte rakt av men de ska kunna ge dig en bra uppfattning om vad du håller på med. Exempelvis så kanske du vill använda Ubuntus guide till en egen konfiguration av kärnan men Gentoo eller Arch till inställningarna för din hårdvara.

Skillnaderna är egentligen inte så stora. Det brukar mest handla om var kärnan är placerad och kopplad till systemet. Gäller bara att veta hur det ser ut för din distro. Inställningarna är desto viktigare, men dessa kan du få från vilken distro som helst. Jag rekommenderar bara Gentoo och Arch därför att de har bra guider som brukar vara uppdaterade.

Och apropå uppdateringar av kärnan. Det är verkligen inte så svårt som många tror. Du behöver liksom inte förstå alla inställningar och många inställningar kommer inte påverka dig alls.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2008
Skrivet av DasIch:

Precis. Om nomodeset fixar problemet, vilket det verkar som att det kan göra, är det bara att bita i det sura äpplet och lära dig konfigurera din egen kärna. Det borde finnas bra guider till det, anpassade för din hårdvara. Om det saknas kan du kolla guider från Gentoo och Arch. De funkar kanske inte rakt av men de ska kunna ge dig en bra uppfattning om vad du håller på med. Exempelvis så kanske du vill använda Ubuntus guide till en egen konfiguration av kärnan men Gentoo eller Arch till inställningarna för din hårdvara.

Skillnaderna är egentligen inte så stora. Det brukar mest handla om var kärnan är placerad och kopplad till systemet. Gäller bara att veta hur det ser ut för din distro. Inställningarna är desto viktigare, men dessa kan du få från vilken distro som helst. Jag rekommenderar bara Gentoo och Arch därför att de har bra guider som brukar vara uppdaterade.

Och apropå uppdateringar av kärnan. Det är verkligen inte så svårt som många tror. Du behöver liksom inte förstå alla inställningar och många inställningar kommer inte påverka dig alls.

Skickades från m.sweclockers.com

Det ska egentligen inte behövas någon konfiguration/kompilering alls, i alla fall Debians kernel är redan kompilerad med rätt parametrar (CONFIG_DRM_AMDGPU=m och CONFIG_DRM_AMD_DC_DCN1_0=y) så skulle ju tippa på att Ubuntu kör med dem påslagna också. Ska alltså vara så enkelt som att bara installera 4.18 från PPA.

Linux 4.19-rc1 och senare har löst problemet jag hade innan med att GPUn kunde hänga sig vid boot så det kan vara något att kika på när man känner sig mer bekväm med att byta kernel.

Mjölnir: AMD Ryzen 5 2400G | Gigabyte GA-AB350N | Crucial Ballistix Sport 8GB | Sapphire RX 580 8GB NITRO+ | IKEA Knagglig
Server: Intel i7-2600 | ASRock Z68 Fatal1ty (defekt men bootar) | Corsair XMS 32GB | Sapphire HD 5850 1GB | NZXT Switch 810

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

Jag har provat Manjaro 18, betaversionen, då den ska ha en nyare kärna(?) och kom då till GRUB men fick då följande felmeddelande:
error: symbol 'grub_key_is_interrupt' not found.
Entering rescue mode

Jag har provat Manjaro 18 med ACPI både aktiverat och inaktiverat.
Gällande UEFI Secure boot verkar inte alla Asrockmoderkort ha alternativ att fippla med det (jag gjorde en snabb och ytlig googling) och jag hittar inget som talar för att jag kan välja "Other OS".

När jag googlade CSM dök det bara upp information om Asusmoderkort.
VT-d verkar vara en Intelgrej. AMD:s motsvarighet är Vi och jag hittar inget om det i BIOS...

Kvarstår då att prova nomodeset
(Jag ska dock prova Ubuntus betaversion av 18.10 också.)

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Medlem
Plats
Västra Frölunda
Registrerad
Aug 2006

Är det skillnad på 2400G & 2200G ? Jag har kört en 2200G med Opensuse Tumbleweed ett tag, och det har varit smärtfritt sedan dom uppdaterade till 4.16, även om prestandan har ökat märkbart i nyare kernel versioner.

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

@ddelin: Den största skillnaden finns någon bakom (framför?) skärmen.

Hursomhelst provade jag att ladda hem Xubuntu 18.10 och det gick att installera utan särskilda BIOS-inställningar.

Stabiliteten är inget jag vågar säga något om men ett OS är i alla fall installerat. Ska prova att migrera lite inställningar från den gamla burken så får den nya agera experimentverkstad under några månader.

Steg ett blir att migrera webbläsarinställningarna.

Tack alla för tips och hjälp (även om det räckte med att hitta den senaste distroversionen)!

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

Ytterligare en uppdatering och skiten vägrade starta. Visst, det är en beta men ändå...

Jag får väl sitta kvar med betan tills den skarpa versionen släpps.

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus

Trädvy Permalänk
Medlem
Plats
Västra Frölunda
Registrerad
Aug 2006
Skrivet av LaoLao:

Ytterligare en uppdatering och skiten vägrade starta. Visst, det är en beta men ändå...

Jag får väl sitta kvar med betan tills den skarpa versionen släpps.

Kolla i den här tråden https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/open-source-amd-linux/1032693-ryzen-2200g-still-not-reliable-in-4-18rc2-when-will-it-work
Verkar vara en del strul med både 2200G & 2400G som är relaterade till moderkorts bios.

Trädvy Permalänk
Medlem
Plats
Öland
Registrerad
Dec 2013

@ddelin: Jag vet att det har varit en del bekymmer med Raven Ridge men jag hade liksom hoppats att de skulle lösas lite fortare.

Som det är nu tycks det bara vara att hänga med både vad det gäller BIOS-uppdateringar och Linuxuppdateringar.

# = Brädgård
FD Nano S|FD Effekt 400W|ASRock AB350 ITX/ac|AMD Ryzen 2400G|Ballistix Sport 2666Mhz CL 16|Samsung 860 EVO 250GB|Dell U2415|Logitech K400 Plus