Kan inte kompilera i Git Bash, olika versioner problem!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2010

Kan inte kompilera i Git Bash, olika versioner problem!

Skriver min första riktiga java kod, den kompileras genom javac kommandot men sedan när jag ska köra den genom java kommandot får jag följande problem:

"java.lang.UnsupportedClassVersionError: has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0"
Har JDK 11 installerat men även JRE 1.8, testade att ta bort JRE men då kunde den inte hitta en viss sökväg, hjälp uppskattas!

EDIT* Löste problemet

Världens ondska rangordnas enligt följande:
Personer som fuskar i spel
"Nedladdnings annonser" på nedladdningshemsidor
Copyswede
TS som inte svarar!

Trädvy Permalänk
Hedersmedlem
Plats
Linköping
Registrerad
Okt 2006
Skrivet av Alexander7938:

Skriver min första riktiga java kod, den kompileras genom javac kommandot men sedan när jag ska köra den genom java kommandot får jag följande problem:

"java.lang.UnsupportedClassVersionError: has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0"
Har JDK 11 installerat men även JRE 1.8, testade att ta bort JRE men då kunde den inte hitta en viss sökväg, hjälp uppskattas!

EDIT* Löste problemet

Hur löste du problemet?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2010
Skrivet av Shimonu:

Hur löste du problemet?

Laddade ner JDK 8 istället för 11, compilern var för ny!

Skickades från m.sweclockers.com

Världens ondska rangordnas enligt följande:
Personer som fuskar i spel
"Nedladdnings annonser" på nedladdningshemsidor
Copyswede
TS som inte svarar!