Forumdelen sponsras av

Gästnätverk fungerar inte för alla enheter

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

Gästnätverk fungerar inte för alla enheter

Hej,
jag har en fundering kring att använda mig utav gäst wifi för mina jobbdatorer men det verkar inte fungera. Anledningen är att jag inte vill att jobbdatorerna ska kunna kommunicera med mitt hemnätverk.
Routern är en TP-link Archer C9 där jag kan välja att aktivera gästnätverket.

Jag har testat med olika mobiltelefoner med (privata dock) och datorer
Nexus 6p - kopplar upp sig till gästnätverket men har inget internet
Huawei P20 pro - kopplar upp sig har internet
HP Elitebook - kopplar upp sig och har internet, Windows 10 pro

Jobbdator 1 - inget internet, Windows 10
Jobbdator 2 - inget internet, Windows 7
Jobbdator 3 - inget internet, Windows 10

Alla enheter kopplar upp sig utan problem mot vanliga nätverket - i.e icke gäst wifi

Vad är det som gör att mina jobbdatorer inte kan koppla upp sig mot mitt gäst-wifi?
De borde väl inte kunna se om det är ett gäst-wifi eller inte?

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

@Carranor: Har du ställt in accesstiden för gästnätverket?
Så att klienterna kommer åt Internet.

Hittade denna guide:
https://www.tp-link.com/se/support/faq/743/?utm_medium=select...

CPU: i5-3570K@4,4GHz | RAM: 16GB (4x4GB) Corsair LP | MB: Asus Maximus V Gene Z77 | GPU: MSI Radeon RX580 Armor 8GB | Chassi: FD Arc mini R2 | PSU: CM700V | SSD: Crucial MX300 750GB | Monitor: Yamakasi Catleap 2B Extreme | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

@Lembritt:
Hej, tack för länken!
Jag har Archer C9 v1 med Firmware Archer C9(UN)_V1_160517 och det verkar inte finnas någon senare version av Firmware längre.
Det finns inte så mycket att välja när jag väljer att använda mig utav Gästnätverk. Finns i princip bara inställningen av eller på!

Länken som du hittade hade många fler funktioner.
Kanske behöver jag installera 3rd party grejor på min router. Jag är bara för feg.

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

@Carranor: Du får tillgång till dom inställningarna under avancerat.

Om du aktiverar gästnätverket, kan enheterna ansluta till det nya nätverket, men saknar anslutning till Internet?
Eller misslyckas anslutning till routern?

CPU: i5-3570K@4,4GHz | RAM: 16GB (4x4GB) Corsair LP | MB: Asus Maximus V Gene Z77 | GPU: MSI Radeon RX580 Armor 8GB | Chassi: FD Arc mini R2 | PSU: CM700V | SSD: Crucial MX300 750GB | Monitor: Yamakasi Catleap 2B Extreme | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Hur fungerar gästnätverket? Är det lösenord på SSID som vanligt eller är det öppet? Om det är öppet så brukar det vara en webbsida du loggar in via. Inte så att det är en begränsning av antal enheter på det nätverket?

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

Mitt interface under Advanced ser nästan identiskt ut som Basic.

@Lembritt

Enheterna kan logga in på nätverket men sen står det ingen internetåtkomst (t.ex. om man tittar på wifi-ikonen längst ner till höger där det står connected, no internet)
Jag kan logga på gästnätverket med min privata laptop och desktop.
Men jobb-lapptoppen så ansluter jag till gästnätverket, sedan tar det stopp. Till det vanliga WiFi är det inga som helst problem.

Har testat med att ställa in de olika kombinationerna med, på bilden är det Auto.

@jocke92
Det är med SSID och password.
Jag har försökt att logga på en enhet i taget.

Det känns som något förhindrar jobbdatorerna från att koppla upp sig till ett gästnätverk. Vad skiljer?

Om det inte är någon skillnad kan jag teoretiskt sätt vända på det och koppla alla mina privata enheter till gästnätverket och jobbdatorerna till det vanliga

Trädvy Permalänk
Medlem
Registrerad
Dec 2008
Skrivet av Carranor:

Mitt interface under Advanced ser nästan identiskt ut som Basic.
http://forumbilder.se/I5NQT/archerc9interface.PNG
@jocke92
Det är med SSID och password.
Jag har försökt att logga på en enhet i taget.

Det känns som något förhindrar jobbdatorerna från att koppla upp sig till ett gästnätverk. Vad skiljer?

Om det inte är någon skillnad kan jag teoretiskt sätt vända på det och koppla alla mina privata enheter till gästnätverket och jobbdatorerna till det vanliga

Det ska inte vara någon skillnad på ett gästnätverk och ett vanligt nätverk sett från en klient. Det som normalt sett skiljer är det jag beskrev innan att du inte har något lösenord först och blir istället skickad till en webbsida för inloggning. Det är det som kan strula, men det har ju inte du.

Du har en knapp där det står 5Ghz, har du aktiverat gästnätet med samma inställningar på det bandet? Så du inte har olika inställningar för det kan ställa till det

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

@jocke92:
Hej, jag har aktiverat den med.
När jag kör Windows Network Diagnostics får jag
Your computer appears to be correctly configured, but the device Detected or resource (primary DNS) is not responding.

Då kom jag på att jag hade satt annan Primary DNS under DHCP settings. Har en raspberry pi där med typ adblock. Men konstigt att den lät enheterna koppla upp sig med internet när jag kopplar på dem vanligt jfr gästnätverket.

Nu får jag bara komma på hur jag kan ha min Ad-block pi aktiv för jag vill gärna ha den på.

När jag tar bort DNS från DHCP så släpper faktiskt gästnätverket in mina jobbdatorer.
Konstigt att de släpps igenom via den vanliga och att routern accepterar mina hemdatorer utan vidare till hemnätverket.

Provar nu min Nexus 6P telefon som är riktigt kinkig.
Den vill inte alls sålänge DNS är ifyllt i routern...hmm.
Nu har jag iallafall hittat källan.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008
Skrivet av Carranor:

@jocke92:
Hej, jag har aktiverat den med.
När jag kör Windows Network Diagnostics får jag
Your computer appears to be correctly configured, but the device Detected or resource (primary DNS) is not responding.

Då kom jag på att jag hade satt annan Primary DNS under DHCP settings. Har en raspberry pi där med typ adblock. Men konstigt att den lät enheterna koppla upp sig med internet när jag kopplar på dem vanligt jfr gästnätverket.

Nu får jag bara komma på hur jag kan ha min Ad-block pi aktiv för jag vill gärna ha den på.

När jag tar bort DNS från DHCP så släpper faktiskt gästnätverket in mina jobbdatorer.
Konstigt att de släpps igenom via den vanliga och att routern accepterar mina hemdatorer utan vidare till hemnätverket.

Provar nu min Nexus 6P telefon som är riktigt kinkig.
Den vill inte alls sålänge DNS är ifyllt i routern...hmm.
Nu har jag iallafall hittat källan.

Då är det så att den använder samma DNS-inställningar för båda nätverken. Det du kan kolla är om du gör en ipconfig /all på klienten där ser du om det är pihole som är DNS eller routern. Ibland kan man ställa in så att klienten frågar routern som i sin tur frågar pihole (eller valfri DNS). Då kommer nog nätet och pihole fungera på gäst-nätverket.

En annan lösning är att köra någon annan DNS som sekundär i DHCP, då kommer enheterna på gästnätverket först testa pihole och sedan efter några sekunder börja fråga den sekundära istället. Så länge pihole svarar kvickt så kommer de vanliga klienterna hålla fast vid pihole

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

@jocke92:
Hej,
jag kollade företagsdatorerna och de svarar mot primary DNS ((en egen "pihole" något jag labbar med)) och secondary (pihole).
Det jag inte får att stämma är varför skulle DNS spela roll på gästnätverket. För kopplar jag upp mot mitt vanliga nät så är det samma primary och secondary DNS som frågas efter först.

Snart börjar semestern och då lär jag inte labba med detta ett bra tag tills det är dags igen.
Tack för svaren.

ps, alternativ lösning är faktiskt koppla på en annan router på annat uttag till mediaomvandlaren. Tror de blir som separata nätverk helt då.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Det brukar ofta gå att ange hur många gäster som får vara anslutna, det är inget sånt som stoppar trafiken ?

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av Carranor:

@jocke92:
Hej, jag har aktiverat den med.
När jag kör Windows Network Diagnostics får jag
Your computer appears to be correctly configured, but the device Detected or resource (primary DNS) is not responding.

Då kom jag på att jag hade satt annan Primary DNS under DHCP settings. Har en raspberry pi där med typ adblock. Men konstigt att den lät enheterna koppla upp sig med internet när jag kopplar på dem vanligt jfr gästnätverket.

Nu får jag bara komma på hur jag kan ha min Ad-block pi aktiv för jag vill gärna ha den på.

När jag tar bort DNS från DHCP så släpper faktiskt gästnätverket in mina jobbdatorer.
Konstigt att de släpps igenom via den vanliga och att routern accepterar mina hemdatorer utan vidare till hemnätverket.

Provar nu min Nexus 6P telefon som är riktigt kinkig.
Den vill inte alls sålänge DNS är ifyllt i routern...hmm.
Nu har jag iallafall hittat källan.

Problemet är att när du kopplar upp dig på gästnätverket så kommer inte klienterna åt din rpi/dns som sitter på din vanliga lan. Vilket är själva tanken med gästnät Jag vet ej hur den funktionen fungerar på TP links. Men antingen så får du sätta en annan dns i dhcpn för gästnäten, vilket är det enklaste typ då 8.8.8.8/1.1.1.1. Eller så får du installera en rpi till som sitter på gästnätet och ange den som dns. Du kan också bocka i "tillåt gästerna att komma åt mitt lan" då kommer det också fungera men då kan de ju likaväl köra på ditt vanliga.
Beroende på hur gästnätet fungerar på tpn så kan du prova göra en fw regel där du tillåter port 53(dns)/udp mellan ditt gästnät och ditt vanliga nät. Då fungerar det också.

Edit: För att verifiera det är dns problem så kan du prova pinga 8.8.8.8 och sedan www.google.se. Om det går att pinga siffrorna men inte namnet så är det dns problem. Funkar det inte att pinga 8.8.8.8 så har du problem med själva länken i sig.
Du kan också prova surfa till http://81.201.220.174 - www.sweclockers.com (samma test som att pinga 8.8.8.8)

Edit2: "Det jag inte får att stämma är varför skulle DNS spela roll på gästnätverket." - det är för att dns fyller fortfarande sin roll oavsett. DNS är en som en telefonkatalog och ipnummer är telefonnumren. Du behöver det för att kunna surfa som vanligt.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2018

Jag har inte prövat någon automatiserad funktion för att aktivera gästnätverk, däremot så har jag gjort det manuellt. Du kan också pröva om du har tillgång till dom funktionerna i routern och om det finns stöd för dom. Skapa ett nytt nätverk som typ 192.168.2.0 (S/M 255.255.255.0). Skapa sedan ett nytt VLAN kopplat till det nätverket, och brygga det sedan med en av Wifi frekvenserna.

För mig fungerade det utmärkt och jag har inte haft några problem med forward DNS lookups. Dock har jag manuellt angett min VPN leverantörs DNS servrar för att tunnla alla DNS förfrågningar dit istället för internetoperatören.

Edit: Kolla i DHCP när gäst-wifi är påslaget, hur stort spann du faktiskt har tillgängligt för anslutande enheter också så det inte har blivit något galet där.

Enthoo Evolv ATX | Asus ROG Strix Z370-H Gaming | Delid 8700K UV 1.100v | NH-D15 | 32GB DDR4 | NVME M2 960 500GB | AG271QG | Gigabyte 1080Ti | R1600T3 Edifier | Sony MDR-1A | Cerberus MK II | Logitech G403 | SteelSeries QcK - XXL Musmatta | Mitt skrivbord Windows 2019 x64 Enterprise LTSC | ASUS MG279Q | Behöver du hjälp? Egna skriverier

Trädvy Permalänk
Medlem
Registrerad
Dec 2008
Skrivet av Carranor:

@jocke92:
Hej,
jag kollade företagsdatorerna och de svarar mot primary DNS ((en egen "pihole" något jag labbar med)) och secondary (pihole).
Det jag inte får att stämma är varför skulle DNS spela roll på gästnätverket. För kopplar jag upp mot mitt vanliga nät så är det samma primary och secondary DNS som frågas efter först.

Snart börjar semestern och då lär jag inte labba med detta ett bra tag tills det är dags igen.
Tack för svaren.

ps, alternativ lösning är faktiskt koppla på en annan router på annat uttag till mediaomvandlaren. Tror de blir som separata nätverk helt då.

Hur menar du med en egen pihole? Så som det borde fungera så frågar den samma DNS:er som det vanliga nätverket, vilket är svaret på varför det inte fungerar. DNS fungerar så att om inte den primära DNS svarar med något går den till sekundära. Det är därför pihole svarar med sin egen IP som är en blank webbsida

Sätter du googles eller 1.1.1.1 som sekundär så tror jag det löser problemet. Men som du säger är en annan lösning att sätta en router till kopplad i medieomvandlaren med ett eget nät.

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

@jocke
Med egen pihole menar jag att jag skrev en sån Adblock i Raspberry pi med hjälp av en kompis innan jag kände till pihole. Den ligger på en Raspberry pi. Sedan köpte jag en Raspberry pi 2 några år senare och i den har jag pihole installerad.

Jag är ingen programmerare så mitt första Adblock fungerar väl hyfsat men har inte uppdaterats på att tag sen kompisen som är programmerare inte längre har tid och så lägg till tidsskillnaden. Han bor i Kanada 😃. Med andra ord har jag inte full koll på hur den fungerar men den läser av en textfil från någon webbsida som innehåller siter som ska blockeras.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Apr 2011

Det löste sig om jag satte secondary till 1.1.1.1. Svaret blev ju uppenbart efter att ha läst era inlägg.
Tack för alla svaren till allihopa.
Ha en glad sommar.