Linux Mint 19.2 och drivrutin till RX 5700XT

Trädvy Permalänk
Medlem
Registrerad
Maj 2017

Linux Mint 19.2 och drivrutin till RX 5700XT

Hej alla!

Jag har för avsikt att helt gå över till Linux och valt just Mint för det.
har installerat operativsystemet i en nybyggd dator. Har för tillfället dualboot med Linux Mint som första alternativ och Windows 10. Båda installationer fungerar bra, men med reservation för linux. Jag har inte lyckats få in drivrutinen för grafikkortet som är ett Sapphire RX 5700XT. Detta gör att jag sitter med en upplösning på 1024x768 på en 4K skärm :-/. Nu har jag har varit inne på AMD:s hemsida och sett att drivrutiner för grafikkortet för Ubuntu (vilka, vad jag förstår ska fungera på Linux Mint?) finns att ladda ned sen igår, men eftersom jag är en riktig gröngöling vad gäller Linux så vågar jag inte experimentera... än!
Så min undring, någon som vet OM det finns drivrutiner för grafikkortet och i så fall hur jag kollar det?... eller är det så att jag behöver ha is i magen för att drivrutinerna ska komma närsom?

någon som kan kasta lite ljus över detta... så är jag evigt tacksam :-)!

Vänligen
Alberto

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Okt 2013
Skrivet av Tetiton:

Hej alla!

Jag har för avsikt att helt gå över till Linux och valt just Mint för det.
har installerat operativsystemet i en nybyggd dator. Har för tillfället dualboot med Linux Mint som första alternativ och Windows 10. Båda installationer fungerar bra, men med reservation för linux. Jag har inte lyckats få in drivrutinen för grafikkortet som är ett Sapphire RX 5700XT. Detta gör att jag sitter med en upplösning på 1024x768 på en 4K skärm :-/. Nu har jag har varit inne på AMD:s hemsida och sett att drivrutiner för grafikkortet för Ubuntu (vilka, vad jag förstår ska fungera på Linux Mint?) finns att ladda ned sen igår, men eftersom jag är en riktig gröngöling vad gäller Linux så vågar jag inte experimentera... än!
Så min undring, någon som vet OM det finns drivrutiner för grafikkortet och i så fall hur jag kollar det?... eller är det så att jag behöver ha is i magen för att drivrutinerna ska komma närsom?

någon som kan kasta lite ljus över detta... så är jag evigt tacksam :-)!

Vänligen
Alberto

Du borde kunna ändra upplösning out of the box utan att installera något särskilt.
Har du provat ändra upplösning i system inställningarna eller med xrandr direkt?

xrandr -s 3840x2160

Prova även installera AMDGPU drivrutinerna https://amdgpu-install.readthedocs.io/en/latest/

Stationär Dator Intel Core i7 4790k 4.85 Ghz @1.3V, Kelvin S24, GTX 970, Kingston Hyper X 4x4 GB 1600 MHz, Samsung 840x3, Msi Z97 Gaming 7, Arch Linux, Beyerdynamic DT 990 PRO, Asus PG279Q. Bärbar Dator Lenovo Yoga 720, Fedora 29 Nas FreeNas 4 TB

Trädvy Permalänk
Medlem
Registrerad
Maj 2017

@SaltyLiquorice: Stor tack för snabbt svar, då har jag något att prova :-)!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006
Skrivet av Tetiton:

Hej alla!

Jag har för avsikt att helt gå över till Linux och valt just Mint för det.
har installerat operativsystemet i en nybyggd dator. Har för tillfället dualboot med Linux Mint som första alternativ och Windows 10. Båda installationer fungerar bra, men med reservation för linux. Jag har inte lyckats få in drivrutinen för grafikkortet som är ett Sapphire RX 5700XT. Detta gör att jag sitter med en upplösning på 1024x768 på en 4K skärm :-/. Nu har jag har varit inne på AMD:s hemsida och sett att drivrutiner för grafikkortet för Ubuntu (vilka, vad jag förstår ska fungera på Linux Mint?) finns att ladda ned sen igår, men eftersom jag är en riktig gröngöling vad gäller Linux så vågar jag inte experimentera... än!
Så min undring, någon som vet OM det finns drivrutiner för grafikkortet och i så fall hur jag kollar det?... eller är det så att jag behöver ha is i magen för att drivrutinerna ska komma närsom?

någon som kan kasta lite ljus över detta... så är jag evigt tacksam :-)!

Vänligen
Alberto

Aldrig kört Mint med AMD grafikkort, bara Nvidia och där är det inga problem, Har du kört drivrutinshanteraren? den brukar fixa rätt drivrutin från AMD eller Nvidia samt ladda ner och installera.

Acer Predator Helios 300

Trädvy Permalänk
Medlem
Registrerad
Maj 2017

Löst det :-)!

@ggustavsson:
ja, provat det men inga drivrutiner kom upp som alternativ.
jag provade även att köra enl tips från SaltyLiquorice; xrandr men det hände ingenting.
Jag laddade ned drivrutinen från AMD:s hemsida och fick läsa på lite för att kunna hantera grundläggande Linuxkommandon i Terminalen (jag anser mig vara en riktig gröngöling på detta :-), följde instruktionerna på AMD:s hemsida (stor tack SaltyLiquorice) efter lite svett.. så har jag nu en fungerande Linux Mint installation, med min önskade 4K upplösning på skärmen.

Stor tack för hjälpen hörni!
Tetiton (gröngölingshackern

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Okt 2013
Skrivet av Tetiton:

@ggustavsson:
ja, provat det men inga drivrutiner kom upp som alternativ.
jag provade även att köra enl tips från SaltyLiquorice; xrandr men det hände ingenting.
Jag laddade ned drivrutinen från AMD:s hemsida och fick läsa på lite för att kunna hantera grundläggande Linuxkommandon i Terminalen (jag anser mig vara en riktig gröngöling på detta :-), följde instruktionerna på AMD:s hemsida (stor tack SaltyLiquorice) efter lite svett.. så har jag nu en fungerande Linux Mint installation, med min önskade 4K upplösning på skärmen.

Stor tack för hjälpen hörni!
Tetiton (gröngölingshackern

Kul du fick det att fungera, den stora tröskeln är verkligen i början när man använder linux. Vid närmare eftertanke fungerade nog inte scale alternativet i xrandr just för att du saknade en drivrutinen som talar om för systemet vilka olika modes (upplösningar) som skärmen har stöd för.

Stationär Dator Intel Core i7 4790k 4.85 Ghz @1.3V, Kelvin S24, GTX 970, Kingston Hyper X 4x4 GB 1600 MHz, Samsung 840x3, Msi Z97 Gaming 7, Arch Linux, Beyerdynamic DT 990 PRO, Asus PG279Q. Bärbar Dator Lenovo Yoga 720, Fedora 29 Nas FreeNas 4 TB

Trädvy Permalänk
Medlem
Registrerad
Maj 2017

@SaltyLiquorice: ja, riktigt kul... blir som en liten unge.. typ ... kan själv :-)!
å ja, förstod att när drivrutinen inte finns tillgänglig så blir det tokigt.
Ett sidospår, men ju mer jag navigerar runt i systemet och försöker förstå hur det fungerar så blir det tydligt vilket stor skillnad det är mot hur Windows fungerar :-)!!
Nästan som att sitta framför datorn och treva mig fram är ju som ett nyupptäckt hobby :-)!

Allt gott!

Trädvy Permalänk
Medlem
Plats
Under din säng!
Registrerad
Mar 2013

Hej på er!

Jag är jätte nybörjare min Linux Mint och har också behov av hjälp för att installera min Radeon HD 6870.

Jag försökte som på den här video men det är inte samma och jag har inte så mycket kunskap om Linux,

Är det någon som kan hjälpa mig?

Jag gick in på https://www.amd.com/en/support/graphics/amd-radeon-hd/amd-rad...
AMD Catalyst™ 15.9 Proprietary Ubuntu 14.04 x86_64 Video Driver for Graphics Accelerators
(Ubuntu x86 64-bit) och valde den förta länk men det gick inte, sedan försökte några andra men det blev ingen vidare.

Här är lite info om min PC, hoppas att det hjälper

Här blev det:
sudo dpkg -i fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb
[sudo] lösenord för smart:
Väljer tidigare ej valt paket fglrx.
(Läser databasen ... 295505 filer och kataloger installerade.)
Förbereder att packa upp fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb ...
Packar upp fglrx (2:15.201-0ubuntu1) ...
dpkg: beroendeproblem förhindrar konfigurering av fglrx:
fglrx är beroende av fglrx-core, men:
Paketet fglrx-core är ej installerat.
fglrx är beroende av libqtcore4 (>= 4:4.7.0~beta2), men:
Paketet libqtcore4 är ej installerat.

dpkg: fel vid hantering av paketet fglrx (--install):
beroendeproblem - lämnar okonfigurerad
Hanterar utlösare för systemd (237-3ubuntu10.25) ...
Hanterar utlösare för ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot
Hanterar utlösare för gnome-menus (3.13.3-11ubuntu1.1) ...
Hanterar utlösare för desktop-file-utils (0.23+linuxmint6) ...
Hanterar utlösare för mime-support (3.60ubuntu1) ...
Fel uppstod vid hantering:
fglrx

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

Den urgamla fglrx-drivrutinen används inte längre.
Mesa-drivrutinen som installeras automatiskt med Mint skall ha fullgott stöd.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Under din säng!
Registrerad
Mar 2013
Skrivet av FattarNiInte:

Den urgamla fglrx-drivrutinen används inte längre.
Mesa-drivrutinen som installeras automatiskt med Mint skall ha fullgott stöd.

Skickades från m.sweclockers.com

Ok DVS.... jag behöver inte göra ngt då eller hur?

En annan sak, spelar det roll vilken DVI port jag använder på grafikkortet?

På Drivrutinshanterarens fönster är tom och längst ner står Inga slutna drivrutiner används.

Trädvy Permalänk
Medlem
Plats
Kungsbacka
Registrerad
Aug 2006

@FattarNiInte: Får man inte en uråldrig version av mesa med ubuntu 18.04? Om inte Linux mint lagt in nyare version på sin installer.

Kör man debian/ubuntu based så får man dra in en PPA från Padoka eller Oibaf för att få senaste Mesa drivers till sin AMD (även intel?) gpu. Välj endast EN av nedanstående PPA, installation finns längre ner på sidorna.

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkpp...

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

ASUS Crosshair VI Hero -- AMD Ryzen 7 1700 -- AMD Vega 56 -- G.Skill 16GB 3200MHz CL14 -- Samsung 960 EVO 1TB -- Arch Linux

Trädvy Permalänk
Medlem
Plats
Under din säng!
Registrerad
Mar 2013
Skrivet av Kokefa:

@FattarNiInte: Får man inte en uråldrig version av mesa med ubuntu 18.04? Om inte Linux mint lagt in nyare version på sin installer.

Kör man debian/ubuntu based så får man dra in en PPA från Padoka eller Oibaf för att få senaste Mesa drivers till sin AMD (även intel?) gpu. Välj endast EN av nedanstående PPA, installation finns längre ner på sidorna.

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkpp...

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

GUD!!!! jag trodde att Linux skulle vara enklare men för mig är så mycket mer komplicerad.

Jag försöker att köra min Uplay kontot i en annan tråd och för att installera "A" måste jag installera packet "B" som på sin tur måste jag har paket "D" som kräver packet "E" och jag är redan på paket "X" och fick inte förbaskat shit igång... och de som är värst, INGEN tutorial jag testade från Youtube blir likadant som från alla videos, det är allting ngt som inte går som ska och blir liknande.

Jag gillar fortfarande Linux Mint men jag förstår att många som vägrar att migrera från Windows, det är mycket enklare.

Trädvy Permalänk
Medlem
Registrerad
Mar 2016
Skrivet av Kokefa:

@FattarNiInte: Får man inte en uråldrig version av mesa med ubuntu 18.04? Om inte Linux mint lagt in nyare version på sin installer.

Nja, det skall inte vara nåt problem. Gäller ju ett gammalt grafikkort utan vulkan och grejer.

Dock finns det en fördel med oibaf eller padoka, snabbt directx 9 inbakat i drivrutinen (gallium nine) om windowsspel skall spelas.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Sep 2017

Som jag förstått det så är drivrutinerna på AMDs hemsida att föredra "generellt". Jag kör mitt Radeon VII med dessa i Ubuntu utan problem (spelar dock ingenting då jag också dualbootar).

Trädvy Permalänk
Medlem
Registrerad
Sep 2017

@Reborn.swe: Kul att du inte låter dig avskräckas Men å andra sidan så är det samma sak som när Windows klagar på något .net eller annat bös som saknas...

Trädvy Permalänk
Medlem
Registrerad
Mar 2016
Skrivet av Reborn.swe:

GUD!!!! jag trodde att Linux skulle vara enklare men för mig är så mycket mer komplicerad..

Du skall _inte_ installera en drivrutin för ditt grafikkort

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Mar 2016
Skrivet av evirob:

Som jag förstått det så är drivrutinerna på AMDs hemsida att föredra "generellt". Jag kör mitt Radeon VII med dessa i Ubuntu utan problem (spelar dock ingenting då jag också dualbootar).

Det enda man vinner nuförtiden med amd:s officiella drivrutin är bättre opencl-stöd. Tex för Blender.
Generellt presterar dom sämre i spel än nyare utgåvor av mesa.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Under din säng!
Registrerad
Mar 2013
Skrivet av FattarNiInte:

Du skall _inte_ installera en drivrutin för ditt grafikkort

Skickades från m.sweclockers.com

OK då, ska inte röra det nu ska ja vända mig till sista försök att installera Uplay, allt finns i det här tråd, Kokefa är redan där och försöker hjälpa till.

Jag vill bara har en steg för steg som kommer att fungera via PlayonLinux, Wine, Lutris eller ngt annat , men det är aldrig samma sak och alltid en ny strul i något steg.

allt detta innan jag slänger dator mot väggen eller köper en Windows 10 licens