Trädvy Permalänk
Medlem
Registrerad
Sep 2011

Problem med DKIM (Postfix)

Hej,

Jag kör Debian och jag försöker sätta upp DKIM genom denna guide.

Problemet är att den inte hittar DNS-recordet av någon anledning.

sudo opendkim-testkey -d mcduckcorp.duckburg.cali -s mail -vvv

och detta blir resultatet:

opendkim-testkey: using default configfile /etc/opendkim.conf
opendkim-testkey: key loaded from /etc/mail/dkim.key
opendkim-testkey: checking key 'mail._domainkey.mcduckcorp.duckburg.cali'
opendkim-testkey: 'mail._domainkey.mcduckcorp.duckburg.cali' record not found

Om jag kör ett: dig mail._domainkey.mcduckcorp.duckburg.cali TXT så får jag ett svar under "ANSWER SECTION".

Såhär ser config-filerna ut:
/etc/opendkim.conf = https://pastebin.com/5svgGXQZ
/etc/default/opendkim = https://pastebin.com/RdrMGtu4
/etc/postfix/main.cf = https://pastebin.com/mcQA5iVz
dns.db = https://pastebin.com/2qVVbQLx

Jag har startat om opendkim, postfix och bind varje gång jag har gjort en ändring men det blir likadant.
Någon som har någon aning om vad det kan vara för fel?

Tack!

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Finns domänen mcduckcorp.duckburg.cali ?

Trädvy Permalänk
Medlem
Registrerad
Sep 2011
Skrivet av Meto:

Finns domänen mcduckcorp.duckburg.cali ?

Nope den är inte publik så vitt jag vet, det är en skoluppgift och detta är domänen som vi ska använda oss utav.

Trädvy Permalänk
Medlem
Registrerad
Jun 2019
Skrivet av Tydh:

Hej,

Jag kör Debian och jag försöker sätta upp DKIM genom denna guide.

Problemet är att den inte hittar DNS-recordet av någon anledning.

sudo opendkim-testkey -d mcduckcorp.duckburg.cali -s mail -vvv

och detta blir resultatet:

opendkim-testkey: using default configfile /etc/opendkim.conf
opendkim-testkey: key loaded from /etc/mail/dkim.key
opendkim-testkey: checking key 'mail._domainkey.mcduckcorp.duckburg.cali'
opendkim-testkey: 'mail._domainkey.mcduckcorp.duckburg.cali' record not found

Om jag kör ett: dig mail._domainkey.mcduckcorp.duckburg.cali TXT så får jag ett svar under "ANSWER SECTION".

Såhär ser config-filerna ut:
/etc/opendkim.conf = https://pastebin.com/5svgGXQZ
/etc/default/opendkim = https://pastebin.com/RdrMGtu4
/etc/postfix/main.cf = https://pastebin.com/mcQA5iVz
dns.db = https://pastebin.com/2qVVbQLx

Jag har startat om opendkim, postfix och bind varje gång jag har gjort en ändring men det blir likadant.
Någon som har någon aning om vad det kan vara för fel?

Tack!

Jag vet att vissa DNS-leverantörer historiskt haft problem med stora DKIM-nycklar. Vad händer om du bygger en 1024-bits DKIM-nyckel?
(Jag förutsätter att DNS-uppslag i sig fungerar och att du ser din DKIM-nyckel korrekt och inom ramarna för korrekt domän om du kör dig -t TXT mot din domän).

Trädvy Permalänk
Medlem
Registrerad
Sep 2011
Skrivet av Det Otroliga Åbäket:

Jag vet att vissa DNS-leverantörer historiskt haft problem med stora DKIM-nycklar. Vad händer om du bygger en 1024-bits DKIM-nyckel?
(Jag förutsätter att DNS-uppslag i sig fungerar och att du ser din DKIM-nyckel korrekt och inom ramarna för korrekt domän om du kör dig -t TXT mot din domän).

Är ganska okunnig inom detta, jag använde detta kommando för att bygga nycklarna: "opendkim-genkey -t -s mail -d mcduckcorp.duckburg.cali". Går det att ändra storleken direkt via kommandot?

Japp "dig" fungerar både mot mcduckcorp.duckburg.cali och mail._domainkey.mcduckcorp.duckburg.cali TXT.
Detta är resultatet av dig mail._domainkey.mcduckcorp.duckburg.cali TXT:

; <<>> DiG 9.11.5-P4-5.1-Debian <<>> mail._domainkey.mcduckcorp.duckburg.cali TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56436
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 471ab9fc06350d3dd7798fde5d9e05d22898a895b87ab607 (good)
;; QUESTION SECTION:
;mail._domainkey.mcduckcorp.duckburg.cali. IN TXT

;; ANSWER SECTION:
mail._domainkey.mcduckcorp.duckburg.cali. 2592000 IN TXT "v=DKIM1; h=sha256; k=rsa; t=y; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ" "8AMIIBCgKCAQEAz2/ZfhxSI/Abqgh0amM8ylrlosirWeKShUhq7fg12aYmRwOqq" "9hIzO0Fcz1BzfgHVu6HU++rC5QoUK0JQK/nk4jwkDgvG2di2ZYmAvEbY/VeiK1x" "/TG0p1Iczr2k6Bj0gEAb/YGD2YbwrwAi4bDXwoPsYuuNn9TB3jjyWKu/dvOsqhf" "f1/4Wc+FkOi0ClvgrXiklN28XTLjyjSyU794ntIoegXxrfwcwkhfPMvuqcnhfIC" "0Z8L71M4WR4SoHyNHVfBtNlUvVNROiXlMxtxnNQvfViSwz6LC8bYIxeAba3hSXP" "TChKu3qZtfR0o3jFwEWAfLQdgIxler0jMEoAyJmfQIDAQAB"

;; AUTHORITY SECTION:
mcduckcorp.duckburg.cali. 2592000 IN NS ns1.mcduckcorp.duckburg.cali.

;; ADDITIONAL SECTION:
ns1.mcduckcorp.duckburg.cali. 2592000 IN A 192.168.1.10

;; Query time: 2 msec
;; SERVER: 192.168.1.10#53(192.168.1.10)
;; WHEN: Wed Oct 09 18:07:46 CEST 2019
;; MSG SIZE rcvd: 575

Trädvy Permalänk
Medlem
Registrerad
Jun 2019

@Tydh:
kör opendkim-genkey --help, så finns det säkert en parameter du kan ange för att sätta en specifik nyckelstorlek. Gissar att det kan vara så enkelt som "-b 1024" utan att ha programmet framför mig.

Trädvy Permalänk
Medlem
Registrerad
Jun 2019

@Tydh:
Har du förresten satt korrekta filsystemsrättigheter på den privata nyckeln för DKIM? Om inte opendkim-användaren kan läsa den (och anser att den är privat), så kommer du garanterat att få problem...

Trädvy Permalänk
Medlem
Registrerad
Sep 2011
Skrivet av Det Otroliga Åbäket:

@Tydh:
kör opendkim-genkey --help, så finns det säkert en parameter du kan ange för att sätta en specifik nyckelstorlek. Gissar att det kan vara så enkelt som "-b 1024" utan att ha programmet framför mig.

Ah det var ganska enkelt ja! Körde detta opendkim-genkey -b 1024 -t -s mail -d mcduckcorp.duckburg.cali och bytte ut nycklarna. Blir tyvärr samma error-meddelande att den inte hittar något record.

Trädvy Permalänk
Medlem
Registrerad
Sep 2011
Skrivet av Det Otroliga Åbäket:

@Tydh:
Har du förresten satt korrekta filsystemsrättigheter på den privata nyckeln för DKIM? Om inte opendkim-användaren kan läsa den (och anser att den är privat), så kommer du garanterat att få problem...

Hmm känner inte igen att jag har gjort det. Tänkte du att man använder chown och chgrp?

*EDIT*
Körde "sudo chown opendkim:opendkim mail.private", fortfarande likadant tyvärr.