Forumdelen sponsras av

Chromecast via Hdmi audio extractor - Får helknasiga färger

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Dec 2008

Chromecast via Hdmi audio extractor - Får helknasiga färger

Hej allesammans!

Har nyligen satt upp en projektor hemma där jag tänkt använda mig av en Chromecast för att lätt och smidigt kunna casta Netflix, Youtube etc. Projen är en Epson TW3200 och denna har ingen separat ljudutgång utan endast bild in via t.ex. HDMI.

Så för att kunna få ut ljudet från Chromecasten och in till min förstärkare så har jag köpt mig en "Hdmi audio extractor" för att separera bild och ljud, se länk.
https://www.teknikdelar.se/4k-hdmi-extractor-for-ljud-och-bil...

Mycket smidig produkt som fungerar klockrent när jag kopplar in min dator i den eller ett Nintendo switch men ICKE med min Chromecast - färgerna blir helt bananas.. se bilder.
Om jag kopplar in Chromecasten direkt i projen så ser färgerna ut som vanligt, någonting blir alltså galet när jag kör Chromecast -> Hdmi audio extractor -> projektor.
Har provat med olika HDMI kablar och även att ändra färginställningarna i projektorn men ingenting verkar hjälpa. Hittar heller inga relevanta inställningar till Chromecasten i Google Home appen. Dessutom verkar den göra någon sorts downscaling då upplösningen endast blir 1280x720? Någon som har en susning om vad det kan vara för fel?

Intel i5 4670K -> Antec Kühler 620 | Asus Z87 Pro | Corsair XMS3 4x2Gb 1600Mhz | 2x Gigabyte WF 670 2GB SLI | XFX PRO 850W | Samsung 830 256 GB | 2 st WD caviar black 640 GB | NZXT phantom vit | Acer 23,6" LCD GD245HQAbid + Nvidia 3D vision

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Mrheadbanger: Färgerna är skolexempel på vad som händer när YCbCr-data forceras in i en RGB-färgrymd. Har exempel på det här: https://www.sweclockers.com/artikel/22077-bildanslutningar-de...

Det kan alltså vara din förstärkare som bråkar. Men också extraktorn som inte gillar en äldre förstärkares HDCP-svar och därför tar ned upplösningen. Vad är det som hindrar att du kör chromecasten rätt in i förstärkaren? Avsaknad av 4K och HDCP 2.2?

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Dec 2008

@Laxpudding
Förstärkaren jag kör med i nuläget har ingen HDMI ingång, därav jag är tvungen att köra splittern för att få ut ljudet till annat format.

Tack för ett sådant välformulerat och intressant svar! Läste vidare i den otroligt matiga guiden du länkade och där stod det mycket riktigt en hel del om detta fenomen.
Det jag inte riktigt förstår är varför detta fenomen endast uppstår mellan Chromecasten (gen2) och extractor boxen? Jag har ingen möjlighet att ändra mellan RGB och YCbCr vare sig i Chromecasten eller extractorn för att kunna korrigera felet?

Skickades från m.sweclockers.com

Intel i5 4670K -> Antec Kühler 620 | Asus Z87 Pro | Corsair XMS3 4x2Gb 1600Mhz | 2x Gigabyte WF 670 2GB SLI | XFX PRO 850W | Samsung 830 256 GB | 2 st WD caviar black 640 GB | NZXT phantom vit | Acer 23,6" LCD GD245HQAbid + Nvidia 3D vision

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Dec 2008

@Laxpudding

Har knappat runt lite bland inställningarna i projektorn och jag kan inte ändra färgrymd eller växla mellan RGB / YCbCr vad jag kan se.
Kan däremot göra en hel del färgjusteringar av bilden men av vad jag provat så tycker jag inte att det blir någon direkt skillnad. Finns det något sätt att komma runt detta?

Skickades från m.sweclockers.com

Intel i5 4670K -> Antec Kühler 620 | Asus Z87 Pro | Corsair XMS3 4x2Gb 1600Mhz | 2x Gigabyte WF 670 2GB SLI | XFX PRO 850W | Samsung 830 256 GB | 2 st WD caviar black 640 GB | NZXT phantom vit | Acer 23,6" LCD GD245HQAbid + Nvidia 3D vision

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Mrheadbanger: Du har en inställning hos epsons projektorer där du har HDMI-inställningarna, där du också kan välja färgrymd mellan "Auto", "RGB" och "YCbCr" (eller hur de nu skriver detta i menyerna)

Men felet ligger nog främst i själva extractorn som inte hanterar EDID på rätt sätt vilket får Chromecast att skicka en viss informatio eftersom Chromecasten aldrig "ser" projektorn i andra änden, endast vad extractorn talar om för den. Sedan återsände extractorn bilden felflaggad. Det kommer YCbCr-data men flaggas som RGB-data och Epson lyssnar med "auto" på vad som flaggas i EDID. Detta är vad gissar är orsaken då Chromecast fungerar normalt direkt in i projektorn.