Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Raid 0 failure efter clear CMOS. Båda diskarna syns i BIOS, bara en är med i raiden.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

Raid 0 failure efter clear CMOS. Båda diskarna syns i BIOS, bara en är med i raiden.

Stötte på lite problem med min dator imorse, och ska försöka förklara vad jag gjort och vad som var fel.

Problem 1 (fixad). Första problemet var att datorn inte startade alls, inga lampor lyste upp, fläktarna rörde sig inte när jag försökte starta datorn. Detta problem överkom jag efter ett litet tag genom att cleara CMOS.
Efter detta startade datorn.

Problem 2 (fixad). Nästa problem var att datorn frös under uppstart. Det var vid laddningsskärmen som datorn frös. Detta löste jag genom att ändra bootordern, windows boot manager låg först, detta ändrade jag till att min SSD med Windows i låg först. Det löste det problemet.

Problem 3. Nästa problem var att min raid 0 failade. Under booten så kommer Intel rapid storage skärmen upp där den visar vilka hårddiskar som är i raid. Här var raid 0 fail, och av de två hårddiskar som var med i denna raid så var det en som funkade och den andra stod som att den inte var med i raiden.

Sökte lite på google, och hittade en konfigurations guide till raid från ASUS (som mitt moderkort är). Där stod det att vid bios reset så måste man ändra om från ACHI till RAID i bios (detta var redan inställt på RAID för mig). Och att man skulle ändra Boot > CSM (Compability support module) > Launch CSM till disabled. Vilket jag gjorde.

Så de problem jag behöver hjälp med här är:
Båda diskarna syns i bios. Notera att en av diskarna nämns som 0.4 och en som 0.5. Så man ser skillnad på dem.

Såhär ser raiden ut just nu, bara en disk är med. Disk 0.4 är det som fortfarande finns med i raiden.

Så här ser det ut i Intel rapid storage inställningarna i bios.

Raiden är failad. Min SSD syns som non raid, som den ska. Men även en av raid diskarna syns som non raid. Detta är då disk 0.5. Medans disk 0.4 fortfarande syns i raiden.

Så det jag har lyckats lista ut genom Google är att eftersom båda mina diskar fortfarande fungerar och syns i bios, så kan jag använda någon raid recovery mjukvara för att få tillbaka innehållet. Men jag ville inte påbörja något utan att få lite input, vill inte råka göra något jag inte borde göra.

Om det är någon mer information som behövs eller om jag har förklarat något dåligt så är det bara att säga till!

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Om du inte har en backup att återställa från är din bästa chans att boota Ubuntu och försöka laga den med mdadm. https://www.digitalocean.com/community/tutorials/how-to-manag...

Själv skulle jag bitit i det sura och återskapat nollan och sen lagt tillbaks från backup - för sådan har jag, plentiful, vis av erfarenheter.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010
Skrivet av hasenfrasen:

Om du inte har en backup att återställa från är din bästa chans att boota Ubuntu och försöka laga den med mdadm. https://www.digitalocean.com/community/tutorials/how-to-manag...

Själv skulle jag bitit i det sura och återskapat nollan och sen lagt tillbaks från backup - för sådan har jag, plentiful, vis av erfarenheter.

Tack för svar! Linux kan jag inget om, så det skipper jag helst.

Kom över en annan fix som verkar vara ganska specifikt för min situation.

https://blog.quindorian.org/2013/07/repair-incorrectly-report...

Så jag kommer nog testa detta om inga andra tips kommer in.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2001

Jag har använt hiren bootcd om en disk har "trillat" ur RAID arrayen. Detta har gjort att jag snabbt kunna starta upp min RAID-0 array-igen utan någon rekonstruering eller liknande.

Om du inte lyckas få ihop RAIDen, så kan RAID Reconstructor (Runtime Software) läsa ut datan och sätta ihop den från diskarna. Detta gjorde jag med gott resultat med RAID-0 bestående av fyra raptordiskar.

Personligen slutade jag med RAID-0 i konsumentlösningar efter SSD-övergången, då jag inte tycker det är tillräckligt pålitligt. Diskras var en felkälla jag hade räknat med, men inte RAID-problem i sig.

Ubuntu | 1440p IPS | 7700k | 1080ti | 32GB@3.6GHz | 960 Pro 1TB
MBP 13" Retina 2014 | iPhone 7+

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

Jag har löst problemet nu, och vill tacka för hjälpen jag fått!

Detta var lösningen jag följde: https://blog.quindorian.org/2013/07/repair-incorrectly-report...

Så om någon stöter på samma problem med att en av diskarna "puttas" ur RAIDen och visas som non-member disk pga bios uppdatering eller i mitt fall clear CMOS, så kan man följa dessa steg, det var en väldigt enkelt fix i slutändan!

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av Kablash:

Jag har löst problemet nu, och vill tacka för hjälpen jag fått!

Detta var lösningen jag följde: https://blog.quindorian.org/2013/07/repair-incorrectly-report...

Så om någon stöter på samma problem med att en av diskarna "puttas" ur RAIDen och visas som non-member disk pga bios uppdatering eller i mitt fall clear CMOS, så kan man följa dessa steg, det var en väldigt enkelt fix i slutändan!

Kul att det löste sig, och bra att du uppdaterade med svar.
Ironiska är:
"Linux kan jag inget om, så det skipper jag helst."
Och det var Test-disk du använde i Linux prompt för det ändå

Så frukta inte Linux för du är osäker, utan hitta en bra guide med det bara, så har du ofta möjligheten att lösa saker som annars är svårt.

Du hade troligen kunnat använda andra recovery-program i detta fallet dock, men guiden du följde gjorde det enkelt.

Test-Disk är faktiskt ett kanonbra linux verktyg för att återställa info från halvtrasiga diskar också.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2007
Skrivet av Kablash:

Jag har löst problemet nu, och vill tacka för hjälpen jag fått!

Detta var lösningen jag följde: https://blog.quindorian.org/2013/07/repair-incorrectly-report...

Så om någon stöter på samma problem med att en av diskarna "puttas" ur RAIDen och visas som non-member disk pga bios uppdatering eller i mitt fall clear CMOS, så kan man följa dessa steg, det var en väldigt enkelt fix i slutändan!

Skönt att det löste sig, skulle nu rekommendera att du tar en backup också på allt viktigt.

|| Cooler Master MasterCase Pro 5 || AMD Ryzen 7 1700 || AMD Wraith Spire ||
|| ASUS Prime B350-Plus || Corsair Vengeance LPX DDR4 3000MHz 32GB ||
|| GTX 970 4GB G1 GAMING ||
|| Corsair SSD Force GT 120GB || Samsung SSD 840 EVO 250GB ||
||Samsung SSD 850 EVO 500GB || Western Digital Green 1TB ||

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010
Skrivet av Paddanx:

Kul att det löste sig, och bra att du uppdaterade med svar.
Ironiska är:
"Linux kan jag inget om, så det skipper jag helst."
Och det var Test-disk du använde i Linux prompt för det ändå

Så frukta inte Linux för du är osäker, utan hitta en bra guide med det bara, så har du ofta möjligheten att lösa saker som annars är svårt.

Du hade troligen kunnat använda andra recovery-program i detta fallet dock, men guiden du följde gjorde det enkelt.

Test-Disk är faktiskt ett kanonbra linux verktyg för att återställa info från halvtrasiga diskar också.

Haha jaså, det visste jag inte. Du kanske har rätt, jag borde nog inte frukta Linux

Skrivet av Nepo:

Skönt att det löste sig, skulle nu rekommendera att du tar en backup också på allt viktigt.

Jag håller på med det just nu! ^^

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2002
Skrivet av Paddanx:

Kul att det löste sig, och bra att du uppdaterade med svar.
Ironiska är:
"Linux kan jag inget om, så det skipper jag helst."
Och det var Test-disk du använde i Linux prompt för det ändå

Så frukta inte Linux för du är osäker, utan hitta en bra guide med det bara, så har du ofta möjligheten att lösa saker som annars är svårt.

Du hade troligen kunnat använda andra recovery-program i detta fallet dock, men guiden du följde gjorde det enkelt.

Test-Disk är faktiskt ett kanonbra linux verktyg för att återställa info från halvtrasiga diskar också.

Jag hade nog reagerat på samma sak om någon bad mig boota från Ubuntu då mina kunskaper är noll. Jag tolkar det som att installera Linux på datorn med distributionen Ubuntu. Det låter alltså som jag behöver installera ett helt operativsystem från grunden för att utföra en åtgärd på en disk. Om jag själv tolkar det som att åtgärden jag behöver göra borde vara mindre komplicerad än så kommer jag givetvis förkasta idén.

Grovt jämfört, "Jag har problem med en drivrutin som krånglar, ibland fungerar inte mitt tangentbord" och någon föreslår att man ska installera om Windows för att lösa problemet. Inte superbra jämförelse, men var mer tidsaspekten jag syftade till

..:: trickeh2k ::.. https://youtube.com/c/trickeh2k Windows 10 Pro - i7 8700k (delid) @ 5Ghz - ASUS Prime Z370-A - 16GB G.Skill Trident Z DDR4 CL14 3000Mhz - Corsair AX860i - EVGA GTX 1080Ti FTW3 Hydrocopper - Acer Predator XB271HU - ASUS VG248QE - QPAD MK-85 (MX-Brown)/SteelSeries Sensei RAW Rubberized - Samsung 960 EVO 250GB, Samsung EVO 860 500GB, SanDisk Ultra II 480GB, 3TB Seagate Barracuda - ASUS Xonar DX - ASUS Strix 7.1 Gaming Headset - Corsair 750D - Custom water loop

Trädvy Permalänk
Medlem
Plats
Motala
Registrerad
Sep 2004

Jag har liknande problem med att raiden failar varje gång jag uppdaterar BIOS på Asus Z87.
Nu var det några år sedan jag behövde uppdatera bios.
Jag löste det varje gång, men det var sjukt störande och berodde på en bugg som som ASUS aldrig åtgärdade.
Jag kommer inte riktigt ihåg detaljerna, men jag har för mig att jag fick skapa om raiden och sen köra någon CLI för att återställa filerna, vilket som tur är gick utan att bli av med några filer.
Det här gällde då Raid0 på Windows partitionen.

Skönt att det löste sig, ville bara tillägga att du inte är ensam om problemet☺

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Där solen aldrig skiner
Registrerad
Sep 2002

@trickeh2k: Det skadar aldrig med en bootbar USB innehållande Ubuntu eller liknande. Behöver inte formatera om befintlig hårddisk eller liknande samtidigt som det öppnar för felsökning oberoende av Windows.

Rent generellt tycker jag Debian och Linux Mint varit mycket enklare och snabbare att installera än Windows 10. Några klick och ange lösenord så är det färdigt.

MSI K9N SLI Diamond | MSI Diamond HDMI 7600GT | AMD X2 4200+ | 1GB Kingston HyperX| 32" LG 5000:1 screen | Asus EeePC 701

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2002
Skrivet av Opatagio:

@trickeh2k: Det skadar aldrig med en bootbar USB innehållande Ubuntu eller liknande. Behöver inte formatera om befintlig hårddisk eller liknande samtidigt som det öppnar för felsökning oberoende av Windows.

Rent generellt tycker jag Debian och Linux Mint varit mycket enklare och snabbare att installera än Windows 10. Några klick och ange lösenord så är det färdigt.

Förutsätter inte det att du kan grundläggande kommandon för respektive dist? Värsta som finns när man har något hårdvarurelaterat och försöker lösa det i uefi och att googla på telefonen. Det går, men det är osmidigt och tar tre ggr så lång tid.

..:: trickeh2k ::.. https://youtube.com/c/trickeh2k Windows 10 Pro - i7 8700k (delid) @ 5Ghz - ASUS Prime Z370-A - 16GB G.Skill Trident Z DDR4 CL14 3000Mhz - Corsair AX860i - EVGA GTX 1080Ti FTW3 Hydrocopper - Acer Predator XB271HU - ASUS VG248QE - QPAD MK-85 (MX-Brown)/SteelSeries Sensei RAW Rubberized - Samsung 960 EVO 250GB, Samsung EVO 860 500GB, SanDisk Ultra II 480GB, 3TB Seagate Barracuda - ASUS Xonar DX - ASUS Strix 7.1 Gaming Headset - Corsair 750D - Custom water loop

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av trickeh2k:

Jag hade nog reagerat på samma sak om någon bad mig boota från Ubuntu då mina kunskaper är noll. Jag tolkar det som att installera Linux på datorn med distributionen Ubuntu. Det låter alltså som jag behöver installera ett helt operativsystem från grunden för att utföra en åtgärd på en disk. Om jag själv tolkar det som att åtgärden jag behöver göra borde vara mindre komplicerad än så kommer jag givetvis förkasta idén.

Grovt jämfört, "Jag har problem med en drivrutin som krånglar, ibland fungerar inte mitt tangentbord" och någon föreslår att man ska installera om Windows för att lösa problemet. Inte superbra jämförelse, men var mer tidsaspekten jag syftade till

Kan förstå att du tänker så, men detta är faktiskt fördelen med Linux, du kan köra det på ett USB minne, ofta i en sk "LIVE" miljö, dvs helt utan att installera något.

Windows har en sådan miljö också, den används när du installerar Windows, och har ibland används som recovery system också.

Men håller med att lite tydligare info kunde getts så du förstod detta

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2002
Skrivet av Paddanx:

Kan förstå att du tänker så, men detta är faktiskt fördelen med Linux, du kan köra det på ett USB minne, ofta i en sk "LIVE" miljö, dvs helt utan att installera något.

Windows har en sådan miljö också, den används när du installerar Windows, och har ibland används som recovery system också.

Men håller med att lite tydligare info kunde getts så du förstod detta

Ja, det går ju inte att förneka hur smidigt och bra det är, förutsatt att man har lite baskunskaper Får väl se till att plugga in dessa, bra att ha som lösning om det skulle skita sig i framtiden

..:: trickeh2k ::.. https://youtube.com/c/trickeh2k Windows 10 Pro - i7 8700k (delid) @ 5Ghz - ASUS Prime Z370-A - 16GB G.Skill Trident Z DDR4 CL14 3000Mhz - Corsair AX860i - EVGA GTX 1080Ti FTW3 Hydrocopper - Acer Predator XB271HU - ASUS VG248QE - QPAD MK-85 (MX-Brown)/SteelSeries Sensei RAW Rubberized - Samsung 960 EVO 250GB, Samsung EVO 860 500GB, SanDisk Ultra II 480GB, 3TB Seagate Barracuda - ASUS Xonar DX - ASUS Strix 7.1 Gaming Headset - Corsair 750D - Custom water loop