Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Forumdelen sponsras av

Problem med DP-ingång (ingen signal) vid start, samt kalibreringsproblem

Trädvy Permalänk
Medlem
Registrerad
Aug 2019

Problem med DP-ingång (ingen signal) vid start, samt kalibreringsproblem

Hej,

Köpte en begagnad skärm för en tusenlapp i förrgår. Det är en 24" Benq XL2420z på 1080 med 144Hz
https://www.inet.se/produkt/2205180/benq-24-xl2420z-led-144hz?gclid=EAIaIQobChMI8-WX7uDf5QIVG8ayCh0ZUgB7EAAYASAAEgIJhfD_BwE

Problem:
Nu efter lite användning har jag upptäckt diverse problem. När jag startar skärmen så känner ej skärmen av att det kommer någon signal från datorn, och jag måste dra ut och sätta i DP-kabeln för att den ska hitta signal och då fungerar det. Det brukar fungera också om jag bara låter skärmen vara i viloläge (d.v.s. bara låter bli att stänga av den).
Förra ägaren körde bara med DVI-kabel och då fungerade det.

Köpte den här DP-kabeln från Kjell & CO, så tror samtidigt inte att det är något fel på kabeln.
https://www.kjell.com/se/produkter/ljud-bild/kablar-adaptrar/displayport/displayport-kablar/displayport-kabel-2-m-p97950

Någon som vet vad det kan röra sig om? Känner att det blir jobbigt att krypa ner och dra ut och in en sladd varje gång jag ska starta datorn. Även ibland när jag ändrar på inställningar (t.ex byter Hz i Windows) så kommer det upp en ruta från själva OSD som säger "Signal utanför intervall" (löses även det genom att dra ut och sätta tillbaka DP-kabeln). Går det att få datorn att skanna av olika inputs automatiskt vid start tro?

Saker jag har testat:
-Dra ut strömsladden och koppla ur i några minuter.
-Testat med DVI-kabel med hdmi adapter (då min GPU RTX 2070 saknar uttag för DVI), vilket fungerade men måste ha DP-kabel för 144Hz.
-Dra ut den andra skärmen (TV:n kopplad via HDMI).
-Återställa skärmens inställningar via OSD
-Raderat och återinstallerat "generic monitor pnp"

Jag har även stött på problem när jag ska kalibrera skärmens färger. Så fort jag försöker kalibrera via Windows och ändra något (t.ex gamma) samt köra Windows egna kalibrerade färgprofil i it.ex (color management), så ändrar Windows automatiskt tillbaka till standardinställningarna så fort jag klickar någonstans utanför. Även när jag är inne i Nvidias kontroll panel och ändrar på brightness eller t.ex gamma så ändrar det tillbaka till originalinställningarna automatiskt oavsett om jag tryckt på "apply" eller inte. Har dock nu lyckats ladda ner en färgprofil från Internet som jag är hyfsat nöjd med (och fått att fungera) Men det ska ju kunna gå och ändra som man vill, inte sant? Vad tror ni problemet kan vara?

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@errkan13: Testa med en certifierad kabel där du är säker på att pinne20 inte är kopplad. Beteendet förekommer ofta i det fallet. Går igenom valet av kabel här: https://www.sweclockers.com/artikel/27577

Annars är det generellt en del sådana svart-skärm-vid-start-problem för många äldre produkter med Displayport. En lösning som fungerar i många fall är då att köra med en strömbrytare till skärmen.

Trädvy Permalänk
Medlem
Registrerad
Aug 2019
Skrivet av Laxpudding:

@errkan13: Testa med en certifierad kabel där du är säker på att pinne20 inte är kopplad. Beteendet förekommer ofta i det fallet. Går igenom valet av kabel här: https://www.sweclockers.com/artikel/27577

Annars är det generellt en del sådana svart-skärm-vid-start-problem för många äldre produkter med Displayport. En lösning som fungerar i många fall är då att köra med en strömbrytare till skärmen.

Såg nu att det fanns en fastnålad tråd längst uppe på forumssidan om just pin 20 och hur den kunde ställa till med problem, och rent av skada datorn.
Men vidare i tråden hittade jag en snubbe som hade köpt precis samma kabel och han hade jag citerar:
"Tejpade ändarna parallellt. Mätte pin 20 och den ger inget utslag på multimetern."
Så antar att kabeln alltså inte är kopplad på pin 20 (vilket jag antar är positivt?)? Borde i för sig mäta min kabel för det kanske skiljer sig individuellt mellan likadana kablar?

Tack för tipset! Men kör jag med en strömbrytare borde väl skärmen dö och viloläget dö ut (vilket också leder till att jag får koppla in och ut kabeln)?

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013
Skrivet av errkan13:

Tack för tipset! Men kör jag med en strömbrytare borde väl skärmen dö och viloläget dö ut (vilket också leder till att jag får koppla in och ut kabeln)?

Kanske. Problemet brukar annars vara att väcka skärmen ur viloläget.