Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Hjälp, spelen låser sig!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

Hjälp, spelen låser sig!

Hej, jag köpte ett Asus 2060 RTX Dual (6GB 0db) och de flesta spelen låser sig men andra funkar?

Så här har jag felundersökt
1. Satte i kortet i datorn (PSU på 750W)
2. Installerade DCH drivrutiner och Geforce Experience
3. Overwatch och Doom 2016 fungerade men följande spel startar och börjar ladda men sen fryser de: Battlefield V, Battlefield 1, Doom Eternal, Battlefront 2, Apex Legends
4. Jag kontaktade Asus och Bethesda och fick instruktioner att avinstallera allt, köra AMD Clean Tool (som startar om Windows i felsäkert läge). När allt var avinstallerat fungerade fortfarande Overwatch och Doom 2016. Battlefront 2 har fortfarande samma problem av att starta, börjar ladda men sen låser sig
5. Installerade drivrutiner och Geforece Experience. Men fortfarande samma fel. Overwatch och Doom 2016 funkar men andra spel laddar och låser sig.

Det verkar som om Overwatch och Doom 2016 inte behöver drivrutiner och att oavsett om de är installerade låser sig mina andra spel.

Mina specifikationer:
- AMD Ryzen 7 3700X
- Corsair Force MP600 SSD M.2
- ASUS ROG Strix X570-F Gaming
- Corsair 16GB DDR4 3600MHz
- Windows 10 (uppdaterat)
- GeForce Game Ready Driver 445.75 (senaste)

Om ni har några förslag, kommentera! Jag kommer antagligen reklamera.

Tack,
Carl

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

Felmeddelanden från spel är DXGI_ERROR_DEVICE_HUNG och DXGI_ERROR_DEVICE_REMOVED

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Aug 2009

Jag gissar att du sett till att ström osv är kopplat
Men köra "AMD Clean Tool" när det verkar vara ditt grafikkort (drivrutiner till det) som strular känns ju lite sådär. Du nämner ingenting om ifall detta är en nybyggd dator, ren installation osv. Om du haft ett annat grafikkort tidigare så hade jag kört Display Driver Uninstaller (DDU) och sett till att rensa möjliga gamla filer från drivrutiner ordentligt. Sedan installera de senaste drivrutinerna.
Att några få spel fungerar låter skumt, men skulle tex kunna vara spel som kör Vulkan som funkar och DirectX strular? Dock har jag inte för mig att Overwatch stödjer Vulkan så då faller den tanken.

Gigabyte Aorus Master | 32gb DDR4 3466MHZ CL14 | Ryzen 3950X | 1080Ti
Asus Z97 Pro Gamer | 32gb ram DDR3 2400MHz | i7 4790k | 2 x R9 390 - Barnen fått ta över
Asrock P67 Extreme4 rev3 | 16gb DDR3 2400MHz | i7 2600K | R9 290 - Barnen fått ta över
En massa bärbara, servrar, RPi's och andra boxar

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

prova att installera DirectX separat.. Tror det är någon jävla Legacy grej som spökar
https://www.microsoft.com/en-us/download/details.aspx?id=35&r...

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Aug 2009
Skrivet av AIMMOTH:

Felmeddelanden från spel är DXGI_ERROR_DEVICE_HUNG och DXGI_ERROR_DEVICE_REMOVED

Utifrån de felmeddelandena så verkar du inte vara ensam.

Folk talar om en workaround där man ändrar recovery level. Vet inte om det löser ditt problem, men sett flera posts från olika människor som haft samma felmeddelande och sagt de hittat en lösning och gjort just detta.

1) Go To Windows Search
2) Search Regedit
3) Right click and select run as administrator
4) Opne HKEY_LOCAL_MACHINE
5) Open SYSTEM
6) Open CurrentControlSet
7) Open Control
8) Click GraphicsDrivers
9) Right Click And Select New In Windows Registry
10) Select DWORD (32-bit) Value
11) Type TdrLevel (Write it exactly T and L should be capital)
12) Double click on TdrLevel
13) Make sure value data is 0
14) Now restart your pc

Lite förklaring: https://support.allegorithmic.com/documentation/spdoc/gpu-dri...

Gigabyte Aorus Master | 32gb DDR4 3466MHZ CL14 | Ryzen 3950X | 1080Ti
Asus Z97 Pro Gamer | 32gb ram DDR3 2400MHz | i7 4790k | 2 x R9 390 - Barnen fått ta över
Asrock P67 Extreme4 rev3 | 16gb DDR3 2400MHz | i7 2600K | R9 290 - Barnen fått ta över
En massa bärbara, servrar, RPi's och andra boxar

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

@inquam: Tyvärr funkade inte det. Om värdet var satt till 0 låste sig spelen snabbare och det gick inte att gå ut till Windows. Till slut startade datorn om. När jag satte värdet till 60 var det samma beteende som tidigare. Testade också med båda värdena. Tack ändå!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

@inquam: Datorn har jag byggt själv. Mitt tidigare grafikort var AMD R9 280x som fungerade bra. Så det jag gjorde nu var bara att ersätta den med mitt nya grafikkort.
Jag testade Guru3Ds DDU i felsäkert läge och det positiva är att den rensade bort allt. Så när jag startade Overwatch hade den ingen hårdvaruacceleration och det var pixlig slö grafik. Doom 2016 startade inte heller. Så det tyder på att datorn var ren. Sen installerade jag dock drivrutiner och Geforce Experience och det blev som tidigare. Overwatch och Doom 2016 funkar, men inte andra spel (de låser sig vid laddning). Tack ändå!

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2002
Skrivet av AIMMOTH:

@inquam: Datorn har jag byggt själv. Mitt tidigare grafikort var AMD R9 280x som fungerade bra. Så det jag gjorde nu var bara att ersätta den med mitt nya grafikkort.
Jag testade Guru3Ds DDU i felsäkert läge och det positiva är att den rensade bort allt. Så när jag startade Overwatch hade den ingen hårdvaruacceleration och det var pixlig slö grafik. Doom 2016 startade inte heller. Så det tyder på att datorn var ren. Sen installerade jag dock drivrutiner och Geforce Experience och det blev som tidigare. Overwatch och Doom 2016 funkar, men inte andra spel (de låser sig vid laddning). Tack ändå!

Avinstallerade du både nvidia och amd-drivare i felsäkert läge? Efter att du gjort det skulle jag rekommendera att du installerar om dx11 och dx12.

Edit, testa även äldre drivrutiner än de allra senaste. Skulle också kunna vara en idé att kika på om det finns ny firmware för moderkortet.

..:: trickeh2k ::.. https://youtube.com/c/trickeh2k Windows 10 Pro - i7 8700k (delid) @ 5Ghz - ASUS Prime Z370-A - 16GB G.Skill Trident Z DDR4 CL14 3000Mhz - Corsair AX860i - EVGA GTX 1080Ti FTW3 Hydrocopper - Acer Predator XB271HU - ASUS VG248QE - QPAD MK-85 (MX-Brown)/SteelSeries Sensei RAW Rubberized - Samsung 960 EVO 250GB, Samsung EVO 860 500GB, SanDisk Ultra II 480GB, 3TB Seagate Barracuda - ASUS Xonar DX - ASUS Strix 7.1 Gaming Headset - Corsair 750D - Custom water loop

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2009

Har du testat gjort en hel nyinstallation av Windows och alla drivrutiner?

Chassi: Fractal Design Define R3 Black, Mobo: ASUS Z170 Pro Gaming, CPU: Intel i7 6700K, kylning CM Hyper 212 EVO, RAM: 32 GB Hyper X 3000 mhz, GPU: Nvidia MSI 1080 Gaming X, PSU: XFX Core Edition Pro 750W, Mus: Logitech G700, Tgb: Corsair Raptor K30, OS: Win10

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

@xmmm: Ingen förbättring tyvärrr. Tack ändå

Trädvy Permalänk
Medlem
Registrerad
Aug 2003

Varför skulle du behöva köra AMD cleanup tool?

Knappast så att chipset drivers stör, kör DDU även efter nyinstallerat, avinstallera alla AMD/Nvidia drivers med den, installera nya chipset drivers.

Därefter nya Nvidia drivers utan Geforce Experience till en början så du kan utesluta det, testa 1-2 versioner äldre också.

Sen kan det vara något helt annat, minnesklock som är instabil eller kass biosversion eller t.o.m defekt nätaggregat.

Kör lite benchmarks som belastar en komponent åt gången, Furmark, Prime 95, memtest.

Trädvy Permalänk
Medlem
Plats
Karlskrona
Registrerad
Aug 2009
Skrivet av AIMMOTH:

@inquam: Datorn har jag byggt själv. Mitt tidigare grafikort var AMD R9 280x som fungerade bra. Så det jag gjorde nu var bara att ersätta den med mitt nya grafikkort.
Jag testade Guru3Ds DDU i felsäkert läge och det positiva är att den rensade bort allt. Så när jag startade Overwatch hade den ingen hårdvaruacceleration och det var pixlig slö grafik. Doom 2016 startade inte heller. Så det tyder på att datorn var ren. Sen installerade jag dock drivrutiner och Geforce Experience och det blev som tidigare. Overwatch och Doom 2016 funkar, men inte andra spel (de låser sig vid laddning). Tack ändå!

Synd... Ja, har du haft ett AMD kort och byter till Nvidia eller tvärtom så är det verkligen rekommenderat att rensa ordentligt med DDU.
Har du provat en äldre drivrutin från Nvidia för att utesluta det? Annars börjar det tyvärr låta lite som att det kanske är något med ditt grafikkort om ditt tidigare AMD kort drog ungefär lika mycket ström eller mer så är det förmodligen inte PSU heller.

Gigabyte Aorus Master | 32gb DDR4 3466MHZ CL14 | Ryzen 3950X | 1080Ti
Asus Z97 Pro Gamer | 32gb ram DDR3 2400MHz | i7 4790k | 2 x R9 390 - Barnen fått ta över
Asrock P67 Extreme4 rev3 | 16gb DDR3 2400MHz | i7 2600K | R9 290 - Barnen fått ta över
En massa bärbara, servrar, RPi's och andra boxar

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

@GuuFi: Bra idé att köra benchmarks. FurMark gav 7348 i poäng.

Köpte sen 3dMark och körde Time spy. Tested krashade med felkod 16! Såg jag skapade en supportticket och inväntar svar.

Tack

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2010

Löst: Defekt kort

Tack för alla tips och råd. Men till slut körde jag garanti och lämnade in kortet på Webhallen. De bekräftade att det är något fel (de vet inte vad) och jag fick ett nytt som lirar!