Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Kan inte nå Web UI (qBittorrent-nox + Raspberry Pi + Ubuntu server)

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011

Kan inte nå Web UI (qBittorrent-nox + Raspberry Pi + Ubuntu server)

Hej alla

Jag försöker sätta upp min RPi 3 med Ubuntu server och har installerat qBittorrent enligt Github qBittorrent men jag verkar inte kunna nå Web UI efter allt är klart (genom annan dator på samma nätverk). Se bild nedan

Körde detta för att starta det genom annan port då 8080 verkade vara upptagen (?)

Citat:

qbittorrent-nox --webui-port=8181

Har ni några tips till en nybörjare? Kan inte förstå vad jag gör fel?
Har testat genom Safari och Chrome

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

Har du öppnat brandväggen?
Kolla om den körs med sudo systemctl status ufw

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011
Skrivet av Kalasis:

Har du öppnat brandväggen?
Kolla om den körs med sudo systemctl status ufw

Hmm... om jag förstår rätt så är den disabled?

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

Står det något matnyttigt om du kör:

sudo journalctl -u qbittorrent.service

Jag misstänker att du startat om demonen?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011
Skrivet av Kalasis:

Står det något matnyttigt om du kör:

sudo journalctl -u qbittorrent.service

Jag misstänker att du startat om demonen?

Yes, demonen är omstartad!

Detta får jag upp:

EDIT: Dum fråga kanske, men det har ingenting med router att göra? Har inte haft detta problemet när jag installerat OpenMediaVault på en annan burk och ansluter till den lokala IPn.

Ser även att det står Tcp6 på port 8181 och vad jag kan förstå så har det med att göra att det går över IPv6?

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

@Big Lars: allt ser ju ut att rulla fint...
Router ska inte spela roll om eftersom det är internt.
Eftersom du sshar in på din pi ska du inte behöva göra något med regler.

Kan du testa att starta på en annan porr? Typ 1234?

Sen kan du bara för att vara säker skriva 'sudo ufw disable' för att vara säker på att brandväggen verkligen är avstängd.

Trädvy Permalänk
Medlem
Registrerad
Dec 2015

På din netstat-körning ser det ut som om du lyckats sätta upp en qbittorent-nox som lyssnar både på IPv4 och IPv6 på port 33587. Plus att samma process bara lyssnar på IPv6 på port 8181. Jag gissar att 33587 är en slumpmässigt vald port som externa bittorrent-klienter ska ansluta till (eventuellt med hjälp av UPNP-hål i brandväggen), medan 8181 är webbgränssnittet.

Men curl-kommandot har ju lyckats hämta en sida från qbittorrent-nox på en IPv4-adress och port 8181. Förvirrande. Men trafik kanske hoppar på det sättet automagiskt om man kör mot localhost?

Vad händer om du installerar curl på en annan dator i nätverket och ger exakt samma kommando, respektive ett kommando där du anger IPv6-adressen i stället? IPv6-adressen är den som börjar på fe80 och slutar på f. Det är en icke routbar adress, så de båda datorerna måste sitta på samma LAN.

Edit: Slutar på 1 -> slutar på f.

Edit2: Efter lite uppfräschning av mina IPv6-kunskaper så verkar det som om fe80-adressen antagligen är en sådan adress som tilldelas interface som inte lyckats få någon IPv6-adress via DHCP (IPv4-motsvarigheten är 169.254.0.0/16). Därmed blir den antagligen svår att nå från en annan dator. Jag ser två lösningar: 1) Stäng av IPv6 i Ubuntu eller 2) Se till att din router börjar dela ut IPv6-adresser på LAN och se till att Ubuntu får en.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011
Skrivet av Kalasis:

@Big Lars: allt ser ju ut att rulla fint...
Router ska inte spela roll om eftersom det är internt.
Eftersom du sshar in på din pi ska du inte behöva göra något med regler.

Kan du testa att starta på en annan porr? Typ 1234?

Sen kan du bara för att vara säker skriva 'sudo ufw disable' för att vara säker på att brandväggen verkligen är avstängd.

Skrivet av KAD:

På din netstat-körning ser det ut som om du lyckats sätta upp en qbittorent-nox som lyssnar både på IPv4 och IPv6 på port 33587. Plus att samma process bara lyssnar på IPv6 på port 8181. Jag gissar att 33587 är en slumpmässigt vald port som externa bittorrent-klienter ska ansluta till (eventuellt med hjälp av UPNP-hål i brandväggen), medan 8181 är webbgränssnittet.

Men curl-kommandot har ju lyckats hämta en sida från qbittorrent-nox på en IPv4-adress och port 8181. Förvirrande. Men trafik kanske hoppar på det sättet automagiskt om man kör mot localhost?

Vad händer om du installerar curl på en annan dator i nätverket och ger exakt samma kommando, respektive ett kommando där du anger IPv6-adressen i stället? IPv6-adressen är den som börjar på fe80 och slutar på f. Det är en icke routbar adress, så de båda datorerna måste sitta på samma LAN.

Edit: Slutar på 1 -> slutar på f.

Edit2: Efter lite uppfräschning av mina IPv6-kunskaper så verkar det som om fe80-adressen antagligen är en sådan adress som tilldelas interface som inte lyckats få någon IPv6-adress via DHCP (IPv4-motsvarigheten är 169.254.0.0/16). Därmed blir den antagligen svår att nå från en annan dator. Jag ser två lösningar: 1) Stäng av IPv6 i Ubuntu eller 2) Se till att din router börjar dela ut IPv6-adresser på LAN och se till att Ubuntu får en.

Okej... så nu har jag testat att starta det genom port 1234 genom kommando:

qbittorrent-nox --webui-port=1234

samt detta i .config/qBittorrent/qBittorrent.conf (som jag egentligen inte vet är nödvändigt då jag läste att det kommer ihåg föregående kommando?)

WebUI\Port=1234

Har även lagt till detta i /etc/sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 net.ipv6.conf.all.forwarding = 1

Lik förbannat får jag inget bra resultat

Edit: Men när jag kör sudo curl http://192.168.0.32:8181 visas det som tidigare.
Edit 2: Bytte ut bilden till en mer komplett

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

Ska försöka sätta upp en uppsättning som din under kvällen så får vi se om jag får igång det.

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

Har du kört guiden helt och hållet och skapat en ny anvädare som du gett privilegier till att köra qbittorrent? För i sådana fall borde du enbart köra dina kommandon som denna.

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005

Nu satte jag upp det på en ren ubuntu server, följde guiden steg för steg och det funkade utan problem alls, så jag undrar vart det kan ha gått fel för dig?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011
Skrivet av Kalasis:

Har du kört guiden helt och hållet och skapat en ny anvädare som du gett privilegier till att köra qbittorrent? För i sådana fall borde du enbart köra dina kommandon som denna.

Yes, skapade en ny användare och gjorde som i guiden men har nog inte kört alla kommandon som den.

Skrivet av Kalasis:

Nu satte jag upp det på en ren ubuntu server, följde guiden steg för steg och det funkade utan problem alls, så jag undrar vart det kan ha gått fel för dig?

Hmm... Kanske ligger något i det som du skrev ovan. Får ta och göra ett nytt försök med färsk installation osv.
Stort tack för att du tog dig tiden att testa!

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Registrerad
Maj 2019
Skrivet av Kalasis:

Nu satte jag upp det på en ren ubuntu server, följde guiden steg för steg och det funkade utan problem alls, så jag undrar vart det kan ha gått fel för dig?

@Big Lars

Återställ IPv6 för localhost... du har stängt det av bara farten, och det kan ställa till med andra problem.

Ska se ut så här :

net.ipv6.conf.lo.disable_ipv6 = 0

Sedan On Topic :
Jag kan inte heller gissa mig till varför WebUI:t inte är igång på IPv4, men... har du provat på localhost?
Såhär:

(Prova också med porten du instruerat vid uppstart, byt ut "1234" efter kolon-tecknet ovan .)

Trädvy Permalänk
Medlem
Plats
0:0:0:0:0:0:7f00:1
Registrerad
Aug 2005
Skrivet av Big Lars:

Yes, skapade en ny användare och gjorde som i guiden men har nog inte kört alla kommandon som den.
Hmm... Kanske ligger något i det som du skrev ovan. Får ta och göra ett nytt försök med färsk installation osv.
Stort tack för att du tog dig tiden att testa!

Ett steg var ju att köra igång programmet som den andra användaren för att acceptera eula.
Kanske det som missades?

Trädvy Permalänk
Medlem
Registrerad
Jul 2017

Har du VPN igång på torrent servern?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011
Skrivet av m1k3_dd:

@Big Lars

Återställ IPv6 för localhost... du har stängt det av bara farten, och det kan ställa till med andra problem.

Ska se ut så här :

net.ipv6.conf.lo.disable_ipv6 = 0

Sedan On Topic :
Jag kan inte heller gissa mig till varför WebUI:t inte är igång på IPv4, men... har du provat på localhost?
Såhär:

(Prova också med porten du instruerat vid uppstart, byt ut "1234" efter kolon-tecknet ovan .)

Okej, ska testa det också!

Skrivet av Kalasis:

Ett steg var ju att köra igång programmet som den andra användaren för att acceptera eula.
Kanske det som missades?

Det har testats!

Skrivet av JeanC:

Har du VPN igång på torrent servern?

Nope, ingen VPN ännu!

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011

Då har jag gjort ett nytt försök och får samma resultat igen. Följt guiden till punkt och pricka hoppas jag, annars är det något jag inte alls förstår.

Steg 1: Kollade upp vilken IP hallonpajen med Ubuntu server har fått och sedan SSH (genom Mac terminal)

Steg 2: Laddar ner och installerar qbittorrent med kommandon som står i guiden. Sedan skapar jag ny användare osv.

Steg 3: Vid tillfället i guiden där det står att man bör komma åt adressen tar jag upp Safari (och Chrome) och försöker ansluta utan resultat. Testar även att starta genom port "1234"

Steg 4: Kollar netstat och hamnar på samma "problem" igen...

Edit: Ska tillägga att jag även försökt ansluta med en windows laptop

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011

Uppdatering

Har testat köras samma process på en annan Pi och blir likadant. Förstår inte var felet ligger, MEN jag testade att istället installera Transmission och kunde ganska enkelt ändra det jag ville i configen med "whitelist" osv.
Nu når jag åtminstone Web UI. Får väl helt enkelt ta och testa detta istället, får huvudvärk av att bara tänka på det andra

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Registrerad
Sep 2018

@Big Lars: Undra om du inte hade white-list för webgui och ditt IP var inte med där förmodligen.

Tips, kör flecket med Transmission då fungerar allt super bra

Macbook Pro 16" 2019 / iPad Pro 12.9" 2020 / iPhone 11 Pro Max

Trädvy Permalänk
Medlem
Registrerad
Okt 2019

Nu vet jag inte hur det är med qbittorrent när man kör headless, om ens dessa inställningar finns på linuxversionen. Men prova att disabla "enable clickjacking protection" samt "Enable cross-site Request forgery (CSRF) protection.

Kan ju även testa att lägga till ditt subnet i vitlistan.

Trädvy Permalänk
Medlem
Registrerad
Mar 2013
Skrivet av KAD:

Edit2: Efter lite uppfräschning av mina IPv6-kunskaper så verkar det som om fe80-adressen antagligen är en sådan adress som tilldelas interface som inte lyckats få någon IPv6-adress via DHCP (IPv4-motsvarigheten är 169.254.0.0/16). Därmed blir den antagligen svår att nå från en annan dator. Jag ser två lösningar: 1) Stäng av IPv6 i Ubuntu eller 2) Se till att din router börjar dela ut IPv6-adresser på LAN och se till att Ubuntu får en.

Nja.

Fe80 är en s.k "link-local" adress, och är en adress som du sätter själv, eller som tilldelas per automatik.
Den är dock bara användbar för kommunikation på det specifika nätverkssegmentet/broadcastdomänen som enheten sitter på.

IPv6 har inte riktigt någon motsvarighet till APIPA-adresser (169.254.0.0/16), när en dator inte kan nå en DHCP server för att få en IPv6-adress så kan den använda sig av EUI64 för att skapa sig en routbar IPv6-adress istället

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2010
Skrivet av Big Lars:

net.ipv6.conf.all.forwarding = 1

Den inställningen vill du sätta till 0 då du nu säger åt din kernel att routa IPv6.

Skulle även rekommendera att köra

sudo tcpdump -nli <ditt interface>

hos både klient och server för att se hur trafiken flödar när du ansluter till servern.

Säker på att du inte har någon brandvägg i någon ände? Kör

sudo iptables -L

För att kolla dina regler samt policys.

Satte upp detta själv rätt nyligen så jag kan posta mina configs ifall du har fortsatta problem.

EDIT: Det är också viktigt att du ändrar i configfilen som ligger i qBittorrent-användarens hemkatalog, d.v.s. /home/qbtuser/.config/qBittorrent.conf om du använder samma användare som i guiden och kör systemd-tjänsten man skapar istället för att bara starta qBittorrent som en vanlig process från terminalen.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2011

Kul med så mycket svar!
Dessvärre funkade inte detta för mitt ändamål, men hoppas någon med samma problem kan hitta tillbaks till denna tråden.

"So I parallel double parked that motherf*cker sideways"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2010
Skrivet av Big Lars:

Kul med så mycket svar!
Dessvärre funkade inte detta för mitt ändamål, men hoppas någon med samma problem kan hitta tillbaks till denna tråden.

Vad var det som inte funkade för ditt ändamål? Då jag själv har en liknande setup är jag intresserat av eventuella begränsningar du stött på.

Trädvy Permalänk
Medlem
Registrerad
Jul 2011

Verkar ju dock inte ha handlat om någon vitlistning av IP-adress för att nå web-guit då OS:et inte ens verkade lyssna på port 1234 över IPv4?

Av ren nyfikenhet, vill du verkligen köra en seedbox på en RPI? Eller det kanske bara är för labb?

Vet hut Fredrik Åkare - skäms gamle karl!