Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Lägg till funktioner till =OM(B2>B1;1;-1) EXCEL

Trädvy Permalänk
Medlem
Registrerad
Sep 2015

Lägg till funktioner till =OM(B2>B1;1;-1) EXCEL

Vill komplettera/göra tillägg på min nuvarande formel med följande, om det är samma värde raden under så ska det bli 1 om det var ett innan och -1 om det var -1 innan utöver min nuvarande OM formation.

Just nu använder jag =OM(B2>B1;1;-1)

1
2....1........1
2...-1........1
3....1........1
1...-1.......-1
-2..-1.......-1
-5..-1.......-1
-3...1........1
-3..-1........1
-3..-1........1
-4..-1.......-1

...Har nu....Vill ha

Har försökt komplettera med fler OM funktioner men får inte till att den ska ta hänsyn till vad som var innan.

MVH

Trädvy Permalänk
Hedersmedlem
Plats
i bestens inre
Registrerad
Jul 2001

Jag tycker det låter som att din nuvarande OM bara ska utföras om värdet på raden under är olika, annars ska resultatet vara oförändrat. Är det rätt uppfattat?

I så fall borde du kunna lösa det genom att nästla den i en ny OM-funktion som testar om värdena är olika.

=OM(B2<>B1(OM(B2>B1;1;-1))

Eventuella åsikter som uttrycks är skribentens egna och återspeglar ej Sweclockers officiella synsätt eller ståndpunkter.

Trädvy Permalänk
Medlem
Registrerad
Sep 2015
Skrivet av Aphex:

Jag tycker det låter som att din nuvarande OM bara ska utföras om värdet på raden under är olika, annars ska resultatet vara oförändrat. Är det rätt uppfattat?

I så fall borde du kunna lösa det genom att nästla den i en ny OM-funktion som testar om värdena är olika.

=OM(B2<>B1(OM(B2>B1;1;-1))

Hej, ja det stämmer. Om värdet går ner så blir det -1 tills värdet ändras igen. Blir det lägre igen så blir det -1 igen och skulle det bli högre så blir det 1.

Mvh

Trädvy Permalänk
Medlem
Registrerad
Sep 2015

@Aphex: testade din formel nu på morgonen och det står Formeln saknar en inledande och avslutande parentes.

MVH

Trädvy Permalänk
Hedersmedlem
Plats
i bestens inre
Registrerad
Jul 2001

Japp, en till ) ska det vara på slutet.

Eventuella åsikter som uttrycks är skribentens egna och återspeglar ej Sweclockers officiella synsätt eller ståndpunkter.

Trädvy Permalänk
Medlem
Registrerad
Sep 2015

@Aphex: testade det, nu står det: Det finns ett problem med den här formeln.

Tack för hjälpen btw

mVH

Trädvy Permalänk
Hedersmedlem
Plats
i bestens inre
Registrerad
Jul 2001

Sorry, satt och skrev det på mobilen. nu när jag faktiskt har excel framför mig blir det lättare att få det rätt

=OM(B2=B1;C1;OM(B2>B1;1;-1))

ger det resultat du ville ha:

1 2 1,00 2 1,00 3 1,00 1 -1,00 -2 -1,00 -5 -1,00 -3 1,00 -3 1,00 -3 1,00 -4 -1,00

Eventuella åsikter som uttrycks är skribentens egna och återspeglar ej Sweclockers officiella synsätt eller ståndpunkter.

Trädvy Permalänk
Medlem
Registrerad
Sep 2015

@Aphex: tackar, funkar utmärkt.