Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Ta reada på vart trafiken till en specifik port stoppas?

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003

Ta reada på vart trafiken till en specifik port stoppas?

Hur kan jag felsöka för att ta reda på varför jag inte lyckas öppna en port i mitt nätverk för en extern tjänst.

Jag vill ta reda på vart trafiken stoppas.

Jag har en Unifi edgerouter x
Som sedan går till en TP-Link Swich tl-sg108
Som i sin tur har en tråd till min dator där jag styr en server.

Men när jag från externt håll försöker ansluta så är min port inte öppen.

Går jag till https://canyouseeme.org/ så får jag negativt resultat.

Jag har öppnat porten i Edgerouter
TCP och UDP.

Jag har startat om router och dator.

Jag har inte fattat om man kan eller behöver komma åt någon setup i en TPLINK swich... som jag förstår det finns det inga inställningar i denna...

Jag har stängt av Windows brandvägg men inget ger resultat.

Hur kan jag ta reda på vart trafiken till en specifik stoppas?

Trädvy Permalänk
Medlem
Plats
Jorden
Registrerad
Nov 2001

Får du publik IP-adress från din ISP?

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003

Vad menar du?

Har en extern ip

Trädvy Permalänk
Medlem
Plats
Jorden
Registrerad
Nov 2001
Skrivet av hjarterkung:

Vad menar du?

Har en extern ip

Om du kollar vilken IP-adress din router har mot Internet, och jämför med IP-adressen du får när du går till canyouseeme.com.
Om det är samma IP-adress så får du publik IP, annars får du sk. CG-NAT, och då kan du kontakta din ISP och be att få publik IP-adress.

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003

Aha, ja då har jag publik. Har samma ip adress på båda.
Enda skillnaden är att i routern står det.... 7/26 på slutet.
http://prntscr.com/tssm4j

hur felsöker jag vart portöppnandet misslyckas?

Trädvy Permalänk
Medlem
Plats
Jorden
Registrerad
Nov 2001

Då har du nog inte vidarebefordrat porten på rätt sätt, switchen lär du inte behöva röra.

Här kan du kolla hur du gör:
https://portforward.com/ubiquiti/edgerouter-x/

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003

Hm... jag hänger inte med på vad jag kan ha gjort för fel.
http://prntscr.com/tst0y

Routern har internet in i eth0: http://prntscr.com/tst1g
Så eth0 får vara WAN interface på första bilden.

Sedan har jag eth4 som LAN interface.... då min switch sitter i eth4 och min dator i switch.

Sedan har jag forwardat både min dators lokala IP adress och min externa publika adress... men inget verkar fungera...

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005

Bara för att dubbelkolla; du kan nå den här tjänsten via den interna adressen från andra datorer i ditt interna nätverk, och via localhost på samma maskin som tjänsten körs på?

Jag varken äger eller har erfarenhet av deras EdgeRouter så har ingen möjlighet att bidra med mer än vad som finns vid en enkel sökning. Däremot hade jag tagit bort alla regler och börjat med en om det är så att det krockar när du har mixat med både intern och extern adress. Det är den lokala IP-adressen du vill forwarda till och ingenting annat. Såg att en annan användare länkade en artikel till vad som behöver göras men här är en annan från deras egna sida.

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003
Skrivet av jagardaniel:

Bara för att dubbelkolla; du kan nå den här tjänsten via den interna adressen från andra datorer i ditt interna nätverk, och via localhost på samma maskin som tjänsten körs på?

Ja Stämmer. Jag kan nå tjänsten via dess interna adress från min dator där den körs men även andra datorer i nätverket, till exempel min mobil som är ansluten på wifi.
Men jag ska nå tjänsten från externt också och därför vill jag testa detta från min mobil med wifi avstängt, men det är här jag fastnar. Tjänsten ger mig en IP adress att använda, vilket är "min publika IP+porten jag har öppnat".

Skrivet av jagardaniel:

Jag varken äger eller har erfarenhet av deras EdgeRouter så har ingen möjlighet att bidra med mer än vad som finns vid en enkel sökning. Däremot hade jag tagit bort alla regler och börjat med en om det är så att det krockar när du har mixat med både intern och extern adress. Det är den lokala IP-adressen du vill forwarda till och ingenting annat. Såg att en annan användare länkade en artikel till vad som behöver göras men här är en annan från deras egna sida.

Har läst igenom där och tror mig ha gjort alla rätt jag kan. Ska försöka börja om från början.

Trädvy Permalänk
Medlem
Plats
Jorden
Registrerad
Nov 2001

Du ska inte göra någon vidarebefordran till din externa adress så prova att ta bort det.

Trädvy Permalänk
Medlem
Plats
stockholm
Registrerad
Jun 2003

Japp det gjorde susen. Så nära och så enkelt. Tog bort externa ip från forwarding och lät bara lokala vara kvar, nu funkar det!

Tack för hjälpen!

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av hjarterkung:

Hm... jag hänger inte med på vad jag kan ha gjort för fel.
http://prntscr.com/tst0y7

Routern har internet in i eth0: http://prntscr.com/tst1gg
Så eth0 får vara WAN interface på första bilden.

Sedan har jag eth4 som LAN interface.... då min switch sitter i eth4 och min dator i switch.

Sedan har jag forwardat både min dators lokala IP adress och min externa publika adress... men inget verkar fungera...

Ser underligt ut att vidarebefordra portar publikt och har du också angett samma portnummer är det fel för en port ska bara pekas till ett ip, det interna.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Jorden
Registrerad
Nov 2001

Toppen!
Och det är ofta något enkelt som saknas när saker inte fungerar.