Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

iwlwifi: BIOS contains WGDS but no WRDS?

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

iwlwifi: BIOS contains WGDS but no WRDS?

Vad betyder det här? Fick lov att installera om LXLE Linux helt. Kom inte in. Bärbar. Asus Vivobook.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Har du installerat firmware till nätverkskortet?
"sudo apt install firmware-iwlwifi"
Har för mig jag behövde göra detta på debian.
https://wiki.debian.org/iwlwifi

LXLE verkar vara baserat på ubuntu som i sin tur är baserat på debian.
Edit: Jag installerade med nätverkskabel, sedan fixade jag det trådlösa.

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Tack... ska kolla...

slött wifi på espressohouse... provar nåẗ liknande kommando jag hittade på google

---------------------------------------------------
Can't you just use APT to install it?

As root:
Code:

apt-get update && apt-get upgrade
apt-get install firmware-iwlwifi

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Får svar i terminalen att "E: kunde inte hitta paketet iwlwifi"

Gjorde det här:

Newer kernels can break some dkms module support but they are mainly for Nvidia graphics and Broadcom wireless.
You should have used the following command to install the new kernel so it stays updated by the Update Manager
Code:

sudo apt-get install --install-recommends linux-generic-hwe-16.04

You can mark as solved by using the Thread Tools menu near the top right of the page

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Vill ogärna slå på död sten med en fail-boot-system message. Och installera om LXLE

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Jag har den senaste.

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

https://easylinuxtipsproject.blogspot.com/p/intel-wifi.html

det här? kan nån kommentera länken?

Gjorde alla steg!

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Har du dual boot med Windows? När jag kört detta har jag varit tvungen att inaktivera "windows snabbstart" då windows annars inte stänger ner datorn ordentligt. Kan orsaka problem såsom nätverksanslutningar som försvinner när man startar Linux efter att ha kört Windows. Kan också vara någon knapp på datorn som aktiverar / inaktiverar trådlöst (flygplansläge eller liknande). Kolla att wifikortet är aktiverat i bios.

https://winbuzzer.com/2020/05/19/how-to-disable-windows-10-fa...

Vilket nätverkskort har du?
Kolla med lspci

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Intel wifi

secure boot då? Har det off.

Nej, dual-bootar ej. Windows 10 används för att spionera på oss, så jag rekommenderar att inte ha det. windows 7 är bättre

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jun 2020

Hej.

ret = iwl_mvm_sar_init(mvm); if (ret == 0) { ret = iwl_mvm_sar_geo_init(mvm); } else if (ret > 0 && !iwl_sar_get_wgds_table(&mvm->fwrt)) { /* * If basic SAR is not available, we check for WGDS, * which should *not* be available either. If it is * available, issue an error, because we can't use SAR * Geo without basic SAR. */ IWL_ERR(mvm, "BIOS contains WGDS but no WRDS\n");

https://github.com/torvalds/linux/blob/v5.5/drivers/net/wirel...

Kan du kolla om XHCI/XHC är satt som disable? Skulle med all sannolikhet tro att de är problemet men det kan vara andra orsaker med:

grep enabled /proc/acpi/wakeup

Står XHCI/XHC som disabled? Återkom gärna med output, om xhci är disable så prova att sätta xhci som enable.

echo 'XHC' > /proc/acpi/wakeup echo 'XHCI' > /proc/acpi/wakeup

Du använder wpa_supplicant va?

Skulle tro det och troligtvis hittat ett gammalt sätt att ansluta på, men nu gissar jag bara.

Vill du bara prova en wifi anslutning väldigt elegant så använd:

wpa_supplicant -B -i <wlan0> -c <(wpa_passphrase SSID MYPASSWORD)

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

XHC är enabled!

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jun 2020

@Lafa: Jag läste igenom allt en gång till.

Först får du meddelandet om bios och sedan hittar du inte modulen till iwlwifi så jag tänkte fråga dig frågorna istället:

Var är detta för laptop?

När ser du meddelandet om WGDS men inte WRDS?
- Är det under en livecd?
- Är det under tiden system vaknar upp igen?
- Är det när det den har gått ner i viloläge det händer?
- Är det när du bootar?
- Är det n är du försöker ansluta till wifi nät?
- Kan du ansluta till öppna nätverk?

Har du kollat så inte wifi kortet ligger som blockat?
rfkill list

Står wifi som soft eller hard blockat?

Sen om du har stängt av secure boot, så kan det ju vara så att wifit inte hängt med, prova köra en first time på modulerna nedan:

for modules in iwlmvm iwldvm iwlwifi; do modprobe --first-time ${modules} done

Här finns lite info: https://unix.stackexchange.com/a/542532

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Det var när jag bootade som jag fick felmeddelandet.

när jag prövade att slå på Secure Boot fungerar inte Wifi alls inne i datorn.

Wireless LAN:
soft blocked: no
hard blocked: no

Trädvy Permalänk
Medlem
Registrerad
Jun 2006

Pröva en live-Debian och se om det funkar:
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-inc...

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Jag tror jag råkat radera en partition när jag försökte installera Manjaro manuellt i laptopen (men misslyckades, det fanns inga alternativ att radera disken helt och installera OS:et i den grafiska installeraren). Nu är det låst att installera OS. Såvida jag inte lämnar in den till en dataexpert. LXLE är precis vad jag vill ha dock.

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av Lafa:

Jag tror jag råkat radera en partition när jag försökte installera Manjaro manuellt i laptopen (men misslyckades, det fanns inga alternativ att radera disken helt och installera OS:et i den grafiska installeraren). Nu är det låst att installera OS. Såvida jag inte lämnar in den till en dataexpert. LXLE är precis vad jag vill ha dock.

Förstår inte hut du menar att det är låst att installera OS. Det är väl bara att ta bort alla partitioner och därefter välja "guidad använd hela disken" Det valet finns åtminstone i Debians installationsprogram. Jag tror bara att du gör fel nånstans.

Angående att LXLE är precis vad du vill ha antar jag att du vill använde LXDE som Desktop Environment eller innehåller LXLE något speciellt? Så länge du väljer LXDE (som hänger med i den Live-versionen jag länkade till) så bör det vara minimal prestandaskillnad mellan vilken dist som helst. Självklart väljer du väl själv vilken dist du vill använda, men jag ser inte nyttan av ett Linux som inte har ett fungerande nätverk. Det finns ju många distar att testa.

Live-disten jag länkade till är ju just en live-dist, du behöver ju inte installera för att testa, bara att boota upp. Pröva först och se om det innehåller drivrutinerna du behöver. Kanske gör de det, kanske gör de det inte.

Trädvy Permalänk
Medlem
Plats
root
Registrerad
Jan 2004

@Lafa både @ronnylov & @wuseman har efterfrågat tämligen basala saker om din bärbara dator för att kunna bistå med hjälp, är det för mycket begärt att du bistår dem med svar till dessa frågor ?

Trädvy Permalänk
Medlem
Registrerad
Feb 2004

Det har inte blivit något error ännu på LXLE med wifin. Allt funkar.

Jag återkommer, har inte mycket surf kvar nu att ladda ner och testa distros.

Får alltså ett felmeddelande på BIOS när jag försöker boota en distro via USB

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jun 2020

@Lafa: Jaha.

Är det ett nvidia kort i laptopen och är det nouvaeu du använder?

lsmod|grep nou

Trädvy Permalänk
Medlem
Registrerad
Feb 2004
Skrivet av wuseman:

@Lafa: Jaha.

Är det ett nvidia kort i laptopen och är det nouvaeu du använder?

lsmod|grep nou

Intel wifi chip är det.

Har äntligen skaffat en PC med HDMI 2.0 4k 60 hz.

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jun 2020

@Lafa: Ok, det kan finnas en konflikt med nouvaeu modulen såg jag men funkar det nu så är det ju lysande.