Permalänk
Medlem

Kan ej starta klonad XP i sata disk

Kör XP i en cnc maskin utan nät eller www.
Moderkort + power s brann upp, nytt gigabyte moderkort GA-N3050N-D3H

Klonade 3st små diskar på 80GB när mask var ny.
Minns att det kom frågor jag var osäker på, troligen sektorer, mbr o annat jag glömt.
Alla diskarna är lika o innehållet vad gäller xp o de maskinspecifika filerna för maskinen verkar ok men tveksamt om boot fil är på rätt plats.
Jag har XP med licens nr + update 2, 3
Alla försök med skivor ger, sätt i boot skiva.
Min önskan är att kunna boota från C: alt från USB 16GB sandisk flash.
Finns på maskinen: CD, USB, HD-SATA.

Kan även tänka mej betala för usb boot

Permalänk
Medlem

Det där moderkortet har UEFI, du behöver ställa om det till "Legacy (BIOS-mode)" för att köra XP.

Om de 3 klonade diskarna är SATA, så skall det mer eller mindre bara vara att koppla in dem, starta upp och sedan installera nya drivrutiner.

CSM, Enable
Storage, Legacy
Såg precis att den första bilden bör vara "disabled" som standard.

Manual: https://www.gigabyte.com/Motherboard/GA-N3050N-D3H-rev-10/sup...

Edit: OM Secure Boot kan konfigureras efter att ovan är ändrade, så skall denna sättas till "disabled".

Permalänk
Rekordmedlem
Skrivet av CNC vicke:

Kör XP i en cnc maskin utan nät eller www.
Moderkort + power s brann upp, nytt gigabyte moderkort GA-N3050N-D3H

Klonade 3st små diskar på 80GB när mask var ny.
Minns att det kom frågor jag var osäker på, troligen sektorer, mbr o annat jag glömt.
Alla diskarna är lika o innehållet vad gäller xp o de maskinspecifika filerna för maskinen verkar ok men tveksamt om boot fil är på rätt plats.
Jag har XP med licens nr + update 2, 3
Alla försök med skivor ger, sätt i boot skiva.
Min önskan är att kunna boota från C: alt från USB 16GB sandisk flash.
Finns på maskinen: CD, USB, HD-SATA.

Kan även tänka mej betala för usb boot

Det kan vara så att du bara har klonat själva datadelen av disken och i så fall kan du behöva skapa en bootloader på klonen, det är ganska enkelt i så fall men det kan också vara att du behöver ställa om en del "offsets" om det du klonade från inte är identiskt med enheten du klonade till.
Guide för att göra en mbr om den saknas >
https://neosmart.net/wiki/fix-mbr/
Men gör det inte på en klon du måste ha kvar utifall det intyte är det problemet.

Permalänk
Medlem
Skrivet av mrqaffe:

Det kan vara så att du bara har klonat själva datadelen av disken och i så fall kan du behöva skapa en bootloader på klonen, det är ganska enkelt i så fall men det kan också vara att du behöver ställa om en del "offsets" om det du klonade från inte är identiskt med enheten du klonade till.
Guide för att göra en mbr om den saknas >
https://neosmart.net/wiki/fix-mbr/
Men gör det inte på en klon du måste ha kvar utifall det intyte är det problemet.

Tack f svaret viita.
CPU var i legacy men de övriga stämmer nog inte, får lösa det i morrn.

Mrgaffe
Det du skriver har jag misstänkt. I min i7 pc i prog iolo kan jag se att det finns en mbr. Kan den "ligga" fel eller peka fel? Ska ta en dump. Ska se lite på neosmart.

Jag skrev aldrig varför hd inte funkade. När jag demonterade den så skramlade burken o en läsarm var av. Vet inte om ett överslag i nätet är felet.
3 mån innan gick pws till styrdatorn sönder. Finns en pc med linux som sköter all styrning av axlar mm.

Permalänk
Rekordmedlem
Skrivet av CNC vicke:

Tack f svaret viita.
CPU var i legacy men de övriga stämmer nog inte, får lösa det i morrn.

Mrgaffe
Det du skriver har jag misstänkt. I min i7 pc i prog iolo kan jag se att det finns en mbr. Kan den "ligga" fel eller peka fel? Ska ta en dump. Ska se lite på neosmart.

Jag skrev aldrig varför hd inte funkade. När jag demonterade den så skramlade burken o en läsarm var av. Vet inte om ett överslag i nätet är felet.
3 mån innan gick pws till styrdatorn sönder. Finns en pc med linux som sköter all styrning av axlar mm.

Du kan alltid skapa en ny mbr på en disk om du vill, det vbar ett ganska vanligt problem på xp tiden eftersom xp alltid skriver över vad som än finns på disken, det kör över allt, även andra versioner av win så att reparera bootloders var ganska vanligt då om man använde flera diskar med olika installationer.
Vad menar du med att läsarmen var av har du öppnat disken aom du nu försöker ersätta med en klon ?

Permalänk
Medlem

Den befintliga disken som senast satt i maskinen var den som läsarmen var trasig på. De klonade diskarna har aldrig körts i maskinen pga mitt boot problem. Men din fråga var helt befogad. Lyfte locket då den lät som en kastanjett av nyfikenhet.

Permalänk
Rekordmedlem
Skrivet av CNC vicke:

Den befintliga disken som senast satt i maskinen var den som läsarmen var trasig på. De klonade diskarna har aldrig körts i maskinen pga mitt boot problem. Men din fråga var helt befogad. Lyfte locket då den lät som en kastanjett av nyfikenhet.

Endera saknas bootsektorn elerl så är det nått problem pga att du klonat mellan olika typer av diskar. Du skulle kunna klona en av klonerna och prova på den om det funkar att skapa en ny bootsektor.
Det andra problemet är svårare att lösa men det finn nog nån som vet hur man ska göra med det också.

Permalänk
Medlem
Skrivet av mrqaffe:

Endera saknas bootsektorn elerl så är det nått problem pga att du klonat mellan olika typer av diskar. Du skulle kunna klona en av klonerna och prova på den om det funkar att skapa en ny bootsektor.
Det andra problemet är svårare att lösa men det finn nog nån som vet hur man ska göra med det också.

Det mesta i setupen var fel men trots justerigar får blå skärm och om koden säger win, supporten en massa tänkbara fel men rek. att köra någon felsökning som finns i win 10 som jag kör i laptopen. Får bli i morn.
Tack så länge!

Permalänk
Hedersmedlem

Vad satt det för moderkort i datorn innan moderkortsbytet?

XP var betydligt känsligare för att byta moderkort när det kommer till s-ata-kontroller än vad senare windows-versioner har varit. Så är det inte samma chipset så är risken stor att du behöver göra en ny xp-installation.

Permalänk
Medlem
Skrivet av CNC vicke:

Det mesta i setupen var fel men trots justerigar får blå skärm och om koden säger win, supporten en massa tänkbara fel men rek. att köra någon felsökning som finns i win 10 som jag kör i laptopen. Får bli i morn.
Tack så länge!

Så du har kommit förbi steg ett, dvs, få datorn att faktiskt boota upp till XP.

När det kommer till blåskärmar så är det oftast frågan om drivrtuiner.
Under uppstart, före XP startar, men precis efter att BIOS lämnar över till att starta XP, "hamra" på F8, dvs, tryck flera gånger på F8 i snabb följd så du får upp en "boot-meny" för Windows.
Där kommer det finnas ett alternativ som ser ut något i stil med "Felsäkert läge", välj detta och starta upp, sedan kan du börja installera om nya drivrutiner för moderkort, eventuellt grafikkort, etc.
(Det är rekommenderat att rensa bort gamla drivruitiner om man har kunskaper om hur man går tillväga.)
Då det inte är frågan om en ren ominstallation, så kan vissa gamla drivrutiner fortfarande orsaka eventuella fel även i framtiden.

Har man kunskaper och tillgång till installationsfilerna till nödvändig mjukvara för användsningsområdet så är det nog ett bättre alterantiv att bara installera om XP på en ny disk.

När det kommer till koden, då antar jag att du menar licensnyckeln?
Den borde inte vara några problem, det är nog mer snarare en fråga om XP fortfarande går att aktivera eller inte.
Jag har ingen aning när det kommer till detta.
Det finns dock som i de flesta fall, sätt att kringgå detta om det visar sig vara problem.

Permalänk
Medlem

Jag skall läsa på o ta vara på dina idéer.
Provade med ssd igår o lurade fram koden men det kan var en herrans massa saker.
0X0000007B INACCESSIBLE BOOT DEVICE
+ massa mer kod. Återkommer senare.

Körde XP på många burkar förr o vet att det bråkade en hel del när man flyttar disk mellan olika pc.
Köpte precis en ny sata disk på 1TB så utöver xp kommer väl det gå åt 2-300 mb. Det fanns inte mindre på Netonet.
Tack så länge!

Permalänk
Medlem
Skrivet av CNC vicke:

0X0000007B INACCESSIBLE BOOT DEVICE

Detta är ett typiskt HAL fel.

hal.dll är en fil som skapas när du installerar XP och innehåller drivrutiner för de hårdvarukomponenter du har. (Hardware Abstraction Layer)
Du får leta upp en XP skiva, boota från den och välja att reparera din windows installation.
Installationen skapar om hal.dll med de komponenter den hittar i systemet, sedan funkar det igen.

Permalänk
Medlem
Skrivet av OSkar000:

Vad satt det för moderkort i datorn innan moderkortsbytet?

XP var betydligt känsligare för att byta moderkort när det kommer till s-ata-kontroller än vad senare windows-versioner har varit. Så är det inte samma chipset så är risken stor att du behöver göra en ny xp-installation.

Tjenare OSkar000
En udda lösning som brukligt när det gäller maskiner. Ett ISA kort med ett antal kontakter för allt som HDD, USB, floppy, CD,
VDI kontakt som använder den inre kontakten som ej går att köpa 2x10 samma på skärmen 2x10 en specialkabel.
Moderkort på Emco concepst maskin Mill/Turn 155

bilden ligger bara uppe 50 timmar.
Jag har bytt då denna låda kostar mer än 20kkr med en HDD på 40 GB.

Permalänk
Medlem
Skrivet av ZecretW:

Detta är ett typiskt HAL fel.

hal.dll är en fil som skapas när du installerar XP och innehåller drivrutiner för de hårdvarukomponenter du har. (Hardware Abstraction Layer)
Du får leta upp en XP skiva, boota från den och välja att reparera din windows installation.
Installationen skapar om hal.dll med de komponenter den hittar i systemet, sedan funkar det igen.

Tackar ZecretW
Kan man radera HAL filen eller är det till ingen nytta. Tänkte om den skriver in den o det bråkar framöver?
Fabrikanten säger att det troligen går att köra Windows 10 32/64 bitars men de pc 3st har alla haft win7 innan och det är den enda skivan jag har utöver XP, XP pro, sp1, sp2, sp3.
Gör ett test med ny HDD o XP pro nu, så får vi se vad som händer.

Permalänk
Hedersmedlem
Skrivet av CNC vicke:

Tjenare OSkar000
En udda lösning som brukligt när det gäller maskiner. Ett ISA kort med ett antal kontakter för allt som HDD, USB, floppy, CD,
VDI kontakt som använder den inre kontakten som ej går att köpa 2x10 samma på skärmen 2x10 en specialkabel.
Moderkort på Emco concepst maskin Mill/Turn 155

bilden ligger bara uppe 50 timmar.
Jag har bytt då denna låda kostar mer än 20kkr med en HDD på 40 GB.

Misstänkte att det var nån sån lösning. Ser dock inte ut som ett ISA-kort, de har betydligt bredare kontaktpunkter.

Kommer det nya moderkortet att fungera med resten av utrustningen sen? Och stödjer det ens XP?

Permalänk
Medlem

Kanske missar något, men har du prövat att i BIOS ställa SATA läge ifrån AHCI till Legacy?

Borde inte vara det så tidigt i bootdelen men lätt o testa

Permalänk
Medlem
Skrivet av OSkar000:

Misstänkte att det var nån sån lösning. Ser dock inte ut som ett ISA-kort, de har betydligt bredare kontaktpunkter.

Kommer det nya moderkortet att fungera med resten av utrustningen sen? Och stödjer det ens XP?

ISA eller kanske något special, det sitter en adapter för bandkablar till hdd o cd bl.a
Process. Celeron ala snigel fart. 166/.....

Jag det vet jag inte ännu men jag kom en bit in i win7 som tydligen oxå ska funka. Stoppar vid steg 2 o letar efter drivrutinen, där står jag. Bootar nu från en usb.
Såg en på nätet med samma problem men har inte läst färdigt ännu.
Oavsett op så löser jag maskindelen för till den har jag nycklar o lic.
På 90-talet var ju detta en enkel operation. Körde xp i alla maskiner o övriga burkar med NTFS.
Någon kanske känner igen win7 problemet.
Har en cd med drv för moderkortet, frågan är om jag ska lägga in den på usb stickan o isåfall var?
I

Missade ISA?? bussen
Permalänk
Medlem
Skrivet av sinclairhacker:

Kanske missar något, men har du prövat att i BIOS ställa SATA läge ifrån AHCI till Legacy?

Borde inte vara det så tidigt i bootdelen men lätt o testa

Ok, ska testa detta i em. Kom en bit in på win7 som du kan läsa.

Permalänk
Medlem
Skrivet av CNC vicke:

Ok, ska testa detta i em. Kom en bit in på win7 som du kan läsa.

Mmm, läste det, det var därför jag funderade om det ändå inte kunde vara att BIOS var ställd till AHCI, som ofta är default idag.

Har man det läget och bootar så kan den krasha en bit in vid boot, mkt svårt att ens komma in i felsäkert läge.
Ställer man då sata till legacy så kan man då komma igång. (iofs lite långsammare access)

Bara en ide, kan vara något annat, men tar ju bara någon minut o testa.

Håller tummarna

Permalänk
Rekordmedlem
Skrivet av CNC vicke:

ISA eller kanske något special, det sitter en adapter för bandkablar till hdd o cd bl.a
Process. Celeron ala snigel fart. 166/.....

Jag det vet jag inte ännu men jag kom en bit in i win7 som tydligen oxå ska funka. Stoppar vid steg 2 o letar efter drivrutinen, där står jag. Bootar nu från en usb.
Såg en på nätet med samma problem men har inte läst färdigt ännu.
Oavsett op så löser jag maskindelen för till den har jag nycklar o lic.
På 90-talet var ju detta en enkel operation. Körde xp i alla maskiner o övriga burkar med NTFS.
Någon kanske känner igen win7 problemet.
Har en cd med drv för moderkortet, frågan är om jag ska lägga in den på usb stickan o isåfall var?
I

Du försöker flytta en klon mellan 2 icke identiska hårdvarukonfigurationer ? Det är nog inte tekniskt möjligt om klonen inte är gjord av en installation avsed för att vara lätt flyttbar, som tidigare nämns så måste HAL stämma mot datorn eller så behöver du på nått sätt manuellt skapa ett nytt.

Permalänk
Medlem

Vad satt det för moderkort i maskinen från början?

Permalänk
Medlem

[quote postid="18671775" userid="180537" name="Svensktiger"]
Vad satt det för moderkort i maskinen

Udda som brukligt. Se info ovan...
https://www.bildtagg.se/bild/4uehnb0edw8py6tyyaqo7zg

Bytt länk
Permalänk
Medlem
Skrivet av mrqaffe:

Du försöker flytta en klon mellan 2 icke identiska hårdvarukonfigurationer ? Det är nog inte tekniskt möjligt om klonen inte är gjord av en installation avsed för att vara lätt flyttbar, som tidigare nämns så måste HAL stämma mot datorn eller så behöver du på nått sätt manuellt skapa ett nytt.

mrqaffe
Ok.
Då låter jag diskarna vara som backup tills vidare.

Har en win7 skiva o en ny hdd som nämns lite ovan.
Stoppar i steg 2 behöver drv filer som jag inte vet vilka ännu. Får bli ett jobb i kväll.

Permalänk
Medlem
Skrivet av Viita:

Det där moderkortet har UEFI, du behöver ställa om det till "Legacy (BIOS-mode)" för att köra XP.

https://i.imgur.com/od6UJTP.png
https://i.imgur.com/POcYIaB.png
https://i.imgur.com/sIV3bdT.png

Om de 3 klonade diskarna är SATA, så skall det mer eller mindre bara vara att koppla in dem, starta upp och sedan installera nya drivrutiner.

CSM, Enable
Storage, Legacy
Såg precis att den första bilden bör vara "disabled" som standard.

Manual: https://www.gigabyte.com/Motherboard/GA-N3050N-D3H-rev-10/sup...

Edit: OM Secure Boot kan konfigureras efter att ovan är ändrade, så skall denna sättas till "disabled".

Skrivet av CNC vicke:

Tack f svaret viita.
CPU var i legacy men de övriga stämmer nog inte, får lösa det i morrn.

Mrgaffe
Det du skriver har jag misstänkt. I min i7 pc i prog iolo kan jag se att det finns en mbr. Kan den "ligga" fel eller peka fel? Ska ta en dump. Ska se lite på neosmart.

Jag skrev aldrig varför hd inte funkade. När jag demonterade den så skramlade burken o en läsarm var av. Vet inte om ett överslag i nätet är felet.
3 mån innan gick pws till styrdatorn sönder. Finns en pc med linux som sköter all styrning av axlar mm.

Måste bara bekräfta så det inte blivit en missuppfattning. Den första bilden "Limit CPUID Maximum" skall vara satt till Disabled enligt beskrivningen.

Något annat, du skriver att du har en 1TB disk.
Var denna partitionerad till 1TB före du kopplade in den?
Om jag inte missminner mig så saknar Windows XP LBA48-stöd, "out of the box", osäker på hur det är med Win7.
Jag minnas att jag var tvungen att installera någon uppdatering för att aktivera LBA48-stöd i XP.

Vad innebär det att det saknas LBA48-stöd?
Diskar som är störe än 137,4GB blir problematiska. (Det är för att det är taket på LBA28 stödet som följer med Windows XP)
Jag kommer inte ihåg om det räcker med att skapa en mindre partition (mindre än 128GB?) som man installerar Windows XP på, och sedan installerar LBA48-stödet och sedan kan använda den övriga delen av hårddisken som en andra partition.

När diskar börjar närma sig 144,1PB så kommer LBA48 att slå i taket, men det är nog ett tag till innan vi är där.

Permalänk
Medlem
Skrivet av Viita:

Måste bara bekräfta så det inte blivit en missuppfattning. Den första bilden "Limit CPUID Maximum" skall vara satt till Disabled enligt beskrivningen.

Något annat, du skriver att du har en 1TB disk.
Var denna partitionerad till 1TB före du kopplade in den?
Om jag inte missminner mig så saknar Windows XP LBA48-stöd, "out of the box", osäker på hur det är med Win7.
Jag minnas att jag var tvungen att installera någon uppdatering för att aktivera LBA48-stöd i XP.

Vad innebär det att det saknas LBA48-stöd?
Diskar som är störe än 137,4GB blir problematiska. (Det är för att det är taket på LBA28 stödet som följer med Windows XP)
Jag kommer inte ihåg om det räcker med att skapa en mindre partition (mindre än 128GB?) som man installerar Windows XP på, och sedan installerar LBA48-stödet och sedan kan använda den övriga delen av hårddisken som en andra partition.

När diskar börjar närma sig 144,1PB så kommer LBA48 att slå i taket, men det är nog ett tag till innan vi är där.

Viita
Tackar för repliken och all övrig info. Jag har gjort det lättare för mej inför nya moderkortet.
Jag köpte en windows 10 pro med licens och en liten -den minsta man hade 1TB hade räckt med 40GB.
Bild på disk hantering
Visste jag hur krångligt detta blev hade jag gjort det direkt men gammal är äldst och vet ju hur allt funkar eller hur. (det var bättre med ABC 800 Bara och erkänna att jorden är platt o bilar går på batteri.
Nu är inte alla era kommentarer onödiga för de kom delvis till nytta även i disk hanteringen som jag gjort i win10 på stn pc.
Återstå ju att få nya moderkortet att godta booten från usb /win 10.
Ett ypperligt forum o tack för alla med snabb hjälp.
Jag återkommer med bilder när maskinen är i drift igen.