Tips önskas för strulande disk

Permalänk
Moderator

Tips önskas för strulande disk

Idag när jag startade om min dator så kunde den inte boota. Först fastnade den på bootloggan med snurrande prickar. Efter att jag försökt tvinga in den i repair mode så fick jag istället två olika fel, En enhet som är ansluten fungerar inte 0xc0000025 och sedan att det saknas bootinformation 0xc0000098. Det gick inte att reparera Windows bootinformation med Windows installationsmedium.

Efter att ha börjat plocka bort och sätta tillbaka enheter i datorn märker jag att detta beror på en specifik disk. Så fort disken är inkopplad så vägrar datorn boota, men kopplar jag ur disken så startar datorn fint. Det är inte en bootdisk och har aldrig varit en bootdisk. Det finns ingen bootinfo på disken i fråga.

Det konstiga är att om jag kopplar in disken till en annan dator så funkar det fint. På den datorn har jag kört diagnos på disken, kollat smart info osv. utan att hitta något anmärkningsvärt. Allt funkar perfekt. Tänkte att disken kanske fungerar efter att den andra datorn fått gå igenom den ordentligt, men sådan tur hade jag inte.

Jag önskar tips på vad jag ska göra härifrån.
Tror ni att jag på något sätt kan få disken att funka med min huvuddator igen?
Eller kanske jag helt enkelt ska byta ut den oavsett? Även om min reservdator tycker att den är helt ok?

Permalänk
Medlem

Vilket moderkort?

Har du ändrat någon hårdvara sen det slutade fungera?

Vilka m2/sata portar används just nu och vilken port är det som får det att funka igen när den kopplas ur?

Permalänk
Festpilot 2020, Antiallo
Skrivet av giplet:

Idag när jag startade om min dator så kunde den inte boota. Först fastnade den på bootloggan med snurrande prickar. Efter att jag försökt tvinga in den i repair mode så fick jag istället två olika fel, En enhet som är ansluten fungerar inte 0xc0000025 och sedan att det saknas bootinformation 0xc0000098. Det gick inte att reparera Windows bootinformation med Windows installationsmedium.

Efter att ha börjat plocka bort och sätta tillbaka enheter i datorn märker jag att detta beror på en specifik disk. Så fort disken är inkopplad så vägrar datorn boota, men kopplar jag ur disken så startar datorn fint. Det är inte en bootdisk och har aldrig varit en bootdisk. Det finns ingen bootinfo på disken i fråga.

Det konstiga är att om jag kopplar in disken till en annan dator så funkar det fint. På den datorn har jag kört diagnos på disken, kollat smart info osv. utan att hitta något anmärkningsvärt. Allt funkar perfekt. Tänkte att disken kanske fungerar efter att den andra datorn fått gå igenom den ordentligt, men sådan tur hade jag inte.

Jag önskar tips på vad jag ska göra härifrån.
Tror ni att jag på något sätt kan få disken att funka med min huvuddator igen?
Eller kanske jag helt enkelt ska byta ut den oavsett? Även om min reservdator tycker att den är helt ok?

Är det ingen super-wow-disk så hade jag avvecklat den. Iaf lagt den i lådan med "troligen trasig hårdvara som jag inte orkar felsöka just nu".

Permalänk
Medlem

Batteriet på moderkortet har dött och biosinställningarna återställts så att den bootar från denna disken? Öppna bootmenyn och välj den rätta disken

Permalänk
Moderator
Skrivet av MeSaber:

Vilket moderkort?

Har du ändrat någon hårdvara sen det slutade fungera?

Vilka m2/sata portar används just nu och vilken port är det som får det att funka igen när den kopplas ur?

Ingenting har ändrats. Möjligt att det installerats någon Windowsuppdatering, men annars ingen skillnad mot när datorn bootades om senast, igår.

Moderkortet är ett ASUS Prime X570-P. Inklusive den strulande disken så har jag en NVMe disk, en SATA SSD, två SATA HDD och en Blurayspelare. Den strulande disken är en SATA HDD på 2TB från Seagate.

Just nu vet jag inte exakt vilken port disken är inkopplad till. Jag hade också en fundering på om jag skulle prova en annan port och kabel. Tyvärr så sitter grafikkortet över SATA-portarna, så det är sjukt bökigt att möblera om detta.

Edit: Provade att koppla disken med en ny SATA-kabel till en port som gick lätt att komma åt. Det gick inte bättre det. Provade också att koppla in den med en strömkabel från en annan disk som fungerar, så det var inte det heller. Skumt detta.

Permalänk
Moderator
Skrivet av Larrxi:

Batteriet på moderkortet har dött och biosinställningarna återställts så att den bootar från denna disken? Öppna bootmenyn och välj den rätta disken

Nej, det är inte problemet. BIOS säger att det är min NVMe disk som är bootdisk både med och utan denna disken inkopplad.

Skrivet av DavidtheDoom:

Är det ingen super-wow-disk så hade jag avvecklat den. Iaf lagt den i lådan med "troligen trasig hårdvara som jag inte orkar felsöka just nu".

Ja, det lutar starkt åt det. Problemet är bara hur jag ska få ur datan. Min backupdator har inte så många SATA-portar. Får väl kopiera över nätverket.

Permalänk
Medlem

Förståeligt.. Men få se här nu. Disken på 2TB har suttit i hela tiden och inte förrän nu så slutar W10 boota utan att du ändrat någon hårdvara.

När du kopplar ur sata kabeln till 2TB disken så rullar systemet som det ska. Samt att denna disk fungerar felfritt i en annan dator.

Prova som @Larrxi skriver om ditt BIOS har återställts till Default. Har det det så byt batteri. I övrigt kolla över vilka diskar som sitter vart, enligt manualen så har du inga begränsningar på X570 så du ska kunna använda alla portar samtidigt. Som du säger kan ju ett test vara att byta port på 2TB disken.

Permalänk
Moderator
Skrivet av MeSaber:

Förståeligt.. Men få se här nu. Disken på 2TB har suttit i hela tiden och inte förrän nu så slutar W10 boota utan att du ändrat någon hårdvara.

När du kopplar ur sata kabeln till 2TB disken så rullar systemet som det ska. Samt att denna disk fungerar felfritt i en annan dator.

Prova som @Larrxi skriver om ditt BIOS har återställts till Default. Har det det så byt batteri. I övrigt kolla över vilka diskar som sitter vart, enligt manualen så har du inga begränsningar på X570 så du ska kunna använda alla portar samtidigt. Som du säger kan ju ett test vara att byta port på 2TB disken.

Helt korrekt uppfattat. Har kollat BIOS och den har inte återställts.
Lutar väl åt att det är något halvknas med disken även om den andra datorn accepterar den utan problem.

Permalänk
Medlem

Du kan ju som uteslutande prova låna en SATA port från en av de diskar som fungerar.

När du provade i den andra datorn bytte du kabel då eller använde du samma som satt i burken du felsöker nu?

Permalänk
Moderator
Skrivet av MeSaber:

Du kan ju som uteslutande prova låna en SATA port från en av de diskar som fungerar.

När du provade i den andra datorn bytte du kabel då eller använde du samma som satt i burken du felsöker nu?

Har provat ny kabel och ny port på moderkortet. SATA-kabeln i backupdatorn sitter normalt kopplad till en DVD-spelare i den burken. Flyttade helt enkelt över kontakterna.

Permalänk
Moderator

Har börjat föra över 670GB data över nätverket nu. :-|

Permalänk
Medlem

Man får beklaga besväret.

Permalänk
Moderator

Det står 2013 på disken, så man kanske inte behöver vara allt för överraskad att den börjar bli lite trött.

Permalänk
Medlem

Gör backup först - sedan har Seagate dignostik-program som kan kolla om diskarna är uppenbart dåliga.

En sak att prova med och som brukar 'laga' diskar om de verkar småbråkiga - är att med 'dd' (under linux) skriver hela disken med '0' från första till sista sektorn och sedan provar att läsa detta hela vägen - då brukar pending error och annat nollställas och eventuellt kanske enstaka reallokerade sektorer räknas upp (är det många i antal på en gång så skall man nog inte använda disken till något viktigt utan enbart som slask/temporärt och att all data kan förloras utan konsekvens), en variant på detta i windows är att man med veracrypt gör en disk-kryptering och sedan gör full formatering - vilket också tvingar på en full skrivning från början till slut.

Det är flertal snurrdiskar som 'räddas' och blivit skötsamma igen lång tid efter en sådan full skrivning, att det är värt att prova. Det är tom. så att diskar som dömts ut av disktillverkarnas egna diagnostik-program, efter en sådan omgång gå igenom provet igen utan några anmärkningar alls.

Det finns dock ett undantag - och påfallande gälla ofta på WD-green 3.5" från runt 2010-14 och även på WD 2.5" USB-diskar som WD passport, passport ultra. wd-elements - kontrollerkorten på diskarna, när de börja bråka så är det inte mycket hopp och det är tiden som kontrollerkortet är strömsatt som räknas även om spindeln hålls avstängd mesta delen av tiden - ligger disken lös, oansluten i en hylla (som en extern USB-disk undanstuvad tex.) så håller det betydligt bättre, men med spänning på i 24/7 (även med spindelmotorn avstängd) så kommer problemen vid runt 35-40 tusen timmar ansluten tid och börja med att den blir värmekänslig och börja dumma sig vid skrivning och läsning när det är lite mer intensivt (och därmed blir varmare) medans sval så går det oftast bra ( och var ofta en förutsättning vid dataräddning när det gått så långt att folk märkt att det är problem)

och till slut de diskar som klarar sig förbi 35000 - 45000 timmar inkopplat kan bli väldigt gamla och ger timsiffror som sjutti till över hundra tusen timmar är inte ovanligt i maskiner som stå bortglömda påslagna år efter år typisk på företag

Permalänk
Rekordmedlem

Prova att köra minnestest på datorn som strular.