Ssd syns inte när m.2 är installerad (och tvärtom)

Permalänk
Medlem

Ssd syns inte när m.2 är installerad (och tvärtom)

Hej!

Moderkort: asus rog strix b550-f

Jag hade 2 ssd diskar och 2 hårddiskar inkopplade vilket funkade perfekt. När jag installerade en ny m.2 disk (wd sn750) så funkar antingen alla (sata) ssd diskar och hårddiskar eller bara m.2 disken.

Jag har kopplat in sata diskarna i port 1-4 för att 5-6 skulle inte funka när 2 st m.2 diskar var inkopplade. Detta borde inte spela någon roll eftersom jag endast har en m.2 disk.

M.2 disken är installerad i den övre porten (viket stod i bruksanvisningarna).

All hjälp godtags.

Permalänk
Medlem

Jag skulle testa att lämna 1&2 tomt

Permalänk
Medlem
Skrivet av StuntmanMike:

Jag skulle testa att lämna 1&2 tomt

Tyvärr funkade det inte heller

Permalänk
Medlem
Skrivet av Jacobo99:

Tyvärr funkade det inte heller

Står garanterat i instruktionerna för mobo.

Permalänk
Medlem

Kan vara något liknande som jag råkade ut för, med M.2 så fungerar bara 1 sata port.
Kortet är ett gigabyte aorus master z390

Permalänk
Medlem
Skrivet av smygolf:

Kan vara något liknande som jag råkade ut för, med M.2 så fungerar bara 1 sata port.
Kortet är ett gigabyte aorus master z390

Var det fel på moderkortet då? Fick du ett nytt som fungerade som det skulle?

Permalänk
Medlem

Den övre M2 platsen går via CPUn, och den nedre via chipset.

Vad har du för CPU ??
Är BIOS up to date, så att det inte beror på kompabilitetsproblem ?!

Permalänk
Medlem

Vet inte riktigt vad ditt problem är exakt. Men när jag bytte till m.2 på mitt asus x-470-f moderkort. Så kunde jag inte hitta den i bios osv.. Men det här löste mitt problem.

The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

Permalänk
Medlem

I manualen står att när m2 används inaktiveras sata6_5/6

https://dlcdnets.asus.com/pub/ASUS/mb/SocketAM4/ROG_STRIX_B55...
Avsnitt 1-11

Permalänk
Medlem
Skrivet av orig_rejser:

I manualen står att när m2 används inaktiveras sata6_5/6

https://dlcdnets.asus.com/pub/ASUS/mb/SocketAM4/ROG_STRIX_B55...
Avsnitt 1-11

När man kör M2 över chipset, dvs den nedre M2 platsen, så inaktiveras sata 5 och 6.

TS har sata 1 - 4 inkopplade, och kör med den övre M2 platsen som går via CPUn.

Permalänk
Medlem
Skrivet av Jacobo99:

Var det fel på moderkortet då? Fick du ett nytt som fungerade som det skulle?

Det är så kortet är byggt, ser man ovan så är det inget ovanligt

Permalänk
Medlem
Skrivet av TechWolf:

Den övre M2 platsen går via CPUn, och den nedre via chipset.

Vad har du för CPU ??
Är BIOS up to date, så att det inte beror på kompabilitetsproblem ?!

Jag har 5600x

Permalänk
Medlem
Skrivet av walkiii:

Vet inte riktigt vad ditt problem är exakt. Men när jag bytte till m.2 på mitt asus x-470-f moderkort. Så kunde jag inte hitta den i bios osv.. Men det här löste mitt problem.

The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

Tack, ska verkligen testa det

Permalänk
Medlem
Skrivet av smygolf:

Det är så kortet är byggt, ser man ovan så är det inget ovanligt

I min manual står det att jag kan använda 1 st m.2 och 6 st sata eller 2 st m.2 och 4 st sata