Excel fråga: Leta rad och lägg ihop värden?

Permalänk
Medlem

Excel fråga: Leta rad och lägg ihop värden?

Jag håller på att sammanställa min inte så stora men ändå existerande cryptoportfölj. På bladet "inköp" har jag valuta i kolumn B och mängd i kolumn C.

Dvs typ
BTC 0,001
XLM 100
BTC 0,003
XRP 300

osv

Sen har jag ett samlingsblad där jag lägger ihop hur mycket jag har av varje valuta från inköpsbladet, och då har jag valuta i A och mängd i B.

Jag tänkte vara smart och använda mig av leta rad och sedan bara hitta alla av matchande valuta och lägga ihop det, så jag skrev

=SUMMA(LETARAD(A4,Inköp!B:C,2,FALSKT))

men varför vill den inte lägga ihop alla värden av matchande valuta? Svaret jag får är 0,001 BTC trots att jag borde få 0,004.

Hjälp!

Permalänk
Medlem

Det är en pivottabell du ska använda dig av för att uppnå det du vill göra

https://www.excelbrevet.se/skapa-pivottabell-vad-ar-en-pivott...

Permalänk
Medlem
Skrivet av PlogarN97:

Det är en pivottabell du ska använda dig av för att uppnå det du vill göra

https://www.excelbrevet.se/skapa-pivottabell-vad-ar-en-pivott...

Jo jag tänkte det först, men sen kom jag på att jag vill att värdena ska uppdateras i plånboken varje gång jag lägger till något i inköps bladet, och jag vet inte hur man gör det i en pivot eller om det ens går.

Permalänk
Medlem

Du löser det enkelt med sumif()
If-funktionen för de olika valutorna, och summa för antalet.

Permalänk
Medlem
Skrivet av lundqan:

Du löser det enkelt med sumif()
If-funktionen för de olika valutorna, och summa för antalet.

Kanon, tack!

Permalänk
Medlem
Skrivet av lundqan:

Du löser det enkelt med sumif()
If-funktionen för de olika valutorna, och summa för antalet.

Detta funkar oftast bra men ska du hantera stora mängder med data är index+match eller sumproduct bättre.

Men klart enklast är ju pivot.