Synology DS220+ + Comhem = Funkar inte

Permalänk
Medlem

Synology DS220+ + Comhem = Funkar inte

Jag har en setup här hemma där jag har all media på en Synology DS220+. Använder kodi/jellyfish på TV/platta/mobil för att konsumera media. Så långt funkar allt skitbra!

Men har ett problem. NASen vill aldrig gå in i hibernate mode. Dvs att den stänger av hårddiskarna och minskar på fläkthastigheten. Just nu så är allt igång fullt ös dygnet runt. Inte så bra för hårddiskarna kanske men det konstanta ljudet är också störande. Tanken är att NASen ska gå in i hibernate mode och sova tills jag via kodi/jellyfish vill titta på något och att den då spinner upp hårddiskarna.

Har varit i kontakt med Synologys support och vi har gått igenom allt. Problemet ligger tydligen i routern från Comhem, förmodligen så pingar den till NASen hela tiden och håller den vaken.

Jag testade att sätta routern i bryggat läge men då försvann all internetåtkomst och jag hade svårt att ens nå routern från laptopen som var inkopplad med ethernetkabel.

Är det kanske någon inställning i routern som är fel? Jag har satt fast IP-adress på NASen i routern, så att den alltid har samma.

Hjälp

Permalänk
Arvid Nordqvist-mannen

Diskar kan ta skada av att spinna ned/upp "hela tiden" Sen bör också NAS-certade diskar användas.

Jag tror att Comhem har MAC-lås, när du bryggade din CH-Router släpps all trafik genom till din router direkt, man kopplar förbi leverantörens egna enhet och således får din router ingen IP från CH. Du får vänta tills låset släpps eller klicka dig runt i CH-Routerns gränssnitt och leta efter Release IP, IPConfig /release eller liknande.

Om du inte har en router från CH ska du absolut inte brygga din egna router.

Permalänk
Medlem
Skrivet av tcntad:

Diskar kan ta skada av att spinna ned/upp "hela tiden" Sen bör också NAS-certade diskar användas.

Jag tror att Comhem har MAC-lås, när du bryggade din CH-Router släpps all trafik genom till din router direkt, man kopplar förbi leverantörens egna enhet och således får din router ingen IP från CH. Du får vänta tills låset släpps eller klicka dig runt i CH-Routerns gränssnitt och leta efter Release IP, IPConfig /release eller liknande.

Om du inte har en router från CH ska du absolut inte brygga din egna router.

Tack för svar!
Jag har WD Red (CMR) diskar i den. Det är alltså bättre att låta dom gå varma? :S Sett att andra också säger så men jag har hellre dom i hibernate och byter ut disken/diskarna efter några år än att behöva stå ut med oljudet till vardags.

Det enda jag har är routern/modemet från Comhem (Com Hem WiFi Hub C2). Letade igenom inställningarna men hittade ingen liknande funktion.

Ska ringa dom imorgon och se ifall dom vet något mer.

Permalänk
Arvid Nordqvist-mannen

Arbetar dem inte så blir de inte varmare än temp i NAS:en och sålänge de inte överstiger maxspeccad temp är det OK.
PS. Du kan behöva byta disk imorgon, du vet aldrig när en kommer att dö:P

Du kanske bara behöver vänta ca halvtimme eller så, allt beroende på hur lång leasetid CH har på sina prylar.

Permalänk
Medlem

Vad har routern med något att göra?

Handlar det om WoL så kommer inte trafiken från routern, du ska dessutom ställa in vilken enhet den får vakna när den får trafik ifrån.

Eventuella begränsningar är från Synology. Lär dig dessa, ingen kommer hjälpa dig.

Permalänk
Medlem
Skrivet av tcntad:

Arbetar dem inte så blir de inte varmare än temp i NAS:en och sålänge de inte överstiger maxspeccad temp är det OK.
PS. Du kan behöva byta disk imorgon, du vet aldrig när en kommer att dö:P

Du kanske bara behöver vänta ca halvtimme eller så, allt beroende på hur lång leasetid CH har på sina prylar.

De klart Kollar med de imorgon om det. Tack!

Skrivet av Petterk:

Vad har routern med något att göra?

Handlar det om WoL så kommer inte trafiken från routern, du ska dessutom ställa in vilken enhet den får vakna när den får trafik ifrån.

Eventuella begränsningar är från Synology. Lär dig dessa, ingen kommer hjälpa dig.

Jag har varit i kontakt med Synologys support i två veckors tid nu. Supportkillen och jag har testat en massa saker för att undanröja så det inte är något fel på NASen. Det enda som kan hålla NASen i vaket tillstånd är routern. Vi har bland annat testat att disconnecta alla enheter och endast låta NASen vara inkopplad till routern. Den håller sig vaken, så fort jag disconnectar NASen från routern så somnar den som den ska.

Vilka begränsningar skulle det vara på NASen?

Permalänk
Medlem
Skrivet av Mirialia:

De klart Kollar med de imorgon om det. Tack!

Jag har varit i kontakt med Synologys support i två veckors tid nu. Supportkillen och jag har testat en massa saker för att undanröja så det inte är något fel på NASen. Det enda som kan hålla NASen i vaket tillstånd är routern. Vi har bland annat testat att disconnecta alla enheter och endast låta NASen vara inkopplad till routern. Den håller sig vaken, så fort jag disconnectar NASen från routern så somnar den som den ska.

Vilka begränsningar skulle det vara på NASen?

Är det svårt att koppla in en switch? Hjälper det? Det är du som får kolla vad det är för trafik som håller den vaken, det är inget något annan kan hjälpa dig med. Det är inte så mycket annat än DHCP och UPNP på en router.

Du behöver kunna analysera trafiken, annars kommer du bara ersätta med en annan router som gör samma sak.

Permalänk
Medlem
Skrivet av Petterk:

Är det svårt att koppla in en switch? Hjälper det? Det är du som får kolla vad det är för trafik som håller den vaken, det är inget något annan kan hjälpa dig med. Det är inte så mycket annat än DHCP och UPNP på en router.

Jag har ingen switch och vet inte vad DHCP eller UPNP gör.

Permalänk
Medlem
Skrivet av Mirialia:

Jag har ingen switch och vet inte vad DHCP eller UPNP gör.

Redigerade samtidigt som du svarade.

Skrivet av Petterk:

Du behöver kunna analysera trafiken, annars kommer du bara ersätta med en annan router som gör samma sak.

Permalänk
Medlem
Skrivet av Petterk:

Redigerade samtidigt som du svarade.

Detta tänker jag mig att Comhem kan hjälpa mig med. De bör väl kunna se i loggar eller inställningar vad det är som pingar NASen. Jag har tittat så gott jag kan i routerns loggar/inställningar men inte kunnat hitta något. Testade även att mha docker installera Netdata och analysera datan därifrån men kunde inte hitta något annat än att det är något som kontinuerligt pingar NASen. Se bifogad bild.

Permalänk
Medlem
Skrivet av Mirialia:

Detta tänker jag mig att Comhem kan hjälpa mig med. De bör väl kunna se i loggar eller inställningar vad det är som pingar NASen. Jag har tittat så gott jag kan i routerns loggar/inställningar men inte kunnat hitta något. Testade även att mha docker installera Netdata och analysera datan därifrån men kunde inte hitta något annat än att det är något som kontinuerligt pingar NASen. Se bifogad bild.

https://i.ibb.co/sHPdPcf/network.png

Nej ingen annan än du kan kolla trafiken i nätverket.

Du får ställa in switchen att skicka all data till din dator och köra Wireshark.

Permalänk
Medlem
Skrivet av Petterk:

Nej ingen annan än du kan kolla trafiken i nätverket.

Du får ställa in switchen att skicka all data till din dator och köra Wireshark.

Wireshark låter intressant. Har du någon guide på hur jag ställer in routern/datorn?
Har ingen switch.

Permalänk
Medlem
Skrivet av Mirialia:

Har ingen switch.

Skaffa en som du kan ställa in "monitoring port" på.

Routern har inte med saken att göra.

Finns gott om resurser om Wireshark.

Permalänk
Medlem
Skrivet av Petterk:

Skaffa en som du kan ställa in "monitoring port" på.

Routern har inte med saken att göra.

Finns gott om resurser om Wireshark.

Vilken, helst billig, switch rekommenderar du?

Permalänk
Medlem
Skrivet av Mirialia:

Vilken, helst billig, switch rekommenderar du?

Netgear GS108E eller GS105E har den funktionen, andra billiga också.

Ingen kommer ge dig en färdig lösning om du inte vill betala typ 5000 kr här. Så vida inte Synology ger exempel på funktioner som kan störa kan du inte sitta och gissa dig till och stänga av på måfå utan behöver ta reda på vad det är för trafik. Alternativt så kör du en egen router som är känd att fungera med WoL.

Permalänk
Medlem
Skrivet av Petterk:

Netgear GS108E eller GS105E har den funktionen, andra billiga också.

Ingen kommer ge dig en färdig lösning om du inte vill betala typ 5000 kr här. Så vida inte Synology ger exempel på funktioner som kan störa kan du inte sitta och gissa dig till och stänga av på måfå utan behöver ta reda på vad det är för trafik. Alternativt så kör du en egen router som är känd att fungera med WoL.

De var rätt dyrt.

Har installerat Wireshark via docker på NASen nu, ska se om jag kan se hur trafiken ser ut via den. Lite svårt att få den att sniffa dock. Ska söka efter guider.

Jag vet inte varför du fortfarande tror det är fel på NASen? Det var inte på måfå, utan vi stängde av allt. Och satte igång en sak i taget i princip för att se vad det är som orsakar problemet.

Permalänk
Medlem
Skrivet av Mirialia:

De var rätt dyrt.

Vad syftar du på? GS105E kostar 350-400 kr.

Skrivet av Mirialia:

Har installerat Wireshark via docker på NASen nu, ska se om jag kan se hur trafiken ser ut via den. Lite svårt att få den att sniffa dock. Ska söka efter guider.

Vet inte om du ser all trafik via docker.

Skrivet av Mirialia:

Jag vet inte varför du fortfarande tror det är fel på NASen? Det var inte på måfå, utan vi stängde av allt. Och satte igång en sak i taget i princip för att se vad det är som orsakar problemet.

Det har jag väl inte påstått? Du behöver däremot veta om det är UPnP, DHCP eller någon annan funktion som ställer till det. En del routrar fungerar inte med WoL (att väcka), men för att somna ska det inte inverka.

En sak du kan testa som är gratis är att köra nätverkskabel direkt mellan dator och NAS, och då fungerar det förmodligen, men det hjälper dig inte att läsa trafiken.

Självklart är det på måfå om du inte kollat trafiken. UPnP ställer ofta till det dock.

Permalänk
Medlem
Skrivet av Petterk:

Vad syftar du på? GS105E kostar 350-400 kr.

Vet inte om du ser all trafik via docker.

Det har jag väl inte påstått? Du behöver däremot veta om det är UPnP, DHCP eller någon annan funktion som ställer till det. En del routrar fungerar inte med WoL (att väcka), men för att somna ska det inte inverka.

En sak du kan testa som är gratis är att köra nätverkskabel direkt mellan dator och NAS, och då fungerar det förmodligen, men det hjälper dig inte att läsa trafiken.

Självklart är det på måfå om du inte kollat trafiken. UPnP ställer ofta till det dock.

Switchen var rätt dyr. Vill försöka fixa detta utan några kostnader. Hade det funkat att sniffa trafiken genom att koppla så här:

NAS --- ethernetkabel --- Laptop med Wireshark --- ethernetkabel --- Router

Och då avläsa trafiken som går igenom? Att Laptopen bara funkar som en tunnel/brygga. Typ något liknande detta: https://ask.wireshark.org/question/1073/help-to-set-up-a-pass...

WoL har jag inte ens testat, har inte den funktionen aktiverad.
Hibernate mode innebär bara att hårddiskarna slutar spinna, men NASen är fortfarande aktiv.

Jag testade att stänga av UPnP IGd i routern men det ändrade inte något.

Permalänk
Medlem
Skrivet av Mirialia:

Switchen var rätt dyr. Vill försöka fixa detta utan några kostnader. Hade det funkat att sniffa trafiken genom att koppla så här:

NAS --- ethernetkabel --- Laptop med Wireshark --- ethernetkabel --- Router

Och då avläsa trafiken som går igenom? Att Laptopen bara funkar som en tunnel/brygga. Typ något liknande detta: https://ask.wireshark.org/question/1073/help-to-set-up-a-pass...

WoL har jag inte ens testat, har inte den funktionen aktiverad.
Hibernate mode innebär bara att hårddiskarna slutar spinna, men NASen är fortfarande aktiv.

Jag testade att stänga av UPnP IGd i routern men det ändrade inte något.

Vad har routern med något att göra om du inte pratar om WoL? Routern är inte kopplad med SMB till din NAS. Du får nog titta på tjänsterna NASen kör som pratar med internet.

Gör så här, koppla ur routern från nätet och ha inget annat anslutet till routern än NAS. Somnar diskarna nu? Om ja så har det inte med routerns funktioner att göra.

Permalänk
Medlem
Skrivet av Petterk:

Vad har routern med något att göra om du inte pratar om WoL? Routern är inte kopplad med SMB till din NAS. Du får nog titta på tjänsterna NASen kör som pratar med internet.

Gör så här, koppla ur routern från nätet och ha inget annat anslutet till routern än NAS. Somnar diskarna nu? Om ja så har det inte med routerns funktioner att göra.

Jag tror att routern har någon inställning där den pingar enheterna som är uppkopplade mot den kontinuerligt. Bara en amatörmässig gissning från min sida baserat på allt jag testat. Och att denna ping gör så att NASen inte sätter hårddiskarna i hibernation mode.

På NASen har jag stängt av alla tjänster och paket.

Tack, jag ska testa ditt förslag så fort jag hinner.

Permalänk
Medlem
Skrivet av Mirialia:

Jag tror att routern har någon inställning där den pingar enheterna som är uppkopplade mot den kontinuerligt. Bara en amatörmässig gissning från min sida baserat på allt jag testat. Och att denna ping gör så att NASen inte sätter hårddiskarna i hibernation mode.

På NASen har jag stängt av alla tjänster och paket.

Tack, jag ska testa ditt förslag så fort jag hinner.

Framsteg? Motgångar?

Behövs nog testas lite, tror inte på din teori om ICMP-paket och eftersom det inte handlar om WoL så har det förmodligen inget att göra med UPnP/NAT-PMP/DHCP eller hur routern beter sig.

Permalänk
Medlem
Skrivet av Petterk:

Framsteg? Motgångar?

Behövs nog testas lite, tror inte på din teori om ICMP-paket och eftersom det inte handlar om WoL så har det förmodligen inget att göra med UPnP/NAT-PMP/DHCP eller hur routern beter sig.

Hej!

Har varit lite upptagen på annat håll och är svårt att hitta en tid när andra i hushållet får klara sig utan bredbandet :D.

Testat nu och du hade rätt. Med följande

NAS --- ethernet --- router --- inget

Här somnade NASen och hårddiskarna sattes i viloläge. Hände efter ungefär 10 minuter (som det är konfigurerat att göra). Hårddiskarna vaknade dock upp inom någon minut. Var igång en stund och somnade om sen vid ca 30 minuter efter att jag kopplat bort internetsladden. Sen dess har den sovit i nu ca 20 minuter.

NAS --- ethernet --- router --- Internet

I detta läge så ville inte NASen somna alls. Detta testade jag med Synologys support. Den somnade först när jag kopplade bort NASen från routern.

Då borde det alltså vara något från NASen som kontaktar nätet eller något från nätet som kontaktar den?

Ska försöka att koppla in en mobil/dator åt gången i routern (fortfarande med nätet bortkopplat) för att se ifall det är någon av dom som håller den vaken.

Permalänk
Medlem

Gjort lite fler tester. Efter att ha kopplat ur alla enheter och routern från nätet med endast NASen inkopplad så gjorde jag så här:

1) Kopplade in datorn via WiFi. NASen vaknade direkt. Kopplade därefter bort datorn från WiFi och NASen somnade efter 10 minuter. Så tänkte att det är väl datorn som håller den vaken. Fortsatte med fler tester:

2) Endast NASen är inkopplad till routern som inte är uppkopplad mot nätet. Därefter kopplade jag på en enhet i taget.

3) AndroidTV påkopplad med ethernet och igångsatt. Ingen reaktion från NASen efter 5 minuter.

4) Xbox påkoppad med ethernet och igångsatt. Ingen reaktion från NASen efter 5 minuter.

5) Android mobil påkopplad med WiFi. Ingen reaktion från NASen efter 5 minuter.

6) Ipad påkopplad med WiFi. Ingen reaktion från NASen efter 5 minuter.

7) 2 Google Home enheter påkopplade via Wifi. Ingen reaktion från NASen efter 5 minuter.

8) Nu när alla enheter är påkopplade och endast datorn kvar, så skulle NASen nog vaknade upp som den gjorde i början. Så istället så lät jag alla enheter vara påkopplade förutom datorn. Sen kopplade jag upp routern mot nätet. Det tog 1-2 minuter men NASen vaknade till liv.

Så det verkar som att både datorn och nätet håller NASen vaken. Vilket är konstigt eftersom jag gått igenom Synologys lista över och deaktiverat allt enligt den. Nästa steg är väl att kolla paketen som skickas.

https://www.synology.com/en-us/knowledgebase/DSM/tutorial/Man...

Permalänk
Medlem
Skrivet av Mirialia:

Hej!

Har varit lite upptagen på annat håll och är svårt att hitta en tid när andra i hushållet får klara sig utan bredbandet :D.

Testat nu och du hade rätt. Med följande

NAS --- ethernet --- router --- inget

Här somnade NASen och hårddiskarna sattes i viloläge. Hände efter ungefär 10 minuter (som det är konfigurerat att göra). Hårddiskarna vaknade dock upp inom någon minut. Var igång en stund och somnade om sen vid ca 30 minuter efter att jag kopplat bort internetsladden. Sen dess har den sovit i nu ca 20 minuter.

NAS --- ethernet --- router --- Internet

I detta läge så ville inte NASen somna alls. Detta testade jag med Synologys support. Den somnade först när jag kopplade bort NASen från routern.

Då borde det alltså vara något från NASen som kontaktar nätet eller något från nätet som kontaktar den?

Ska försöka att koppla in en mobil/dator åt gången i routern (fortfarande med nätet bortkopplat) för att se ifall det är någon av dom som håller den vaken.

Eftersom du hade testat – om jag förstod det rätt – med enbart NAS kopplad till routern så kan det vara något den tar kontakt med på nätet och sen fortsätter att hålla kontakt med. Dina andra enheter kan givetvis hindra den också. Kräver nog lite mer grävande hur som helst

Permalänk
Medlem
Skrivet av Petterk:

Eftersom du hade testat – om jag förstod det rätt – med enbart NAS kopplad till routern så kan det vara något den tar kontakt med på nätet och sen fortsätter att hålla kontakt med. Dina andra enheter kan givetvis hindra den också. Kräver nog lite mer grävande hur som helst

Såg nu att det kan vara SMB på min windows dator som håller den vaken (på lokalt håll - som du nämner så verkar det även vara något den försöker kontakta på nätet). Ska testa med att stänga av SMB också för att se hur det ser ut.

Skickade även en debug logg till Synology efter dagens fyndigheter.

Permalänk
Permalänk
Medlem
Skrivet av tcntad:

Det är kanske inte SMB då det bara är ett protokoll. Däremot kan exempelvis kan nätverksidentifiering mm söka efter enheter.

https://community.synology.com/enu/forum/1/post/131608
https://community.synology.com/enu/forum/1/post/130317

Läser man den tråden så finns också att pröva:

* Uppdatera firmware (DSM) - vilken kör du?

* Låsa ip-adressen till fast i NAS:en, borde finnas med i inställningar någonstans. (har nog så om jag minns rätt på min men det är en gammal sketen Netgear)

"I had this issue initially which was resolved once I set static IPs for networks, this is not in Synology's article quoted above."

Permalänk
Medlem

Tror inte det finns nån bredbandsupport du kan ringa till som kan hjälpa dig med detta. Det blir nog mest "funkar det att surfa, mäter bredbandskollen bra, är nätet OK på din dator?" Jepp. "Jaha då funkar vår tjänst tack och hej."

Det enda jag kan tipsa om är att det finns management även på "bryggade" modem/routrar, supporten kan nog ge dig rätt IP till denna - det är inte samma som ifall du har NAT på i routern.

Permalänk
Medlem
Skrivet av tcntad:

Det är kanske inte SMB då det bara är ett protokoll. Däremot kan exempelvis kan nätverksidentifiering mm söka efter enheter.

https://community.synology.com/enu/forum/1/post/131608
https://community.synology.com/enu/forum/1/post/130317

Intressanta trådar. Tack för länkarna. Skulle mycket väl kunna vara något sådant. Väntar just nu på att Synology ska komma tillbaka med deras rapport från debug filen. Hittar de inget så kommer jag köra laptopen med wireshark mellan NAS och router för att (med mina amatörmässiga skills ) försöka luska ut vad det är som händer.

Skrivet av orginallinus:

Läser man den tråden så finns också att pröva:

* Uppdatera firmware (DSM) - vilken kör du?

* Låsa ip-adressen till fast i NAS:en, borde finnas med i inställningar någonstans. (har nog så om jag minns rätt på min men det är en gammal sketen Netgear)

"I had this issue initially which was resolved once I set static IPs for networks, this is not in Synology's article quoted above."

Kör senaste DSM (6.2.4). Jag låste adressen till NASen första gången jag kopplade upp den i comhems router. Måste jag sätta statisk IP på alla uppkopplade enheter eller räcker det med NASen?

Skrivet av Parmenides:

Tror inte det finns nån bredbandsupport du kan ringa till som kan hjälpa dig med detta. Det blir nog mest "funkar det att surfa, mäter bredbandskollen bra, är nätet OK på din dator?" Jepp. "Jaha då funkar vår tjänst tack och hej."

Det enda jag kan tipsa om är att det finns management även på "bryggade" modem/routrar, supporten kan nog ge dig rätt IP till denna - det är inte samma som ifall du har NAT på i routern.

Har faktiskt inte kollat med Comhem. Försöker fixa det. I värsta fall, om det inte går att fixa, så får jag helt enkelt behålla den och sätta i en Noctua fläkt + stötdämpande åtgärder (såg någon mod med kardborreband).

Permalänk
Medlem
Skrivet av Mirialia:

Kör senaste DSM (6.2.4). Jag låste adressen till NASen första gången jag kopplade upp den i comhems router. Måste jag sätta statisk IP på alla uppkopplade enheter eller räcker det med NASen?

DHCP rullar på routern även om routern inte har internet.