Konstiga login-problem med Wordpress

Permalänk

Konstiga login-problem med Wordpress

Hej,

Jag fick plötsligt problem med att logga in på min wordpress via min PC. Jag fick ett säkerhetsfelmeddelade. Jag kontaktade då Hostgator där jag har websidan. Dom fixade problemet , vitlistade min IP och kollade om det fungerade att logga in. Dom kunde nu logga in på min wordpress ( via /wp-admin) men det kunde inte jag. Jag fick inga fler felmeddelanden, men när jag skriver in inloggningsuppgifterna och trycker enter så ser det bara ut som att sidan laddar om och inget händer. Jag kunde inte heller skapa ett nytt lösenord. Inget hände.
Hostgator skapade då nytt lösenord åt mig som jag noga sparade. Jag kunde dock fortfarande inte logga in. Dom testade mitt lösenord och kunde logga in.
Jag testade då att logga in med det nya lösenordet via min iMac istället och det fungerar.
Hostgator sa då att det måste vara min cache. Jag rensade all min cache (det gjorde dom med från sin sida). Det fungerade inte att logga in då heller.
min iMac och PC är på samma nätverk (samma router), men jag kan bara logga in från min iMac och inte från min PC. Dom är kopplade till samma router via ethernet (inget wifi).

Lista på vad jag testat på min PC:
Rensat all cache i alla internet browsers samt all historik
Provat från firefox, edge och chrome.
avaktiverat alla plugin jag kör i firefox.
Rensat all möjlig annan typ av cache även i windows.
Ominstallerat firefox.
Startat om routern 2 gånger.
Kört DNS flush via command.
Startat om datorn x antal gånger
Provat logga in både via wp-admin och wp-login.php
Uppdaterat wordpress (via min mac)

Kan fortfarande bara logga in från min iMac.

Det konstiga är att jag kan logga in via min Mac men inte via min PC. skillnaden på dem i själva användandet är att jag nästan aldrig stänger av macen. Jag loggar ofta in på min wordpress på via min PC i vanliga fall. Plötsligt går det inte.
En sak jag märkte är att när jag loggar in på min wordpress i vanliga fall så får jag meddelande från Wordfence att "någon" (jag) loggat in och det står staden jag loggat in från. Den staden har nu ändrats till en annan närliggande stad. Det är troligtvis det (jag spekulerar) som orsakade det initiala säkerhetsproblemet med min inloggning som hostgator då fick fixa med att vitlista. Men när dom löste det problemet hängde det kvar för mig att jag inte kan logga in via min PC, men supporten från hostgator i Indien kunde logga in därifrån och jag kan som sagt logga in från min andra dator i samma nätverk.

Hursomhelst. Jag vet inte vad mer jag ska prova!
Har brottats med detta i två dagar, då det är mycket viktigt att få detta fixat.
Tacksam för hjälp.

förtydligande
Permalänk
Medlem

Då du nämnde meddelande från Wordfence, om din leverantör provar med att temporärt stänga av alla tillägg på sidan (eller att du gör det själv genom att kommentera ut "plugins" mappen på FTP servern), kommer du in då?

Permalänk
Skrivet av ZimpanX:

Då du nämnde meddelande från Wordfence, om din leverantör provar med att temporärt stänga av alla tillägg på sidan (eller att du gör det själv genom att kommentera ut "plugins" mappen på FTP servern), kommer du in då?

Nej.
Det hade varit konstigt eftersom jag kommer in på min Mac men inte på min PC.

Permalänk
Medlem
Skrivet av spacemarcus:

Nej.
Det hade varit konstigt eftersom jag kommer in på min Mac men inte på min PC.

Är detta ett "Nej det fungerar fortfarande inte" eller "Nej, jag tänker inte prova då lösningen låter konstig"?

Menar du det senare, så skadar det inte att prova tycker jag då du redan provat allt annat. Och är redan märkligt nog att problemet som du beskriver det nu inte löstes med att rensa cache.

Det enda jag kan tänka mig annars är att du har en editerad hosts fil på Windows datorn som jävlas med dig.

Permalänk
Skrivet av ZimpanX:

Är detta ett "Nej det fungerar fortfarande inte" eller "Nej, jag tänker inte prova då lösningen låter konstig"?

Menar du det senare, så skadar det inte att prova tycker jag då du redan provat allt annat. Och är redan märkligt nog att problemet som du beskriver det nu inte löstes med att rensa cache.

Det enda jag kan tänka mig annars är att du har en editerad hosts fil på Windows datorn som jävlas med dig.

Hej igen,
Nej, jag provade det faktiskt efter att du sa det.

Vet du vad det var till slut? Det var Bitdefender (!) ... som lade sig i inloggningen. Jisses. JAg provade deaktivera det och loggade in.. fungerade!
Ännu mer otroligt var att jag löste det själv, och inte någon av de 4-5 tech supportrare jag pratat med på hostgator och telia

Men konstigt nog funkar det inte att vitlista URL:en(-erna) i bitdefender exceptions, så jag vet inte exakt vad det är som bitdefender reagerar på.

Permalänk
Medlem

Najs att det löste sig för dig!

Du nämnde att leverantören hade vitlistad din IP, har sidan legat tidigare för intrång möjligtvis? Har kanske med att göra dom fick Bitdefender att reagera.

Permalänk

Ja, något åt det hållet säkert.
Det var alltså host providern som fick vitlista mig i det som heter Mod_security som fungerar som en sorts brandvägg dom använder, som var det som reagerade som om jag själv var en potentiell attacker eller liknande. Mod_security ska skydda mot t.ex ddos och sådant, så som jag tolkar det. Den säkerhetflaggningen orsakad av detta triggade möjligen Bitdefender till att inte lita på antingen något url-relaterat eller något annat i inloggningsfunktionen... Gissar jag på...!