Permalänk
Medlem

Felsöka nätverkskort

Hej!

Jag har haft problem med mitt internet fram och tillbaka sedan årets början och tänkt att det handlar om routern eller leverantören. men börjar närma mig en slutsats om att det är nätverkskortet det är fel på.

Efter lite letande på internet och testande av olika åtgärder är det ingen skillnad.

Problemet är att mitt trådade funkar perfekt, mitt 2,4GHz funkar som det ska (men långsamt), och 5GHz kopplar upp sig men får inget internet på PCn.

Använder man sig av ipconfig får jag "media disconnected" på wifi.

Nätverksadaptern har uppdaterade drivrutiner.

Jag funderar på att lämna in hela datorn för felsökning då nätverksadaptern är integrerad i moderkortet (MSI B450I).

Innan jag tar det beslutet ville jag se om något geni i detta forum varit med om liknande och har tips.

Mvh
Robin

Permalänk
Medlem

Du skrev "uppdaterade" men inte vilken version. Använder din dator de absolut senaste drivarna för det Intel WiFi som finns på moderkortet?

Intel WIFI Driver, 22.70.0.6, Release Date 2021-09-02
https://www.msi.com/Motherboard/support/B450I-GAMING-PLUS-AC#...

Vad är det för WiFi router du ansluter till och vilket FW har det?

Permalänk
Medlem

Jag har den drivrutinen som du länkade till, samt denna laddade jag ner direkt från intels sida:
https://www.intel.com/content/www/us/en/products/sku/94854/in...

Routerns FW är inte uppdaterad till senaste gissar jag, men den är rätt ny då vi bytte leverantörer ganska nyligen. Det är comhems egna router, har även en asus rt-n56u dual band som presterar exakt likadant.

FW till asus är för övrigt: 3.4.3.9-099_d7fc2c1

Permalänk
Medlem

Hur ser din trådlösa omgivning ut? När jag (för typ 10 år sedan) felsökte WiFi åt kund på Alderholmen i Gävle dök det upp närmare 100 accesspunkter på 2.4 GHz och ett 50-tal på 5 GHz. Där var det då helt omöjligt att få till en tillförlitlig trådlös anslutning. Det var kabel som gällde. Se även till att döpa ditt SSID till något helt unikt så att det inte krockar med något befintligt trådlöst nätverk.

Permalänk
Medlem

Det ska vara lugnt på den fronten, får bra mottagning, och fungerar bra på övriga maskiner i hushållet. Kollar man "wifi analyzer" kan 5GHz bandet vara lite högtraffikerat på samma kanal och kan då byta över, men tror inte där problemet ligger. Detta känns mer kopplat till PCn i fråga eller eventuell dålig router. pekar mer mot något skumt på PCn.

Permalänk
Hjälpsam
Skrivet av Robbsternius:

Hej!

Jag har haft problem med mitt internet fram och tillbaka sedan årets början och tänkt att det handlar om routern eller leverantören. men börjar närma mig en slutsats om att det är nätverkskortet det är fel på.

Efter lite letande på internet och testande av olika åtgärder är det ingen skillnad.

Problemet är att mitt trådade funkar perfekt, mitt 2,4GHz funkar som det ska (men långsamt), och 5GHz kopplar upp sig men får inget internet på PCn.

Använder man sig av ipconfig får jag "media disconnected" på wifi.

Nätverksadaptern har uppdaterade drivrutiner.

Jag funderar på att lämna in hela datorn för felsökning då nätverksadaptern är integrerad i moderkortet (MSI B450I).

Innan jag tar det beslutet ville jag se om något geni i detta forum varit med om liknande och har tips.

Mvh
Robin

Har du angett vilken router och nätverkskort du har, i din fråga?

Varit med om att routern använde fler kanaler än internationell standard, detta gjorde att mitt nätverkskort kunde få problem.
Fanns en inställning som hette "Enable aditional channels", den bockade jag ur.

Permalänk
Medlem
Skrivet av Ratatosk:

Har du angett vilken router och nätverkskort du har, i din fråga?

Varit med om att routern använde fler kanaler än internationell standard, detta gjorde att mitt nätverkskort kunde få problem.
Fanns en inställning som hette "Enable aditional channels", den bockade jag ur.

Routern är en comhem standard och deras senaste. Nätverkskortet är integrerat i mobon, msi b450i.

Supporten gjorde en ändring där de ändrade kanal på 5GHz-bandet (vilket jag testat själv utan framgång) nu verkar det fungera okej, fast lite sämre hastighet och dippar ibland, men inte totalkollaps som innan.

Permalänk
Hjälpsam
Skrivet av Robbsternius:

Routern är en comhem standard och deras senaste. Nätverkskortet är integrerat i mobon, msi b450i.

Supporten gjorde en ändring där de ändrade kanal på 5GHz-bandet (vilket jag testat själv utan framgång) nu verkar det fungera okej, fast lite sämre hastighet och dippar ibland, men inte totalkollaps som innan.

Låter som att jag inte var helt fel ute, tråkigt dock, att du fortfarande får dippar.
Såg att nätverkskortet är ett Intel och de har så vitt jag vet gott rykte.
Har du hittat någon inställning för att slå på extra kanaler? Den skall i så fall, bockas ur.

Permalänk
Medlem

Prova att avinstallera drivrutinerna och "ta bort" WiFi kortet i Device manager. Starta om datorn och låt windows själv sköta drivisarna.

Ibland har jag haft problem med Intel WiFi kort när jag installerat nyare drivrutiner osv.

Permalänk
Medlem
Skrivet av Ratatosk:

Låter som att jag inte var helt fel ute, tråkigt dock, att du fortfarande får dippar.
Såg att nätverkskortet är ett Intel och de har så vitt jag vet gott rykte.
Har du hittat någon inställning för att slå på extra kanaler? Den skall i så fall, bockas ur.

Det verkar helt klart som att kanalen varit största boven, men upplever att nuvarande kanal som sagt är lite ostadigare i form av hastighet. Det finns ingen inställning om att få eller ta bort extra kanaler men listan sträcker sig till kanal 136.

Skrivet av Donhoz:

Prova att avinstallera drivrutinerna och "ta bort" WiFi kortet i Device manager. Starta om datorn och låt windows själv sköta drivisarna.

Ibland har jag haft problem med Intel WiFi kort när jag installerat nyare drivrutiner osv.

Detta var en av de första sakerna jag prövade, men tror som sagt att problemet ligger någon annanstans, men känns i alla fall som det inte är hårdvarufel längre. Det konstiga är dock att krascherna från innan kanalbytet var grövre på PCn än t ex TVn eller mobilen.