Nyss installerat om datorn och den betedde sig konstigt i början med frysningar sen med en oväntad krasch? Hur löser man detta så det ej händer igen?

Permalänk

Nyss installerat om datorn och den betedde sig konstigt i början med frysningar sen med en oväntad krasch? Hur löser man detta så det ej händer igen?

Jag har följande komponenter:

AMD Ryzen 5 1200 AF

MSI B450M PRO-M2 MAX

Corsair 16GB (2x8GB) DDR4 3200Mhz CL16 Vengeance

Crucial BX500 120GB

Seagate BarraCuda Desktop 1TB 7200rpm 64MB

Gigabyte GeForce GTX 1650 SUPER 4GB WINDFORCE OC

CORSAIR VS Series VS450 - Nätaggregat (intern) - ATX12V 2.31/ EPS12V 2.92 - 80 PLUS - AC 100-240 V - 450 Watt

Förord

Jag vill bara tillägga att innan jag gjorde en ominstallation av datorn, då kunde jag spela RDR2 eller Gta V och samtidigt som jag streamade och rendera videos med programmet DA Vinci Resolve i bakgrunden utan problem. Dock minns jag att frysningar/kraschar har hänt i början efter en ominstallation med den här datorn.

Problem 1
Igår installerade jag om min dator till samma OS som jag hade innan, alltså Windows 10. Efter installationen när jag började uppdatera med Windows update, då frös datorn varje gång, vilket i slutändan ledde till att jag fick starta om den. Mitt problem på lösningen var att jag gick in i BIOS och aktiverade XMP på slot 2. Vilket gjorde att den slutade frysa och allt funkade som det skulle.

Nu undrar jag varför löste det problemet? Kan det vara något fel på mina RAM-Minnen? Jag vill övrigt påpeka att jag köpte ram-minnena för 2 års sen och när jag var inne i BIOS igår så såg jag att de hade olika MHZ. Den 3200 och 2966 eller något, fast jag köpte de i samma paket och det skulle vara samma hastighet.

Anledningen till att jag satte XMP på slot 2 var för att den hade 3200 mhz, vilket kändes bra, då jag har förstått att XMP gör att ram-minnen presterar mer. I övrigt har datorn inte fryst mer sen detta aktiverades, hade igång den 15h igår, men laddade bara upp en massa saker till youtube och spelade inte något.

I övrigt har jag inte gjort något i BIOS efter ominstallationen, förutom XMP ändringen då, den var på OFF först innan jag satte den på ON.

Problem 2
Jag har mitt OS på en SSD 120 GB och min HDD 1TB låter lite mycket. Så idag gick jag in på energi-inställningar och ändrade tillbaka “Stäng av hårddisken” från 0 till 20 minuter. Då när jag satte den inställningen igår så trodde jag att detta skulle påverka SSD, men kom på att jag aldrig har ändrat den innan och det var faktiskt den som stängde av min HDD innan som gjorde att den inte lät så himla mycket.

Den stängde av min HDD faktiskt, när jag gick in på HDD hörde jag att den började låta igen, sen efter 10 minuter så blev skärmen SVART och musiken jag lyssnade på började lagga, som att en cd-spelare spelar en CD skiva med hack i, sen startade datorn om. Tror ni detta har med energi-inställningar att göra? Det enda jag gjorde när det hände var att surfa runt och skriva dokument som ligger på SSD.

Fråga
Det kanske är dags för mig att byta PSU, Moderkort och processor? För den här AMD processorn har ingen inbyggd grafik och vill gärna ha det ifall grafikkortet skulle ge upp.

Vilket moderkort, PSU och processor rekommenderar du? Själv har jag spanat in dem här och tänkte att de passar väl bra till övriga delar.

PSU: https://www.inet.se/produkt/6904761/corsair-cv650-650w-dual-e...
Moderkort: https://www.inet.se/produkt/1903275/msi-b460m-pro
CPU: https://www.inet.se/produkt/5303146/intel-core-i5-10400-2-9-g...

Permalänk
Medlem

Problem 1: XMP är kort och gott - profiler som är till för att sätta dina ram minnen på rekommenderade "max" specifikationer. Jag rekommenderar att du lägger båda dina minnen på XMP - det låter som att du bara har ena satt på XMP.

Problem 2: kan bero på Problem 1 men kan det inte vara så att din dator bara uppdaterade? - det brukar bli svart osv - när man uppdaterar system kritiska drivrutiner som grafikkort och dyl.

Angående komponenter - så har du en rätt så bra uppsättning, jag skulle rekommendera att ifall du vill ha något nytt så behöver du bara skaffa något som AMD Ryzens G serie - som Athlon 3000G ifall du inte behöver världens kraft eller Ryzen 3/4/5x00G utefter behov. Du kan dock behöva uppdatera BIOS/UEFI för att få allt att fungera fint.

Permalänk
Skrivet av ATRmayo:

Problem 1: XMP är kort och gott - profiler som är till för att sätta dina ram minnen på rekommenderade "max" specifikationer. Jag rekommenderar att du lägger båda dina minnen på XMP - det låter som att du bara har ena satt på XMP.

Problem 2: kan bero på Problem 1 men kan det inte vara så att din dator bara uppdaterade? - det brukar bli svart osv - när man uppdaterar system kritiska drivrutiner som grafikkort och dyl.

Angående komponenter - så har du en rätt så bra uppsättning, jag skulle rekommendera att ifall du vill ha något nytt så behöver du bara skaffa något som AMD Ryzens G serie - som Athlon 3000G ifall du inte behöver världens kraft eller Ryzen 3/4/5x00G utefter behov. Du kan dock behöva uppdatera BIOS/UEFI för att få allt att fungera fint.

Jag kan bara välja mellan 1 och 2. Därför valde jag 2an. Vet ej om det var en kritisk uppdatering då jag nyss har uppdaterat och den hittade inget när jag sökte igen.

Permalänk
Medlem

Kolla hälsan på HD med Crystal disk tex. Jag har haft konstiga problem med dålig hårddisk

Permalänk
Skrivet av trebrecks:

Kolla hälsan på HD med Crystal disk tex. Jag har haft konstiga problem med dålig hårddisk

Allt verkar vara som det ska vara enligt bilderna.

https://imgur.com/eLZMBr0

https://imgur.com/QmqMxLH

Permalänk
Skrivet av ATRmayo:

Problem 1: XMP är kort och gott - profiler som är till för att sätta dina ram minnen på rekommenderade "max" specifikationer. Jag rekommenderar att du lägger båda dina minnen på XMP - det låter som att du bara har ena satt på XMP.

Problem 2: kan bero på Problem 1 men kan det inte vara så att din dator bara uppdaterade? - det brukar bli svart osv - när man uppdaterar system kritiska drivrutiner som grafikkort och dyl.

Angående komponenter - så har du en rätt så bra uppsättning, jag skulle rekommendera att ifall du vill ha något nytt så behöver du bara skaffa något som AMD Ryzens G serie - som Athlon 3000G ifall du inte behöver världens kraft eller Ryzen 3/4/5x00G utefter behov. Du kan dock behöva uppdatera BIOS/UEFI för att få allt att fungera fint.

Glömde säga att jag skulle vilja köra på Intel för det är ett säkrare kort och de har bättre kvalitet än AMD. Så det blir nog att jag beställer dem delarna där som jag valde.

Permalänk
Medlem

Kan bara värt att prova sätta ram i 2933mhz, jag har inte haft mycket tur med ryzen 1000 serien och minnen snabbare än så. Dock var detta på b350 moderkort, men du har en go to om du upplever systemet instabilt.

Permalänk
Skrivet av Erickey:

Kan bara värt att prova sätta ram i 2933mhz, jag har inte haft mycket tur med ryzen 1000 serien och minnen snabbare än så. Dock var detta på b350 moderkort, men du har en go to om du upplever systemet instabilt.

??? Vad ska jag sätta Ram i ? vad menar du?

Permalänk
Skrivet av ATRmayo:

Problem 1: XMP är kort och gott - profiler som är till för att sätta dina ram minnen på rekommenderade "max" specifikationer. Jag rekommenderar att du lägger båda dina minnen på XMP - det låter som att du bara har ena satt på XMP.

Problem 2: kan bero på Problem 1 men kan det inte vara så att din dator bara uppdaterade? - det brukar bli svart osv - när man uppdaterar system kritiska drivrutiner som grafikkort och dyl.

Angående komponenter - så har du en rätt så bra uppsättning, jag skulle rekommendera att ifall du vill ha något nytt så behöver du bara skaffa något som AMD Ryzens G serie - som Athlon 3000G ifall du inte behöver världens kraft eller Ryzen 3/4/5x00G utefter behov. Du kan dock behöva uppdatera BIOS/UEFI för att få allt att fungera fint.

Kan jag sätta att hårddisken ska stängas efter 20 min igen tror du eller kan det bli problem då igen med detta?

Permalänk
Medlem
Skrivet av j-bergtrom:

Kan jag sätta att hårddisken ska stängas efter 20 min igen tror du eller kan det bli problem då igen med detta?

Det bör inte vara några problem förutsatt att du inte har din pagefile satt på din mekaniska, prova och se helt enkelt, kör något systemtest i 30min eller mer och se ifall datorn fungerar som förväntat. Har för mig att 3dmark och andra liknande bolag har diverse automatiserade systemtest som är gratis i vissa fall.

Permalänk
Medlem
Skrivet av j-bergtrom:

??? Vad ska jag sätta Ram i ? vad menar du?

Det du antar är olika hastighet på olika ram antar jag är två olika xmp profiler i bios. I bios så kolla om du har en xmp profil som anger under 3000 mhz alltså då 2933mhz. Se ifall den går stabilt efter det.

Permalänk
Skrivet av Erickey:

Det du antar är olika hastighet på olika ram antar jag är två olika xmp profiler i bios. I bios så kolla om du har en xmp profil som anger under 3000 mhz alltså då 2933mhz. Se ifall den går stabilt efter det.

Ah. Du menar att Profil 1 gör att den går på 3200 och Profil 2 går efter 2933? Jag provar välja Profil 1 istället för 2 då det står 2933 mhz på den och kollar om det går mer stabilt efter det. För nu har jag profil 1 där det står 3200 mhz.

Dock i övrigt har ingen krasch skett ännu, så det kanske var en kritiskt drivrutin uppdatering som ovan misstänkte.

Permalänk
Medlem
Skrivet av j-bergtrom:

Ah. Du menar att Profil 1 gör att den går på 3200 och Profil 2 går efter 2933? Jag provar välja Profil 1 istället för 2 då det står 2933 mhz på den och kollar om det går mer stabilt efter det. För nu har jag profil 1 där det står 3200 mhz.

Dock i övrigt har ingen krasch skett ännu, så det kanske var en kritiskt drivrutin uppdatering som ovan misstänkte.

Springer du in i instabilitet så vet du vad du kan prova

Permalänk
Skrivet av ATRmayo:

Problem 1: XMP är kort och gott - profiler som är till för att sätta dina ram minnen på rekommenderade "max" specifikationer. Jag rekommenderar att du lägger båda dina minnen på XMP - det låter som att du bara har ena satt på XMP.

Problem 2: kan bero på Problem 1 men kan det inte vara så att din dator bara uppdaterade? - det brukar bli svart osv - när man uppdaterar system kritiska drivrutiner som grafikkort och dyl.

Angående komponenter - så har du en rätt så bra uppsättning, jag skulle rekommendera att ifall du vill ha något nytt så behöver du bara skaffa något som AMD Ryzens G serie - som Athlon 3000G ifall du inte behöver världens kraft eller Ryzen 3/4/5x00G utefter behov. Du kan dock behöva uppdatera BIOS/UEFI för att få allt att fungera fint.

Skrivet av Erickey:

Springer du in i instabilitet så vet du vad du kan prova

Jag ändrade till XMP 1 vilket är 2933 mhz. Men den stänger fortfarande av sig själv vid uppdateringar verkar det som. Igår uppdaterade Windows och idag, vilket gjorde att den blev svart och startade om helt slumpmässigt, fast jag inte tryckt på någon knapp om att starta om nu. Hur stoppar man det här i fortsättningen? Jag satt i Zoom idag med min lärare från Hermods och hade examination och tur han jag in i tid igen och hann slutföra och fick godkänt. Men jag ska ha examination imorgon också och det funkar inte att den håller på så här.

Tror det har med uppdateringarna att göra som @ATRmayo sa då.

Permalänk
Medlem

Vad har du för Windows version? Vet att jag hade precis samma problem med min förra CPU. Har du inte senaste så rekommenderar jag att du gör en ny formatering med senaste ISO filen från Microsoft.

Permalänk
Medlem
Skrivet av j-bergtrom:

Jag ändrade till XMP 1 vilket är 2933 mhz. Men den stänger fortfarande av sig själv vid uppdateringar verkar det som. Igår uppdaterade Windows och idag, vilket gjorde att den blev svart och startade om helt slumpmässigt, fast jag inte tryckt på någon knapp om att starta om nu. Hur stoppar man det här i fortsättningen? Jag satt i Zoom idag med min lärare från Hermods och hade examination och tur han jag in i tid igen och hann slutföra och fick godkänt. Men jag ska ha examination imorgon också och det funkar inte att den håller på så här.

Tror det har med uppdateringarna att göra som @ATRmayo sa då.

https://i.imgur.com/tFQapso.png

Skrivet av Nightwing:

Vad har du för Windows version? Vet att jag hade precis samma problem med min förra CPU. Har du inte senaste så rekommenderar jag att du gör en ny formatering med senaste ISO filen från Microsoft.

Kan det vara att han kanske har Windows Home? Jag sitter på Pro varianten och kan själv bestämma när uppdateringar ska ske - om han sitter på Home så vet jag att det valet inte är hans att göra... Har dock ingen erfarenhet av Home nu på senare tid - Windows XP Home vart det enda Home jag haft - således har jag aldrig haft det här problemet. Vill dock påpeka att uppdateringarna som körts inte är direkt kopplat till hårdvara om inte det är så att dessa Defender uppdateringar ska patcha eventuella "specter/hurrdurrbleed" hårdvaru ting? (orkar inte kolla igenom vad de rör)

Precis som nightwing undrar jag också vad du har för OS version - du kan se detta genom att köra winver. Vore också bra att veta hur din ominstallation gick till? Använde du Microsofts inhemska lösning "reset" eller körde du på en ren installation?

Du kan förövrigt även kolla i windows felloggar via nedan:

Event Viewer
"Control Panel\System and Security\Security and Maintenance\Problem Reports"

Permalänk
Medlem
Skrivet av j-bergtrom:

Problem 2
Jag har mitt OS på en SSD 120 GB och min HDD 1TB låter lite mycket. Så idag gick jag in på energi-inställningar och ändrade tillbaka “Stäng av hårddisken” från 0 till 20 minuter. Då när jag satte den inställningen igår så trodde jag att detta skulle påverka SSD, men kom på att jag aldrig har ändrat den innan och det var faktiskt den som stängde av min HDD innan som gjorde att den inte lät så himla mycket.

Den stängde av min HDD faktiskt, när jag gick in på HDD hörde jag att den började låta igen, sen efter 10 minuter så blev skärmen SVART och musiken jag lyssnade på började lagga, som att en cd-spelare spelar en CD skiva med hack i, sen startade datorn om. Tror ni detta har med energi-inställningar att göra? Det enda jag gjorde när det hände var att surfa runt och skriva dokument som ligger på SSD.

Det här problemet är något som jag själv upplevet med en av mina hårddiskar.
Lösningen för min del var att med CrystalDiskInfo förhindra att från att någonsin gå i viloläge/standby, dvs, skivorna spinner hela tidan.
Jag vet inte riktigt vad som är orsaken, om det är att det tar lång tid för disken att starta upp eller om det är för att den tar så pass mycket ström att starta upp att det stör andra delar i systemet.

Förövrigt är jag tveksam till att systemdisken någonsin går i viloläge såvida du inte sätter datorn i någon form av viloläge.

Permalänk
Skrivet av Nightwing:

Vad har du för Windows version? Vet att jag hade precis samma problem med min förra CPU. Har du inte senaste så rekommenderar jag att du gör en ny formatering med senaste ISO filen från Microsoft.

Jag har Windows 10 Home och använder deras USB sticka för både formatering och installation. Jag undrar om nyckeln kommer funka om jag laddar ner ISO.

Skrivet av ATRmayo:

Kan det vara att han kanske har Windows Home? Jag sitter på Pro varianten och kan själv bestämma när uppdateringar ska ske - om han sitter på Home så vet jag att det valet inte är hans att göra... Har dock ingen erfarenhet av Home nu på senare tid - Windows XP Home vart det enda Home jag haft - således har jag aldrig haft det här problemet. Vill dock påpeka att uppdateringarna som körts inte är direkt kopplat till hårdvara om inte det är så att dessa Defender uppdateringar ska patcha eventuella "specter/hurrdurrbleed" hårdvaru ting? (orkar inte kolla igenom vad de rör)

Precis som nightwing undrar jag också vad du har för OS version - du kan se detta genom att köra winver. Vore också bra att veta hur din ominstallation gick till? Använde du Microsofts inhemska lösning "reset" eller körde du på en ren installation?

Du kan förövrigt även kolla i windows felloggar via nedan:

Event Viewer
"Control Panel\System and Security\Security and Maintenance\Problem Reports"

Windows 10 Home. Köpte USB via Inet för några år sen. Du får nog förklara Event Viewer närmare, hittade till stället, men saker och ting där är inte som du skriver. Vad ska jag kolla efter?

Skrivet av Viita:

Det här problemet är något som jag själv upplevet med en av mina hårddiskar.
Lösningen för min del var att med CrystalDiskInfo förhindra att från att någonsin gå i viloläge/standby, dvs, skivorna spinner hela tidan.
Jag vet inte riktigt vad som är orsaken, om det är att det tar lång tid för disken att starta upp eller om det är för att den tar så pass mycket ström att starta upp att det stör andra delar i systemet.

Förövrigt är jag tveksam till att systemdisken någonsin går i viloläge såvida du inte sätter datorn i någon form av viloläge.

Jag gjorde så här nu. Jag gick in på Windows update och aktiverade så att Windows meddelar mig nästa gång datorn ska starta om, för det kanske var det som var problemet. I övrigt vill jag bara säga till alla att datorn funkar ganska felfritt efter den har gjort blackscreen, resten av dagarna. Det är just när det har varit update som den ska gå över till blackscreen och starta om, men vi får se nu om det hjälper med windows meddelande för det var på OFF innan. Även den andra aktiverade jag.

Permalänk
Medlem

Osäker på vilken winver du har, du borde kunna kolla upp det om du söker i startmenyn så får du upp exakt vilken build du kör på.

Tror 21H2 är senaste. När du aktiverar din nyckel så tillämpas rätt Windows version i installationen har jag för mig så är det en home nyckel så får du upp home versionen under installation om jag inte minns fel.

Permalänk
Skrivet av Nightwing:

Osäker på vilken winver du har, du borde kunna kolla upp det om du söker i startmenyn så får du upp exakt vilken build du kör på.

Tror 21H2 är senaste. När du aktiverar din nyckel så tillämpas rätt Windows version i installationen har jag för mig så är det en home nyckel så får du upp home versionen under installation om jag inte minns fel.

Permalänk
Medlem

Ram testas med Memtest86 ( https://www.memtest86.com ) det finns ett gratisalternativ på den där sidan som är begränsad men om det är uppenbara problem med minnen räcker det för att flagga om att minnena är trasiga.

Du lägger in memtest86 på ett USB minne sen botar du från det.

Permalänk
Skrivet av rstolpe:

Ram testas med Memtest86 ( https://www.memtest86.com ) det finns ett gratisalternativ på den där sidan som är begränsad men om det är uppenbara problem med minnen räcker det för att flagga om att minnena är trasiga.

Du lägger in memtest86 på ett USB minne sen botar du från det.

Sådär nu har jag kört MEMTEST. Men jag vet ej om RAM blev rätt, för det verkade bara finnas ett test för RAM. Jag körde dock en på CPU också som tog 3 timmar ungefär. Ledsen för kassa bilder.

CPU Test

Ett ram test, det enda test jag kunde hitta för RAM.

Permalänk
Medlem
Skrivet av j-bergtrom:

Sådär nu har jag kört MEMTEST. Men jag vet ej om RAM blev rätt, för det verkade bara finnas ett test för RAM. Jag körde dock en på CPU också som tog 3 timmar ungefär. Ledsen för kassa bilder.

CPU Test
https://i.imgur.com/5gpk41Q.jpg

Ett ram test, det enda test jag kunde hitta för RAM.
https://i.imgur.com/MJ84SvT.jpg

https://i.imgur.com/BVFvif3.jpg

https://i.imgur.com/1EdLSVE.jpg

Kolla så att XMP står aktiverat på båda RAM minnena.
Annars ge info från Event Log i Windows ( du får googla hur du kollar efter fel där, arbetar hinner inte förklara)

Permalänk
Medlem
Skrivet av j-bergtrom:

Glömde säga att jag skulle vilja köra på Intel för det är ett säkrare kort och de har bättre kvalitet än AMD. Så det blir nog att jag beställer dem delarna där som jag valde.

Intel har inte bättre kvalitet än AMD, det är en gammal sanning som helt försvunnit sedan Ryzen processorerna kom. Eftersom du redan har ett moderkort som du enkelt kan uppgradera med en bättre processor så är det betydligt enklare än att byta till Intel då du isf måste köpa nytt moderkort också.

Permalänk
Skrivet av rstolpe:

Kolla så att XMP står aktiverat på båda RAM minnena.
Annars ge info från Event Log i Windows ( du får googla hur du kollar efter fel där, arbetar hinner inte förklara)

Alltså... Jag kan bara ha XMP på en av dem och inte båda.

Permalänk
Medlem
Skrivet av j-bergtrom:

Alltså... Jag kan bara ha XMP på en av dem och inte båda.

hmm, då skulle jag kolla i instruktionsboken för du ska kunna ha XMP på båda. Det är inte så att du har 4st slots för RAM och att dom räknar två som en?

Har du kollat så att RAM är isatt som dom rekommenderar i instruktionsboken för moderkortet? Vet att det är varannan port man ska sätta i fall om man har 4st RAM slots. Men du lär kolla i instruktionsboken så att det är rätt.

Permalänk
Medlem
Skrivet av j-bergtrom:

Alltså... Jag kan bara ha XMP på en av dem och inte båda.

Kan du ta en bild och visa?

edit: det kan vara så att du har satt i de lite tråkigt.

Permalänk
Medlem
Skrivet av ATRmayo:

Kan du ta en bild och visa?

edit: det kan vara så att du har satt i de lite tråkigt.

Lite det jag va ute efter i mitt inlägg ovan med att han har satt dom fel i slotsen dvs i både A och B medans dom ska vara i A1 och A2 (exempel bara man lär kolla i instruktionsboken för att se exakt)

Permalänk
Medlem
Skrivet av rstolpe:

Lite det jag va ute efter i mitt inlägg ovan med att han har satt dom fel i slotsen dvs i både A och B medans dom ska vara i A1 och A2 (exempel bara man lär kolla i instruktionsboken för att se exakt)

Man brukar ha de i olika banor dvs A1 och B1. Kolla dual channel delen här https://www.onecomputerguy.com/ram-slot-order

Permalänk
Medlem
Skrivet av ATRmayo:

Man brukar ha de i olika banor dvs A1 och B1. Kolla dual channel delen här https://www.onecomputerguy.com/ram-slot-order

Jag tog bara exempel du finner svaret i din instruktionsbok jag pekade bara åt ett håll där felet kan ligga