Kan inte längre hosta server efter byte av datordelar

Permalänk
Medlem

Kan inte längre hosta server efter byte av datordelar

Jag bestämde mig för att uppgradera datorn, bytte ut moderkort, grafikkort och CPU samt la till vattenkylning.
Efter det så kan jag inte längre hosta server på ett spel, vilket gick förut innan bytet då båda mina vänner kunde komma in utan problem. Jag har provat stänga av brandvägg, lägga till UDP fastän bara TCP krävs, slå på DMZ, slå av UPnP, starta om router, provade netstat -na via CMD men såg inte porten där, om det ens ska göra det. Som ni märker så har jag ingen vidare kunskap om routrar, kan lägga till mer information om det behövs.

Jag fick en ny internal ip där de tre sista siffrorna hade ändrats, men trots att jag uppdaterade port forwarden så gick det inte. Spelet i fråga är Vintage Story och det är väldigt indie, men jag trycker det är skitkonstigt att det funkade bra innan jag bytte ut komponenterna.

Kör med Telia, "trådlös fiber", och från routern är det kabel rakt in i datorn. Har dynaimsk IP på. Routern är en Asus RT-AX92U som jag köpte för någon månad sen enbart för att jag hade hört att standardroutrar från internetleverantörer oftast är kassa. Enda skillnaden jag märkte var att internet lägger av vid hård belastning då och då, streaming, vet ej om det beror på fel i routern eller något annat.
Hosta spel via Steam går fortfarande bra.

Permalänk
Medlem

Kolla upp om du ligger bakom CG-NAT. Om ja, så behöver du göra av dig till Telia och be om publik IP, annars spelar det ingen roll vilka portar du öppnar.

Har du inget modem innan din Asus router? Är detta bryggat? Om inte, så är det i modemet du ska öppna portar.

Men börja med att kolla upp om du ligger bakom CG-NAT.

Permalänk
Medlem

Jag testade att köra CMD tracert på min ip, som jag tog via whatsmyip, det första jag får är en 1:a vilket betyder att jag har en publik IP? Routerns WAN IP stämmer även överens med vad whatsmyip visar, betyder detta att jag inte är bakom CG-NAT?

Jag ringde Telia och dom sa att dom inte längre har erbjudandet med att man måste ringa och köpa tillgång till publik IP utan det ska vara helt öppet hela tiden. Det verkar som att jag har en publik IP.

Min setup är att från antenn går det en kabel till en dosa, därifrån en sladd till routern, från routern en vanlig nätkabel direkt till datorn. Min routersetup ändrades inget när jag bytte datordelar och det bytet skedde utan ominstallering av datorn för det ska tydligen funka bra, vilket det i övrigt har gjort förutom ett par märkliga beteenden i mjukvara, som att Discord bytte från min vanliga ljudenhet till skärmens. O enda skillnaden jag kan se i routern är att interna adressen gick från 192.168.30.195 till
192.168.30.140 (påhittat snarlikt)

Ipv6 är disabled på routern, om det nu gör någon skillnad.

Permalänk
Medlem
Skrivet av Zelascelar:

Jag testade att köra CMD tracert på min ip, som jag tog via whatsmyip, det första jag får är en 1:a vilket betyder att jag har en publik IP? Routerns WAN IP stämmer även överens med vad whatsmyip visar, betyder detta att jag inte är bakom CG-NAT?

Jag ringde Telia och dom sa att dom inte längre har erbjudandet med att man måste ringa och köpa tillgång till publik IP utan det ska vara helt öppet hela tiden. Det verkar som att jag har en publik IP.

Min setup är att från antenn går det en kabel till en dosa, därifrån en sladd till routern, från routern en vanlig nätkabel direkt till datorn. Min routersetup ändrades inget när jag bytte datordelar och det bytet skedde utan ominstallering av datorn för det ska tydligen funka bra, vilket det i övrigt har gjort förutom ett par märkliga beteenden i mjukvara, som att Discord bytte från min vanliga ljudenhet till skärmens. O enda skillnaden jag kan se i routern är att interna adressen gick från 192.168.30.195 till
192.168.30.140 (påhittat snarlikt)

Ipv6 är disabled på routern, om det nu gör någon skillnad.

Låter inte som du har CG-NAT. Skulle testat och öppna en annan port och se om du kan nå den utifrån t ex ifrån mobilen.!

Permalänk
Medlem

Inställningar för port-forwarding som har tappats?

Permalänk
Medlem

Finns det någon app som man kan testa med? Är ännu sämre med mobilen och har ingen annan dator i huset.

Port forwarden är:
Service Name: VS
External Port: 24240
Internal Port: (tom)
Internal IP Adress: 192.168.**.***
Protocol: TCP
Source IP: (tom)

Först gjorde jag en edit på den där jag ändrade IP:n till den nya, funkade inte, o har provat deleta o göra om utan framgång.

I WAN så ser jag t.ex. att Connect to DNS server automatically är på men DDNS client är avstängt?

Något som är lustigt är att innan bytet så funkade det att hosta, mina polare kunde joina, fastän spelet i sig sa "hosting failed" för att den inte kunde hitta UPnP fastän den var på, har inte ändrat på det sen då förutom när jag testade den off efter uppgraderingen utan framgång.
Nu med den nya IP:n så står det i spelet "Hosting success on <ip>" fast då kan inte mina vänner joina istället. Spegelvänt.