PCE-AC68 i Ubuntu 22.04 men inga trådlösa nätverk syns

Permalänk
Medlem

PCE-AC68 i Ubuntu 22.04 men inga trådlösa nätverk syns

Hej,

Jag har en äldre lite stationär dator där jag installerat nätverkskortet ASUS PCE-AC68 i ett av datorns två PCI-slot och installerat Ubuntu 22.04. Nätverkskortet verkar fungera så långt att det går att stänga av och på men inga tillgängliga nätverk syns.
Har skrivit diverse kommandon i terminalen utan någon framgång. Jag har suttit i timmar för att försöka förstå vad som är fel.

Vad kan jag ha missat?

Ska tillägga att nätverkskoret fungerade utan bekymmer i Windows 10 när jag använde det sist.

Tacksam för all hjälp.

Permalänk
Medlem

Har du följt instruktionerna på ASUS hemsida?

https://www.asus.com/support/FAQ/1045215

Permalänk
Medlem
Skrivet av Hannynha:

Hej,

Jag har en äldre lite stationär dator där jag installerat nätverkskortet ASUS PCE-AC68 i ett av datorns två PCI-slot och installerat Ubuntu 22.04. Nätverkskortet verkar fungera så långt att det går att stänga av och på men inga tillgängliga nätverk syns.
Har skrivit diverse kommandon i terminalen utan någon framgång. Jag har suttit i timmar för att försöka förstå vad som är fel.

Vad kan jag ha missat?

Ska tillägga att nätverkskoret fungerade utan bekymmer i Windows 10 när jag använde det sist.

Tacksam för all hjälp.

Vad ger lsmod för output?

Åtrerkom med output från dmesg när du slår på enheten och samtidigt har nedan aktiv i en terminal:

Skriv:

dmesg -wxHT

Slå på enheten efter du skrivit ovan, vad blev output?

Vad använder du för att söka efter nätverk?

Vad är output när du kollar /proc/net/dev?

awk '/:/ {print $1}' /proc/net/dev

Använder du bcma tillsammans med wl modules Prova nedan isåfall, prova enbart wl.

rmmod -f bcma wl: modprobe -v wl

.
Permalänk
Medlem
Skrivet av LeifSandvik:

Har du följt instruktionerna på ASUS hemsida?

https://www.asus.com/support/FAQ/1045215

Tack för din respons. Tyvärr hjälper inte detta mig då min enhet är PCI istället för USB.

Permalänk
Medlem
Skrivet av wuseman:

Vad ger lsmod för output?

Åtrerkom med output från dmesg när du slår på enheten och samtidigt har nedan aktiv i en terminal:

Skriv:

dmesg -wxHT

Slå på enheten efter du skrivit ovan, vad blev output?

Vad använder du för att söka efter nätverk?

Vad är output när du kollar /proc/net/dev?

awk '/:/ {print $1}' /proc/net/dev

Använder du bcma tillsammans med wl modules Prova nedan isåfall, prova enbart wl.

rmmod -f bcma wl: modprobe -v wl

Tusen tack för ditt svar och ber om ursäkt att mitt svar har dröjt. Inte alltid lätt att hitta tiden som småbarnsförälder.

dmesg -wxHT

" dmesg: läsning av kärnbuffert misslyckades: Operationen inte tillåten" Gör jag fel?

Vad använder du för att söka efter nätverk?
Jag använder GUI:et som Ubuntu ger mig. Klickar på ikonen i övre högra hörnet. Väljer sök nätverk.

awk '/:/ {print $1}' /proc/net/dev

Reslutat:
lo:
enp0s7:
wlp3s0:

rmmod -f bcma wl: modprobe -v wl

Resultat:
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'bcma': Operation not permitted
rmmod: ERROR: could not remove module bcma: Operation not permitted
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'wl:': Operation not permitted
rmmod: ERROR: could not remove module wl:: Operation not permitted

Hur går jag vidare?

Permalänk
Medlem
Skrivet av Hannynha:

Tusen tack för ditt svar och ber om ursäkt att mitt svar har dröjt. Inte alltid lätt att hitta tiden som småbarnsförälder.

dmesg -wxHT

" dmesg: läsning av kärnbuffert misslyckades: Operationen inte tillåten" Gör jag fel?

Vad använder du för att söka efter nätverk?
Jag använder GUI:et som Ubuntu ger mig. Klickar på ikonen i övre högra hörnet. Väljer sök nätverk.

awk '/:/ {print $1}' /proc/net/dev

Reslutat:
lo:
enp0s7:
wlp3s0:

rmmod -f bcma wl: modprobe -v wl

Resultat:
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'bcma': Operation not permitted
rmmod: ERROR: could not remove module bcma: Operation not permitted
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'wl:': Operation not permitted
rmmod: ERROR: could not remove module wl:: Operation not permitted

Hur går jag vidare?

Du måste nog köra sudo framför kommandot:
sudo rmmod -f bcma wl:
sudo modprobe -v wl

Permalänk
Medlem
Skrivet av Eazy:

Du måste nog köra sudo framför kommandot:
sudo rmmod -f bcma wl:
sudo modprobe -v wl

Tack! Jag provade igen och fick följande resultat:

sudo rmmod -f bcma wl:
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'bcma': No such file or directory
rmmod: ERROR: could not remove module bcma: No such file or directory
rmmod: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'wl': No such file or directory
rmmod: ERROR: could not remove module wl: No such file or directory

sudo modprobe -v wl:
insmod /lib/modules/5.15.0-47-generic/updates/dkms/wl.ko

Blir jag smartare av detta?

Permalänk
Medlem

Hmm, nu kör jag inte Ubuntu, så jag famlar lite. Har du installerat bcmwl-kernel-source (om det finns)?

sudo apt install bcmwl-kernel-source

Sedan:
sudo modprobe wl

Som sagt, bara gissar lite...

Permalänk
Medlem

@Hannyha Jag får samma svar som du när jag kör kommandona från @Eazy på min Nuc (som kör nätverkskort från Intel), alltså inte Broadcom. Troligt att du inte har installerat drivrutinerna. Broadcom är för övrigt struliga och något man ska undvika, men det är en annan sak.

Permalänk
Medlem
Skrivet av Eazy:

Hmm, nu kör jag inte Ubuntu, så jag famlar lite. Har du installerat bcmwl-kernel-source (om det finns)?

sudo apt install bcmwl-kernel-source

Sedan:
sudo modprobe wl

Som sagt, bara gissar lite...

Tack. Jag provade och fick följande resultat:
sudo modprobe wl:
Läser paketlistor… Färdig
Bygger beroendeträd… Färdig
Läser tillståndsinformation… Färdig
bcmwl-kernel-source is already the newest version (6.30.223.271+bdcom-0ubuntu8).
0 att uppgradera, 0 att nyinstallera, 0 att ta bort och 9 att inte uppgradera.

sudo modprobe wl: ger ingenting.

Börjar bli lite smått frustrerad. Provat olika llinux distros men slutresultat blir detsamma.

Permalänk
Medlem
Skrivet av TANDEMCYKELN:

@Hannyha Jag får samma svar som du när jag kör kommandona från @Eazy på min Nuc (som kör nätverkskort från Intel), alltså inte Broadcom. Troligt att du inte har installerat drivrutinerna. Broadcom är för övrigt struliga och något man ska undvika, men det är en annan sak.

Ja, att det strular skriver jag under på alla dagar i veckan. Jag hittade denna video som inger lite hopp. https://www.youtube.com/watch?v=YHCPiGrWYVg
Lösningsförslag nr 2 har jag inte testat än. Måste hitta mitt USB-sticka med installationen av Ubuntu på. Förslag nr 1 och 3 funkade inte för mig, tyvärr.