[Fläktstyrning] Hur får jag detta att fungera på en Raspberry Pi4?

Permalänk
Medlem

[Fläktstyrning] Hur får jag detta att fungera på en Raspberry Pi4?

Hej!

Köpte för en tid sedan följande kit:
https://www.kjell.com/se/produkter/dator/raspberry-pi/okdo-ra...

Jag har installerat kylflänsar och fläkten efter konstens alla regler och enligt bilden nedan:

Allting funger perfekt, OS är uppdaterat mm men fläktstyrningen fungerar inte.

I Raspberry Pi OS har jag ställt in följande:

Fan GPIO: 2
Fan Temperature: 60

Som jag tolkar det hela så bör väl fläkten först gå igång när CPU-temp närmar sig 60 grader? I mitt fall använder jag endast min rPI4 för Adguard Home (DNS-blockering) så den har ju ingen hög last och temperaturen ligger i princip alltid på ~40 grader.

Är Fan GPIO på fel inställning? "Räknar jag pinnarna" fel kanske?

Andra idéer varför fläkten alltid är igång på 100%?

Tusen tack!

Permalänk
Rekordmedlem
Skrivet av Xophile:

Hej!

Köpte för en tid sedan följande kit:
https://www.kjell.com/se/produkter/dator/raspberry-pi/okdo-ra...

Jag har installerat kylflänsar och fläkten efter konstens alla regler och enligt bilden nedan:
https://www.okdo.com/wp-content/uploads/2019/10/6-connect-fan.jpg?w=544&resize=544%2C431

Allting funger perfekt, OS är uppdaterat mm men fläktstyrningen fungerar inte.

I Raspberry Pi OS har jag ställt in följande:

Fan GPIO: 2
Fan Temperature: 60

Som jag tolkar det hela så bör väl fläkten först gå igång när CPU-temp närmar sig 60 grader? I mitt fall använder jag endast min rPI4 för Adguard Home (DNS-blockering) så den har ju ingen hög last och temperaturen ligger i princip alltid på ~40 grader.

Är Fan GPIO på fel inställning? "Räknar jag pinnarna" fel kanske?

Andra idéer varför fläkten alltid är igång på 100%?

Tusen tack!

Har du kopplat som bilden har du satt fläkten till 5V matningen, gpio 2 är på "raden under"

Visa signatur

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Permalänk
Medlem
Skrivet av mrqaffe:

Har du kopplat som bilden har du satt fläkten till 5V matningen, gpio 2 är på "raden under"
https://cdn.sparkfun.com/assets/learn_tutorials/1/5/9/5/GPIO.png

Hej!

Tack för svaret @mrqaffe!

Är det således bara en ändring i OS till rätt gpio jag behöver justera (ifrån nr 2 till 4?) eller ska jag sätta kontakten på ett annat ställe?

Bara så jag inte missförstår dig!

Permalänk
Rekordmedlem
Skrivet av Xophile:

Hej!

Tack för svaret!

Är det således bara en ändring i OS till rätt gpio jag behöver justera eller ska jag sätta kontakten på ett annat ställe?

Bara så jag inte missförstår dig!

Som du kopplat nu har du alltid 5V till fläktmotorn så den kommer alltid att gå så du ska väl flytta kontakten till en pinne du kan styra och konfa det rätt, pinne 2 är ju nära så det är väl enkelt att flytta den dit.

Originalfläkten har 3 ledare och styrs av pinne 14 men det finns väl inga tvång utan det går väl att koppla och konfa ganska fritt men det bästa är ju att välja en låda som inte behöver fläkt

https://www.raspberrypi.com/products/raspberry-pi-4-case-fan/

Visa signatur

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Permalänk
Medlem

Om du tycker att fläkten låter för mycket när den går på 5V kan du testa att köra den på 3,3V istället, jag kör i stort sett alla mina fläktkylda SBC på 3,3V.

Visa signatur

HTPC: Silverstone Sugo SG05W Vit, Asus H110I-Plus, G4560, Corsair Vengeance LPX 2133 MHz 2x4GB, Samsung 870 EVO 500GB, Toshiba N300 2x10TB, MSI GeForce GT 1030 Passive OC 2GB, (& typ 15 enkortsdatorer med div användningsområden). Har ett "par" andra stationära datorer åxå. LG OLED 65CX. Shield Pro.

Permalänk
Medlem
Skrivet av Xophile:

Hej!

Tack för svaret @mrqaffe!

Är det således bara en ändring i OS till rätt gpio jag behöver justera (ifrån nr 2 till 4?) eller ska jag sätta kontakten på ett annat ställe?

Bara så jag inte missförstår dig!

Nej. Du tänker på pin nummer vilket inte är samma som gpio nummret. Om du kollar på bilderna så kommer du hitta en pinne som heter gpio2 men ha ett helt annat pin nummer.

Gpio 2 är pinne 3, och gpio 4 är pinne 7

Visa signatur

ASUS B550-f-Gaming, R9 3900X, HyperX 3200Mhz cl16 128Gb ram, MSI GTX 1070ti gaming oc@ 1979Mhz/8996Mhz.
[Lista] De bästa gratisprogrammen för Windows

Permalänk
Medlem

Hej allesammans!

Ursäkta sent svar. Lite sjukdom och tjänsteresor mm gjorde att allt drog ut på tiden.

Stort tack för alla svar!

Jag blev irriterad och drog ur fläkten helt och hållet. Kör bara Adguard home för dns-filtrering så ingen hög last på min Pi. Funderar även på ett passivt chassi men det får bli senare.

Allt fungerar utan fläkten och cpu är på 55-60 grader. Hoppas det är ok. Med fläkten var det ca 10 grader lägre.

Permalänk
Medlem

Det är väl endast pinnarna med 5 V och 3,3 V som direkt klarar av att driva fläkten. Övriga pinnar är "data" och då krävs någon enkel förstärkare, kanske bara en transistor/optokopplare för att driva fläkten.

Visa signatur

Linux Mint 21 Vanessa Cinnamon @Mintbox Mini 2 Pro