Slackware, problem med upplösning och hz

Trädvy Permalänk
Medlem
Plats
Gällivare
Registrerad
Feb 2002

Slackware, problem med upplösning och hz

Tjo!
Har precis installerat Slackware mha av guiden som Trek har gjort (grym guide!!!!!). Men iaf, nu när jag startar X så är upplösningen hela 1800 nånting, så allt är jätte litet och allt flimmrar! När jag försöker ändra genom KDK:s Inställnings central eller vad den heter, så kan jag ändra alla inställningar där osv. När jag gjort det och trycker på applay så vill den att jag ska starta om X. Så när jag ska göra det och loggar ur så blir skärmen svart, efter en liten stund kommer det upp på skärmen att den inte får någon signal. Och jag kan inte startaom datorn med ctrl+alt+delete. Så jag må trycka på knappen för att starta om. När jag nu försöker starta X igen så händer ingenting.. skärmen är bara svart och daton "tänker" inget. Jag kan dock återgå till orginal inställningarna genom att starta om igen och sedan köra "xfree86setup". Men då var det tillbaka till flimmer igen.

Tacksam för hjälp!

/awai-benda

Jag har en Opel..

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Apr 2002

ändra i /etc/X11/XF86Config

IBook G4 12" | 1.5GB | 120Gb | OS X 10.4.9 / Ubuntu
C2D E6400@2.8GHz | 2GB | 1,7TB | Gentoo
1700+@2400MHz | KD7-RAID | 1,25GB | Win2k

Trädvy Permalänk
Medlem
Plats
Gällivare
Registrerad
Feb 2002

försökte nu göra som du skrev. Men det funkade inte. Jag var inloggad som root och skrev precis det du skrev men då kom det bara upp "Permission denied" (Stavning?! Kass på att stava..). Är det nått jag måste skriva innan "/etc/X11/XF86Config" för att kunna ändra i den?? Snälla hjälp mig!

/awai-benda

Jag har en Opel..

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001

Du har nog ändå inte varit root när du försökt ändra i filken.
Du kan även växla mellan dina fördefinerade upplösningar genom ctrl - +

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2001

<din favorit editor> /etc/X11/XF86Config

Om du inte har nån aning om vilka det finns så är nano/pico ett bra val.

Trädvy Permalänk
Medlem
Plats
Gällivare
Registrerad
Feb 2002

Tyvärr har inget av förslagen fungerat för mig.... detta verkar ju hopplöst...

Jag har en Opel..

Trädvy Permalänk
Medlem
Plats
:sʇɐlԀ
Registrerad
Dec 2003

Slut ögonen, ta ett djupt andetag och slappna av.

(öppna ögonen)

Hej. Jag tänker nu på ett enkelt sätt förklara hur du ska ställa in XFree till att använda rätt refresh.

De tidigare inläggen har antagit att du redan är familjär med linuxterminalen, vilket jag antar att du inte är. Nåväl, låt oss börja.

1: Ta reda på din monitors vertical refresh rate och horizontal refresh rate. Den hittar du vanligvis på tillverkarens hemsida. Även kända som vsync/hsync eoch vrefresh/hrefresh.
Hsync mäts vanligvis i Hz, min hsync är t.ex 30-70 Hz.
Vsync mäts vanligtvis i kHz(kiloHz), min vsync är 50-160 kHz.
Anteckna dessa värden på ett godtyckligt stycke papyrus och gå vidare till nästa steg.
Anteckna din vsync och hsync.

2: Öppna en terminal och växla mapp till /etc/X11/. Detta görs genom att använda kommandot cd. 'cd <mapp>' växlar mapp till <mapp>, och 'cd ..' går upp ett steg i mappstrukturen, t.ex från /etc/X11/ till /etc/.
Öppna en terminal och skriv 'cd /etc/X11/'.

3: Öppna filen XFreeConfig alternativt XFreeConfig-4 beroende på vilken version av X du har. För att öppna filer med program använder du kommandot <program> <fil>.
T.ex så gör 'nedit XFreeConfig' att du öppnar filen XFreeConfig med editorn nedit. Jag föredrar personligen nano för att göra småändringar.
Skriv 'nedit XF86Config'.

4a(refresh): Bläddra ner till sektionen som ser ut ungefär såhär:

Section "Monitor" Identifier "Generic Monitor" HorizSync 30-70 VertRefresh 50-160 Option "DPMS" EndSection

Där det står

HorizSync <något värde> VertRefresh <något värde>

, skriv in

HorizSync <din horizontal refresh rate> VertRefresh <din vertical refresh rate>

. Se exemplet ovan för ett exempel på hur man ska skriva in värdena.
Spara dokumentet.
Skriv in din hsync och vsync och spara dokumentet.

4b(upplösning): Bläddra ner till sektionen som ser ut ungefär såhär:

Section "Screen" Identifier "Default Screen" Device "Generic Video Card" Monitor "Generic Monitor" DefaultDepth 24 SubSection "Display" Depth 1 Modes "1024x768" EndSubSection SubSection "Display" Depth 4 Modes "1024x768" EndSubSection SubSection "Display" Depth 8 Modes "1024x768" EndSubSection SubSection "Display" Depth 15 Modes "1024x768" EndSubSection SubSection "Display" Depth 16 Modes "1024x768" EndSubSection SubSection "Display" Depth 24 Modes "1024x768" EndSubSection EndSection

Efter 'modes', skriv in de upplösningar du vill kunna använda. Ex:

Modes "600x480""800x600""1024x768""1280x1024"

Bläddra ner och ställ in Modes till de upplösningar du vill använda, X tar den högsta som default. Spara.

5: Starta om X. Att starta om datorn bara för att man har ändrat något sådant är väldigt onödigt, använd därför kombinationen Control-Alt-Backspace för att starta om X.
Tryck Control-Alt-Backspace.

6: Klaga här om det inte funkar.

i5-4670k | GTX 670 | ASUS Z87-A | 2x4GB Corsair Vengeance 1333 MHz | Corsair VX 450 | 80 GB Intel X25 SSD systemdisk | 256 GB Samsung 840 spel/cachedisk | 2+3 TB WD Green lagringsdiskar | Fractal Define R4 | G2420HDBL (24") + L227WT (22")

Citera för svar!

Trädvy Permalänk
Medlem
Plats
Vallentuna
Registrerad
Jan 2004

Det är inte ett alternativ att testa Xorg istället för Xfree86?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Sep 2003
Citat:

Ursprungligen inskrivet av Icetec
Det är inte ett alternativ att testa Xorg istället för Xfree86?

du måste ställa in vsync och hsync i xorg också

Grejer jag tycker om: OpenBSD, FreeBSD samt Gentoo

Trädvy Permalänk
Medlem
Plats
Vallentuna
Registrerad
Jan 2004
Citat:

Ursprungligen inskrivet av Reiman
du måste ställa in vsync och hsync i xorg också

Jag tänkte mer på "Permission Denied".

Trädvy Permalänk
Medlem
Registrerad
Nov 2001

Jag för detta heller inte att funka Suse 10.1!

AMD64 4000+, Geforce 6800, 1024 Ram, HP 19" TFT 16ms, 660 Gb HDD

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Jul 2003
Citat:

Ursprungligen inskrivet av Meganeoman
Jag för detta heller inte att funka Suse 10.1!

utveckla gärna mer. Att posta din x-confgirationsfil förmodligen är det /etc/X11/xorg.conf.

Dessutom finns det lite kommandon du kan köra

% X -configure

skapar en konfigrationsfill automatisk, är inte alltid jätte bra.

% xorgconfig

Låter dig svara på massa frågor te.x vilket grafikkort du har osv.

% xorgcfg

Som förra fast ncurses.

Trädvy Permalänk
Medlem
Registrerad
Nov 2001

Fattar ingenting av det du skrev, ny på linux!
Mitt grafikkort geforce 6800 (Nvidia)

Var kör man dom kommandona?
Skriver man % före?

AMD64 4000+, Geforce 6800, 1024 Ram, HP 19" TFT 16ms, 660 Gb HDD

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Jul 2003

Du kör kommandona i valfri terminal, % markerar en prompt så du skriver inte det. Du skall göra det som root eller skria sudo före kommandot. Om du inte vet det så är root "admin", och sudo är "super-user do" super-user är root (typ, root är en super-user). Om du har loggat in som dig själv men vill byta till root skriver du su vilket betyder "switch user" om inget annat anges byter du till root. sudo kräver dock att du har rättigheter för sudo, vilket men offstast får med det konto man sätterupp vid installationen. Både su och sudo kommer att fråga efter lösenord ( eller bör, har du inget lösen frågas det heller inte efter något, sudo kan, men bör inte, vara konfiguerat så att man inte måste skriva lösen (, så är sudo för root)), su frågar efter roots lössen och sudo för ditt. GLHF

Trädvy Permalänk
Medlem
Plats
Localhost
Registrerad
Mar 2002

edit får lära mig att läsahela inlägget

Trädvy Permalänk
Medlem
Plats
Gällivare
Registrerad
Feb 2002

OT: oj.. det var ett tag sedan jag starta denna tråd hehe

Jag har en Opel..