Alsa-ljud funkar nääästaaan

Trädvy Permalänk
Medlem
Plats
Sävsjö
Registrerad
Apr 2002

Alsa-ljud funkar nääästaaan

Hej

Nu har jag problem igen

Denna gången med Slackware 8.1. (Med 2.4 kernel, alltså inte alsa inbyggt). Jag har kört mandrake innan och där funkade ljudet sktibra efter många om och men. Men det var enklare eftersom alsa fanns med som standard i kärnan. Nu har jag alltså installerat och konfigurerat alsa till slack 8.1 och testat lite.

Vad som fungerar:
KMiX som mixer funkar.
Jag kan lyssna på CD-skivor om jag KsCD i KDE. Allt detta funkar bra. Alltså, inställningarna för ljudkortet är det ju inget fel på så (irq och all sån skit)

Vad om INTE fungerar:
Jag kan inte lyssna på ljud-filer från hårddisken. Varken med xmms eller mpg123 eller mpg321. Jag kan inte ändra några inställningar med ALSA:s egna utilities (amixer, alsamixer osv) eftersom dom kan inte hitta kortet.

Alltså, varför kan jag lyssna på CD-skivor och inte på ljudfiler? Helskumt...

En annan grej: Aktiverar jag mikrofonen i kmix och drar upp volymen får ett tjut i form av rundgång. Ännu ett bevis att grejorna är rätt konfigurerade...

I XMMS kommer det upp ett felmeddelande när jag väljer Alsa som output device. Om jag väljer OSS kommer det bara inget ljud, men låter spelas upp. (Tror alsa är inställt på att emulera OSS ljud annars).

Spec:
Dell Latitude CPi D266XT
Audio Cirrus Logic CS4237B
Port=0x530
Control Port=0x210
IRQ=5
DMA1=0
DMA2=1
MPU Port=0x330
FM Port=0x388
MPU IRQ=9

Snälla hjälp mig
Tack på förhand

if (computer->sNoiselevel=="silent") { computer->status=the_best; }

Trädvy Permalänk
Medlem
Plats
Ystad
Registrerad
Okt 2002

Prova att stänga av arts, kde's ljudmixer.
Bör väl även finnas arts output till xmms

Ett lurvigt skägg döljer inte bristande
intelligens.

Trädvy Permalänk
Medlem
Plats
Sävsjö
Registrerad
Apr 2002

arts outpu fanns inte i mitt xxms iaf. Hjälpte ine att stänga av arts heller.

Efter lite noggrannare undersökningar verkar det som om /dev/dsp och /dev/mixer osv inte funkar eller är rätt inställda... Trots detta fungerar det att spela upp ljud från audio-cd??!?!?!

Det skulle förklara varför inte alsamixer startar upp heller.

Skulle vilja veta lite mer om dessa (/dev/dsp och /dev/mixer), begriper inte riktigt hur det fungerar och/eller hur man ställer in dom. Och var i slackware ställer man in vilka modules som ska startas vid startup? Tydligen laddas ljud-modulerna in, men jag vet inte hur...

EDIT: Alsamixer felmeddelande: function snd_ctl_open failed for default: No such file or directory

EDIT2: OK, Jag kom fram till följande. Jag testade att komentera hela modules.conf filen undvika att ladda in modulerna till alsa en gång. Visade sig att kmix slutade fungera, inte helt oväntat kanske. Men det visade sig också att spela audio-cd fortfarande funkar. Alltså är det nog något fel på inställningarna (spec:en ovan). Får testa runt lite. Dom funkade iallafall prima i mandrake 10.1 Community.

if (computer->sNoiselevel=="silent") { computer->status=the_best; }

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

dra in nyare slackware och testa... 8.1 e lite gammalt

Trädvy Permalänk
Medlem
Plats
Sävsjö
Registrerad
Apr 2002

Datorn är lite gammal (266 MHz). Men den största anledningen till att jag använder detta är att jag inte har fått igång cd-rom i något annat linux. Sen sitter jag på modem, så blir det jobbigt att ta hem en massa distar och prova fram och tillbaka ;). Men det är klart, skulle ju faktiskt vilja testa med en nyare version av just slackware...

if (computer->sNoiselevel=="silent") { computer->status=the_best; }

Trädvy Permalänk
Medlem
Plats
Boden
Registrerad
Mar 2002

prova alsaconf, det hjälpte när jag fick ditt meddelande när du försöker starta alsamixer.

Trädvy Permalänk
Medlem
Plats
din root :>
Registrerad
Feb 2004
Citat:

Ursprungligen inskrivet av zansibal
Datorn är lite gammal (266 MHz). Men den största anledningen till att jag använder detta är att jag inte har fått igång cd-rom i något annat linux. Sen sitter jag på modem, så blir det jobbigt att ta hem en massa distar och prova fram och tillbaka ;). Men det är klart, skulle ju faktiskt vilja testa med en nyare version av just slackware...

man kan ju typ välja old_cds som kernel när man installerar

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

Antagligen har du rättighetsproblem ?

We live in the age o stupidity || SparcStation 20,384mb RAM,1gb disk,2*125mhz, Solaris8
--------------------------------------------------------------------------------------------
Every suicide is a solution to a problem. -- Jean Baechler

Trädvy Permalänk
Medlem
Plats
Sävsjö
Registrerad
Apr 2002

TheDude: Har provat. Alsaconf ställer inte in modules.conf filen tillräckligt exakt. Funkar inte för mig eller någon annan som har det ljud(kortet).

nystan: Ofan, kanske skulle vara idé att testa med någon gång. Bara jag får tag i någon nyare dist så.

gluffis: Vet inte?? Jag gör allting som root just nu, för säkerhets skull. Kan det bli strul ändå?

EDIT: Om jag skriver "modprobe -c" så hittar jag, utöver mina egna options för alsa drivrutinerna, några inställningar till ett sb (soundblaster alltså). Kan det vara så att OSS vid installation ställde in så att linux varje gång laddar in moduler till ljudkortet som den tror vara soundblaster? Hur stänger jag av det isf? Det kanske stör alsa lite sådär, vem vet....

if (computer->sNoiselevel=="silent") { computer->status=the_best; }

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

När jag swappade till ALSA från OSS var det strul med rättigheterna på /dev/dsp osv. Men kör du som root borde det funka tycker jag.

We live in the age o stupidity || SparcStation 20,384mb RAM,1gb disk,2*125mhz, Solaris8
--------------------------------------------------------------------------------------------
Every suicide is a solution to a problem. -- Jean Baechler

Trädvy Permalänk
Medlem
Plats
Sävsjö
Registrerad
Apr 2002

Hur gör man för att stänga av OSS? Verkar som det kanske kan vara någon liten konflikt mellan OSS inställningar och de nya jag gjort för alsa. (Värt ett försök iaf)

if (computer->sNoiselevel=="silent") { computer->status=the_best; }

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Jag har typ samma typ av problem
Kört alsaconfig (men som inte hittat kortet) sen har jag laddat in några moduler och då funkar ”cat /dev/urandom > /dev/dsp” men inte något annat som mp3.

Kör debian på en sun ultra 10

Några ideer?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Vilka moduler laddade du in?

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

cs4231 och audio

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Ok, det är inte ALSA-moduler. Skulle du kunna testa ALSA istället?

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

menar du att jag ska köra ”modprobe alsa”?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Aha. Nej. Vet du om ALSA är installerat?

Alsamodulerna har namn som börjar på snd-, men i övrigt ofta samma sak som OSS-modulerna, så du skulle kunna försöka med snd-cs4231

Jag har faktiskt en Ultra5 här (som har samma innehåll som en U10, såvitt jag vet). Om du orkar vänta så kan jag testa på den?

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Om du vill och har tid.

jag har installera alsa men som sagt alsaconf hittar inte kortet står ” snd: no module by that name found” så nej snd-cs4231 finns inte även om den borde finnas där. =/
kör 2.4.27-2 kernel kanske ska testa med 2.6 med hört att den inte vill boota på en ultra 10