Trädvy Permalänk
Medlem
Registrerad
Nov 2002

ljudproblem

har en thinkpad t20. Ljudet har fungerat förut men med kernel 2.6.12 vill det inte... Har fungerat förut men har tyvärr inte kvar min .config.

lspci:
0000:00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)

har laddat modulen snd-cs46xx vilken ska fungera men alsamixer säger
"No mixer elems found"

kär jag alsaconfig hittar den ljudkortet och föreslår just snd-cs46xx.

modulerna
sound card support
sequencer support
sequencer dummy client
oss mixer api
oss pcm api
oss sequencer api
är inkompilerade i kerneln.

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001

Re: ljudproblem

Ett tips kan ju vara att inte kompliera drivrutinerna som moduler utan i stället kompliera in dem statiskt. Jag körde själv ALSA som moduler tidigare men det skapade bara mer problem än man kunde hantera, så slutligen kompilerade jag in dem och sedan dess har jag inte haft problem med ljudet i huvudtaget...

Trädvy Permalänk
Medlem
Registrerad
Nov 2002

Hade modulen statiskt kompilerad innan det fungerade inte heller... Måste vara något annat

Trädvy Permalänk
Medlem
Plats
i min SGI Indigo
Registrerad
Maj 2004
Citat:

Ursprungligen inskrivet av VRMS
Hade modulen statiskt kompilerad innan det fungerade inte heller... Måste vara något annat

Vad står det i dmesg när du laddar modulen?

Är du med i gruppen audio? kan vara så att alsamixer inte har rättigheter att läsa/skriva ljudenheten.

funkar alsa? cat /proc/asound/devices

/Tj

Trädvy Permalänk
Medlem
Registrerad
Nov 2002

Står inget alls i dmesg... Inte heller när jag laddar den manuellt

Jodå.

cat /proc/asound/devices
1: : sequencer
8: [0- 0]: raw midi
0: [0- 0]: ctl
33: : timer

Trädvy Permalänk
Medlem
Plats
i min SGI Indigo
Registrerad
Maj 2004

Det funkar ju uppenbart inte

nåväl... du har inte slängt OSS-drivrutinerna också?

/Tj

Trädvy Permalänk
Medlem
Registrerad
Nov 2002

inga oss.