Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001

apache url problem

Tjenare
Har lite bekymmer med min webserver. När man går in på http://www.homeworld.se så ändras adressen automatiskt till min ip.

Var är det man ändrar så den slutar med det?

Umm, kan tillägga att det handlar om Debian med Apache 2 installerat.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2002

Kika på ServerName och ändra till www.homeworld.se
Borde finnas i en av filerna i /etc/apache2/sites-enabled/

This is a UNIX virus. Please remove all your files and copy this message to friends.
(Citera mig om du förväntar dig svar)

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av zeth
Kika på ServerName och ändra till www.homeworld.se
Borde finnas i en av filerna i /etc/apache2/sites-enabled/

i /sites-enabled/ ligger en fil "000-default" och jag hittar inget om server name :\
Den ser ut så här för övrigt

NameVirtualHost * <VirtualHost *> ServerAdmin webmaster@localhost DocumentRoot /var/www/ <Directory /> Options FollowSymLinks AllowOverride None </Directory> <Directory /var/www/> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all # This directive allows us to have apache2's default start page # in /apache2-default/, but still have / go to the right place # RedirectMatch ^/$ /apache2-default/ </Directory> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory "/usr/lib/cgi-bin"> AllowOverride None Options ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory> ErrorLog /var/log/apache2/error.log # Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn CustomLog /var/log/apache2/access.log combined ServerSignature On Alias /doc/ "/usr/share/doc/" <Directory "/usr/share/doc/"> Options Indexes MultiViews FollowSymLinks AllowOverride None Order deny,allow Deny from all Allow from 127.0.0.0/255.0.0.0 ::1/128 </Directory> </VirtualHost>

BTW: Ingen som vet någon bra nybörjarguide till apache2?
Har letat som tusan men inte hittat något

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

Prova att lägga till

ServerName www.homeworld.se

Efter ServerAdmin

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av GunnarD
Prova att lägga till

ServerName www.homeworld.se

Efter ServerAdmin

Testade, funkade inte :\

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

Dum fråga men startade du om apache efteråt?

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av GunnarD
Dum fråga men startade du om apache efteråt?

Jadå, tog det säkra före det osäkra och startade om hela burken

Trädvy Permalänk
Medlem
Plats
90210
Registrerad
Okt 2001

Ett tips kan också vara att titta på CanonicalName och se till att det är avstängt.
Dock är jag inte helt hundra på hur config-filer och liknande sitter ihop under apache2.

Old math teachers never die, they just tend to infinity.

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

Apache2 använder samma config filer som Apache1.

Det där ser mera ut som något "debian special".

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D