Problem med uppstart av XP efter Suse 9.3 installerats

Trädvy Permalänk
Medlem
Registrerad
Okt 2003

Problem med uppstart av XP efter Suse 9.3 installerats

Jag har sökt ett svar på denna frågan och jag har sett att det är flera stycken som har haft/har detta problemet.. dock har ingen kommit med en lösning (för allmän beskådning iaf).

Installerade igår Suse 9.3 Professional, på denna dator, som jag då redan hade Win XP Pro på. Allt verkade gå smidigt, jag kunde starta upp både Windows (som står som standard), och Suse, efter att ha valt det i Grub.

Problemet är följande: När jag skulle starta upp datorn idag (Windows, som är standard), kom följande felkod (med vit text och svart bakgrund):
"root (hd1,0)
Filesystem type unknown, partition type 0x7
chainloader +1"

Det enda man kan göra då är att starta om datorn.. väljer jag då Suse, så startar den upp utan problem. Väl inne kan jag komma åt mina Windowspartitioner utan problem.

/dev/hdc1 är min Windowspartition.

I /boot/grub/menu.lst, står följande:

"# Modified by YaST2. Last modification on mån jul 25 12:30:40 CEST 2005

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd1,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
root (hd1,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.3
kernel (hd1,2)/boot/vmlinuz root=/dev/hdc3 vga=0x317 selinux=0 splash=silent resume=/dev/hdc2 showopts
initrd (hd1,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd1,2)/boot/vmlinuz root=/dev/hdc3 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0 3
initrd (hd1,2)/boot/initrd"

Skulle bli väldigt tacksam om någon har en smidig lösning på detta problem, känner inte direkt för att formatera och stoppa in Windows igen. Då dröjer det säker tlika länge igen innan jag testar linux nästa gång.

Edit: såg nu att Filsystem-ID 0x07 är HPFS/NTFS. Borde det inte vara det?

Trädvy Permalänk
Medlem
Plats
i landet
Registrerad
Jul 2005

Ursäkta en dum?? fråga : Vad är Suse 9.3 förnågot och vad är
det bra för ???
Ha det !

Volvomannen

Trädvy Permalänk
Medlem
Plats
Södra norrland
Registrerad
Jul 2003
Citat:

Ursprungligen inskrivet av pappirappi
Ursäkta en dum?? fråga : Vad är Suse 9.3 förnågot och vad är
det bra för ???
Ha det !

SuSE 9.3 är en distrobution av linux. Dvs ett OS som är byggt kring linuxkerneln.

S|eeper: Vet inte om det är rätt men har sett i diverse grub.conf guider att man ska skriva

makeactive

i sin bootsekvens för windows. Har för mig att det ska stå före chainloader +1 men är inte säker. Ta detta med en stor nypa salt men det kan ju vara värt att testa

Stationär: i5 750@3.8GHz kylt av H80 P'n'P| Asus DC2 7970 | 8GB RAM | 750GB SSD + 2.5TB HDD | FD Define R2 | beQuiet Dark Power 850W |
Bärbar: 13" rMBP | i5 2.4GHz | 8GB RAM | 256GB SSD | Intel Iris |

Trädvy Permalänk
Medlem
Registrerad
Okt 2003
Citat:

Ursprungligen inskrivet av Willhelm
S|eeper: Vet inte om det är rätt men har sett i diverse grub.conf guider att man ska skriva

makeactive

i sin bootsekvens för windows. Har för mig att det ska stå före chainloader +1 men är inte säker. Ta detta med en stor nypa salt men det kan ju vara värt att testa

Hmm.. i min grub.conf är det enda som står:
"setup --stage2=/boot/grub/stage2 (hd0) (hd1,2)
quit"

Det var i min menu.lst som det står "chainloader +1".

Menmen, för en nybörjare som mig är det klart värt att testa! Tackar för förslaget, men kom gärna med fler!

Edit: hjälpte inte att skriva in det i min menu.lst iaf. Enda skillnaden var att det istället står:
"root (hd1,0)
Filesystem type unknown, partition type 0x7
makeactive
chainloader +1"