Midnight Commander - å ä ö

Trädvy Permalänk
Medlem
Registrerad
Sep 2003

Midnight Commander - å ä ö

Får inte å ä ö att funka när jag använder Midnight Commander.
Har testat att lägga till "export LANG=sv_SE.ISO-8859-1" i .bachrc och i .profile men det gör ingen skillnad.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

har inte heller lyckats få rätt med det tyvär

hade varit kul om nån hade hittat det.. tyvär verkar många avsky MC hehe

Trädvy Permalänk
Medlem
Plats
i min SGI Indigo
Registrerad
Maj 2004

Re: Midnight Commander - å ä ö

Din locale lär vara fscked up, i Fedora Core 4 funkar det problemfritt med åäö i mc.

Är du säker på att du kör ISO-8859-1?

själv kör jag UTF-8 och kommandot "locale" ger följande utdata:

LANG=sv_SE.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=

och följande, vad ska man med mc till när man kan tabba filnamn och använda kraftig regexpr i skalet?

yum remove mc

/Tj

Trädvy Permalänk
Medlem
Plats
Plats?
Registrerad
Feb 2004

Forsok satta 'export LC_CTYPE=<onskad locale>' i bash_profile istallet.

Stationär: P4 2,8C @ 3,1 GHz/ Asus P4C800E-DLX/ 1 GB Kingston PC 3200/ Hercules 3D Prophet 9800 Pro @ XT 423\368 / VGA Silencer/ 80 GB + 40 GB HDD/ Antec Sonata; 380 W PSU, 2x 120 mm/ HP LJ1015/ Gentoo Linux 2005.0
Bärbar: Asus M6BNe; 15,4" WXGA/ Dothan @ 1,8 GHz/ 1 GB Kingston PC 2700/ ATI Rad M 9700/ 60 GB Hitachi @ 7200 rpm

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Re: Re: Midnight Commander - å ä ö

Citat:

Ursprungligen inskrivet av T-Mastah J

och följande, vad ska man med mc till när man kan tabba filnamn och använda kraftig regexpr i skalet?

för att regexpr är asdrygt... bara användbart vid ytterst nödvänligt..

Har testat alla locale-inställningar nu... det blir på svenska bara.. men man kan inte skriva ÖÅÅ för det..

Trädvy Permalänk
Medlem
Registrerad
Nov 2004

Har du kollat i menyn under "Options" -> "Display bits" så att inställningarna där stämmer?

Trädvy Permalänk
Medlem
Registrerad
Sep 2003

Vad ska det vara för inställningar då?

Trädvy Permalänk
Medlem
Registrerad
Nov 2004

På "Input / display codepage" väljer du ISO 8859-1 om du kör det på systemet. Minns inte säkert, men tror du bör klicka i "Full 8 bits input" också.