liten bootbar linux-cd för att fixa lilo-problem

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002

liten bootbar linux-cd för att fixa lilo-problem

Jag har lyckats totalförstöra LILO-inställningarna på min garderobsdator. Nu behöver jag någo form av bootbar cd med linux för att ställa allt till rätta. Problemet är att jag inte kan köra något grafiskt gränssnitt på datorn då jag saknar mus och skärmen (en vanlig 28" tv) inte är rolig att använda till det...

Jag har försökt med SUsEs live-cd, men den är ju grafisk. Försökte även med Knoppix, men även den verkar försöka starta nått grafiskt (skärmen blir grå och flimmrar).

Finns det nån mindre, enklare live-cd, som har stöd i kärnan för många olika typer av hårdvara (behöver stöd för ett SATA-kontrollerkort från silicon-image) och som bara lämnar mig i en kommandoprompt med root-access så att jag kan skriva tillbaka lilo?

EDIT: kör debian på burken...

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Jan 2003

Går det inte att låna skärm och mus från en annan dator?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002

joo... det hade väl gått... men nu är det så att det av någon oooutgrundlig anledning är så att bara tv-outen funkar på grafikkortet... så...

aja... lyckades boota knoppix i RL 2 så jag bara har kommandoprompt.

nu gäller det bara att skriva tillbaka lilo på rätt sätt.

Trädvy Permalänk
Medlem
Registrerad
Jul 2001

DSL är liten...50Mb

www.damnsmalllinux.org

skriv dsl 2 i prompten (typ 5 sek efter att skivan snurrat igång)

dsl 2 kör igång utan grafiskt stöd

Har varit på detta forum på tok för länge...

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

Använd Debianskivan igen?

Finns något sätt att boota in i en existerande installation har jag för mig.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

Starta Knoppix genom att skriva knoppix blind.

::.. KDE Neon ..::
Home | MAME Arcade
Spelkonsoler

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av m0REc
Använd Debianskivan igen?

Finns något sätt att boota in i en existerande installation har jag för mig.

Det vore precis vad jag behöver... nån som vet hur man gör på rak arm?

Trädvy Permalänk
Medlem
Registrerad
Maj 2005

slarvas det med nödfallsbootdisketterna månne...?

bitte kein Hotlinking!

Trädvy Permalänk
Medlem
Plats
:sʇɐlԀ
Registrerad
Dec 2003

Annars typ såhär:
boot med knoppix
växla till tty2(eller 3,4,5,6) med ctrl-alt-f2
bli root
mkdir /mnt/oldroot
mount /dev/dinhårddiskochpartition /mnt/oldroot
chroot /mnt/oldroot
lilo

i5-4670k | GTX 670 | ASUS Z87-A | 2x4GB Corsair Vengeance 1333 MHz | Corsair VX 450 | 80 GB Intel X25 SSD systemdisk | 256 GB Samsung 840 spel/cachedisk | 2+3 TB WD Green lagringsdiskar | Fractal Define R4 | G2420HDBL (24") + L227WT (22")

Citera för svar!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av Ingen
Annars typ såhär:
boot med knoppix
växla till tty2(eller 3,4,5,6) med ctrl-alt-f2
bli root
mkdir /mnt/oldroot
mount /dev/dinhårddiskochpartition /mnt/oldroot
chroot /mnt/oldroot
lilo

problemet med den metoden (har redan prövat ) är att den inte verkar kunna köra lilo pga fel version av Device-mapper i knoppix. Jag behöver alltså vara i "mitt" system för att kunna fixa det. moment 22 : /

Tubgirl: mjo... du vet hur det är "äh, jag ar aldrig behövt den innan, varför skulle jag göra en nu"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

På ditt första inlägg låter det som om lilo bootar i högre upplösning än vga=normal? Eller är det X som startas när skärmen blir grå?
Provade du att boota Knoppix genom att skriva 'knoppix blind'?
Blev det någon skillnad eller är det nåt annat som strular nu?

::.. KDE Neon ..::
Home | MAME Arcade
Spelkonsoler

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av apeekaboo
På ditt första inlägg låter det som om lilo bootar i högre upplösning än vga=normal? Eller är det X som startas när skärmen blir grå?
Provade du att boota Knoppix genom att skriva 'knoppix blind'?
Blev det någon skillnad eller är det nåt annat som strular nu?

botade med "knoppix 2" då startar den i RL 2...

nu är det själva tillbakaskrivningen av lilo som är problemet, då LILO klagar på att knoppix har fel version av Device-mapper.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

Ok, då är jag med.

Jag är osäker på vad ditt felmeddelande betyder, men en sökning på google antyder att du använder LVM?

Jag kör ingen speciellt avancerad hårddisk-konf och har aldrig behövt göra någon chroot innan jag har skrivit tillbaka lilo.

Det har bara varit några enkla steg:
* Radera sym-länken som ligger i rooten och som pekar på kärnan som Knoppix bootar på.
* Mounta partitionen som /boot och /etc ligger på och skapat en ny sym-länk till min kärna som jag vanligtvis använder.
* Köra 'lilo -C /mnt/hda3/etc/lilo.conf' eller var du nu råkar ha din lilo.conf nånstans.

::.. KDE Neon ..::
Home | MAME Arcade
Spelkonsoler

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002
Citat:

Ursprungligen inskrivet av apeekaboo
Ok, då är jag med.

Jag är osäker på vad ditt felmeddelande betyder, men en sökning på google antyder att du använder LVM?

Jag kör ingen speciellt avancerad hårddisk-konf och har aldrig behövt göra någon chroot innan jag har skrivit tillbaka lilo.

Det har bara varit några enkla steg:
* Radera sym-länken som ligger i rooten och som pekar på kärnan som Knoppix bootar på.
* Mounta partitionen som /boot och /etc ligger på och skapat en ny sym-länk till min kärna som jag vanligtvis använder.
* Köra 'lilo -C /mnt/hda3/etc/lilo.conf' eller var du nu råkar ha din lilo.conf nånstans.

Har helt kopplat ur asmtliga diskar i min LVM nu, men LILO klagar fortfarande.

Detta är meddelandet jag får upp när jag kör lilo med min conf

/proc/misc: No entry for Device-mapper found
Is Device-mapper missing from the kernel?
/dev/mapper/control: open failed: Permission denied
Faliure to communicate with kernel device-mapper driver.
/proc/misc: No entry for Device-mapper found
Is Device-mapper missing from the kernel?
/dev/mapper/control: open failed: Permission denied
Faliure to communicate with kernel device-mapper driver.
Incompatible libdevmapper 1.01.00-ioctl (2005-01-17)(compat) and kernel driver
Fatal: open /dev/sda: permission denied

"Fatal: open /dev/sda: permission denied" står bara om jag har chrootat till partitionen sda2 först.

Kan detta bero på att jag använder en satadisk? Eller har jag missat att ändra rättighet till nån uppenbar fil?

EDIT: hmmmm... det verkar som om jag inte kan bli root efter att jag chrootat... därav persmission denied

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2002

Jag har tyvärr ingen erfarenhet av LVM, men nån annan kanske har några bra tips.
Enligt felmeddelandet så låter det ju som att LVM saknas i kärnan du bootar på.

::.. KDE Neon ..::
Home | MAME Arcade
Spelkonsoler

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2002

Det är ju det som är så sjukt... den ger det där felmeddelandet oavsett om jag försöker skriva till mbr med min eller deras lilo.conf och både när jag skriver den till /dev/sda och /dev/fd0.

Min LVM har jag helt kopplat ur pga de där felmeddelandena, då den bara används till lagring och inte är bootbar över huvud taget.

jag förstår inte varför lilo ens försöker göra nått med lvm.

EDIT: har äntligen fått den att boota...