wlan.. funkar typ åt ena hållet

Trädvy Permalänk
Medlem
Plats
Slottsbron
Registrerad
Jan 2002

wlan.. funkar typ åt ena hållet

jag har ett 3com CRWE154A72 och använder madwifi (antar jag iaf... har lagt med stöd för en drös kort i kerneln (prism54 å atheros iaf)) och det verkar nästan funka. jag tror jag ska använda prism54 egentligen(upptäckte det nyss) men eftersom kortet hittas å så, så jag antar att det ska gå bra ändå. Jag kan få ip av dhcpservern men längre än så går det inte. jag kan inte pinga ut från datorn, men pinga utifrån å in går. i gentoos (använder gentoo...) irc kanal funderade de kring routing tabellen, och det verkar mest troligt, men varken de eller jag hittade nåra fel.

laptop peter # route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 * 255.255.255.0 U 0 0 0 eth0 192.168.0.0 * 255.255.255.0 U 0 0 0 ath0 loopback localhost 255.0.0.0 UG 0 0 0 lo default server 0.0.0.0 UG 0 0 0 ath0 default server 0.0.0.0 UG 0 0 0 eth0

just nu sitter eth0 kabeln i, men det gör ingen skillnad på det hela(förutom att routing tabellen blir mindre) om man drar ur den..

laptop peter # iwconfig ath0 IEEE 802.11a ESSID:"whoracle" Mode:Managed Frequency:5.2 GHz Access Point: 00:0D:54:F7:59:B3 Bit Rate=54 Mb/s Tx-Power:50 dBm Sensitivity=0/3 Retry:off RTS thr:off Fragment thr:off Encryption key:4E07-B21D-C5 Security mode:open Power Management:off Link Quality=36/94 Signal level=-59 dBm Noise level=-95 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

laptop peter # ifconfig ath0 Link encap:Ethernet HWaddr 00:0D:54:A7:A8:0D inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0 UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1 RX packets:10 errors:0 dropped:0 overruns:0 frame:0 TX packets:2 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:199 RX bytes:932 (932.0 b) TX bytes:686 (686.0 b) Interrupt:10 Memory:dfa40000-dfa50000

laptop peter # lspci 0000:02:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01) Subsystem: 3Com Corporation: Unknown device 6002 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- Latency: 168 (2500ns min, 7000ns max), cache line size 20 Interrupt: pin A routed to IRQ 10 Region 0: Memory at 1f800000 (32-bit, non-prefetchable) Capabilities: [44] Power Management version 2 Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-) Status: D0 PME-Enable- DSel=0 DScale=2 PME-

nån som kan hjälpa?

peter@server ~ $ uptime
22:26:14 up 30 days, 21:28, 4 users, load average: 21.77, 42.33, 26.94

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Frequency: 5.2 GHz ??

Kör du .11a hemma eller?

Trädvy Permalänk
Medlem
Plats
Slottsbron
Registrerad
Jan 2002

a/b/g är kortet och accesspunkten kapabla till.

peter@server ~ $ uptime
22:26:14 up 30 days, 21:28, 4 users, load average: 21.77, 42.33, 26.94