Trädvy Permalänk
Medlem
Plats
Staden
Registrerad
Sep 2003

Konfigurering av PHP

Jag skulle behöva utförliga beskrivningar över vad som behöver göras för att få igång php på min Debian server med apache 1.3.33.
Apache funkar felfritt.

Jag har instalerat "php3" via apt-get. Och sen då? Jag antar att det är lite konfande i diverse config filer. Och det är detta som jag behöver hjälp med.

Tack på förhand.

Trädvy Permalänk
Medlem
Registrerad
Okt 2004

jag körde apt-get install apache php4-* så funkar det direkt + att man får en massa grejer med... gör man det i efterhand måste man väl ändra massa config-filer? Annars kan du ju prova att köra apachectl restart efter att ha installerat PHP...
EDIT: kör hellre php4 än php3 Om du nu inte har speciella skäl att använda php3..

Trädvy Permalänk
Medlem
Plats
Staden
Registrerad
Sep 2003

Okej, tack. Jag testar med php4 istället. "apachectl restart" startar den bara om apache? Det har jag redan gjort isf.

Edit: Tack! Det funkade prima. Nu kan jag börja lära mig php.

Min första kodsnutt: http://mixdisk.no-ip.com/php

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Mar 2002

php3!?
Trodde att så gamla version av php förvandlats till damm och försvunnit

"Knowledge amplification. What he learns, we all learn. What he knows, we all benefit from."

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

<?php phpinfo(); ?>

brukar vara rätt vanligt som första kodsnutt, så får man lite information om ens PHP-installation.

KentRoyal: So did I.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Nov 2002

Är inte linux en billig kopia av ms-dos?

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Dec 2001
Citat:

Ursprungligen inskrivet av akn3
http://www.php.net/manual/sv/install.unix.php#install.unix.ap...

Där har du en kanon dokumentation!

Eller som man gör i debian, 'apt-get install libapache-mod-php4'

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Nov 2002
Citat:

Ursprungligen inskrivet av peppelorum
Eller som man gör i debian, 'apt-get install libapache-mod-php4'

debain ja, men jag är hardcore

Är inte linux en billig kopia av ms-dos?

Trädvy Permalänk
Medlem
Plats
Staden
Registrerad
Sep 2003

Jag vet inte varför jag instalerade php3. Jag sökte bara på php och såg php3 paketet och så stod det något om att det var för Apache 1.3.33.
Jag kollade igenom paketen lite för fort. Men funkar allt och för tillfället så följer jag Don_Tomaso php guide.

Tack för hjälpen.