Kan någon hjälpa mig i min misär (hd-crash, vill testa mounta från BSD men hur göra?)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Kan någon hjälpa mig i min misär (hd-crash, vill testa mounta från BSD men hur göra?)

Den förbannade jävla windows-disken rasade tydligen till slut.
Kopplade in min gamla floppy för att försöka boota från en startdiskett men datorn tycker att floppyn också är trasig.

Så, jag drog nu igång BSD-disken, och har (trasiga?) windows-disken sittande bredvid som slav.

Hur gör jag nu för att från FreeBSD mounta och försöka kika på disken?

Jag menar, även om den inte går att boota från så kanske kanske kanske det går att rädda lite filer, eller är det osannolikt?

Väldigt tacksam för snabb hjälp som ni kanske förstår

EDIT: Ingen aning, men chansade med detta.

server# mount /dev/ad1 /win mount: /dev/ad1 on /win: incorrect super block

Är det nåt fel jag gjort, eller är det så man gör och är det där i så fall ett väldigt otrevligt felmeddelande som betyder att disken är så paj att jag inte kan mounta den ens???

CCNA sedan juni 2006

Trädvy Permalänk
Hedersmedlem
Registrerad
Jul 2001

Mount vet inte vilket filsystem partitionen innehåller.
Använd mount_ntfs, men läs manualen först.

Sen ser jag att du försöker mounta hela hårddisken, du måste välja en partition. ex:
mount_ntfs -r /dev/ad1s1 /win
(disk 1, slice(partition) 1)

Bienvenido a la maldad

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Aphex
Mount vet inte vilket filsystem partitionen innehåller.
Använd mount_ntfs, men läs manualen först.

Sen ser jag att du försöker mounta hela hårddisken, du måste välja en partition. ex:
mount_ntfs -r /dev/ad1s1 /win
(disk 1, slice(partition) 1)

Ok, tack, ska testa nu
Visste det där med slices, men tänkte att den inte skulle känna igen windows-partitioner utan bara ta hela disken direkt.

EDIT: -r gillade den inte (kankse nåt Linux-trams som inte funkar i BSD ) men utan det så verkar den faktiskt mounta. Nu ska jag se om jag kan kopiera över filer också :):):)

EDIT2: mount_ntfs /dev/ad1s1 /win funkar fint och ger mig c: som jag inte har nåt viktigt alls på, medans mount_ntfs /dev/ad1s2 /win ger "invalid argument". Borde inte d: vara s2 och c: är s1???

EDIT3: ad1s2s1 var det visst

CCNA sedan juni 2006