Trädvy Permalänk
Medlem
Plats
i eeeeen tunna
Registrerad
Okt 2002

PCRE-stöd till php

hej!
Jag är nybörjare vad gäller *NIX och sånt därnt, och har precis gjort en ominstalltion på min server. Men när jag försöker köra min gästbok känner den inte igen funktion preg_split(), och efter lite efterforskning visade det sig att min php4-installation saknade stöd för pcre(perl compitabel regular expressions). NU undrar jag, finns det något lätt sätt att ordna detta ? genom någon port?

Jag kör FreeBSD 4.11.

"en trevlig sak man skulle kunna göra med hans fru, det är om man malde ner henne till köttfärs, med salt och peppar och sånt där. Så gjorde man en 352 hamburgare av henne som man då gav till honom. För att då skulle ju inte han kunna äta upp dom.. ja för han är ju vegetarian. Det vore trevligt."

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2002

Aldrig kört FreeBSD 4, men bör vara samma sak som i 5.

cd /usr/ports/lang/php4-extensions make config // och välj PCRE make install clean

Perl - Made by Idiots, Java - Made for Idiots, C++ - Envied by Idiots
Homepage: http://rgba.se
IRC: #code.se at QuakeNet

Trädvy Permalänk
Medlem
Plats
i eeeeen tunna
Registrerad
Okt 2002

Fungerade utmärkt, tack för hjälpen!

"en trevlig sak man skulle kunna göra med hans fru, det är om man malde ner henne till köttfärs, med salt och peppar och sånt där. Så gjorde man en 352 hamburgare av henne som man då gav till honom. För att då skulle ju inte han kunna äta upp dom.. ja för han är ju vegetarian. Det vore trevligt."