Ajajaj, kan detta bli problem? (å ä ö filnamn i min Samba-share gillas inte av BSD)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Ajajaj, kan detta bli problem? (å ä ö filnamn i min Samba-share gillas inte av BSD)

Kom just på att å ä ö funkar ju inte i terminalen i FreeBSD.
Och den ersätter inte å ä ö med varsin teckenkombination, utan alla verkar ersättas med "?".

Det lär ju betyda att när jag ska mounta min Samba-share med Mina dokument och digitalkamerabilder och alla hundratals filer som innehåller å ä ö så kommer det gå åt skogen

Vad göra? Fler än jag lär väl ha Unix som filserver och använda svenska tecken i windows.

Har bara servern än så länge och förbereder den nu så gott jag kan inför kommande burkarna nästa/nästnästa vecka.

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Boden
Registrerad
Maj 2004

Borde finnas nått script som döper om alla ö till 'o', eller kanske rakt av o.
Jag undrar för övrigt också om det finss nån lösning till detta?

Macbook Vit | Macbook Unibody | D80 | iPod Touch | iPhone 3GS

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

ÖÄÅ ser ut som öäå på min. Mellanslag är också ett problem.

Gissar på att samba har fel codepage inställd eller något

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av maDa
ÖÄÅ ser ut som öäå på min. Mellanslag är också ett problem.

Gissar på att samba har fel codepage inställd eller något

Hmm...fast jag har ju inte testat via Samba än eftersom jag inte har nån färdig XP-klient.
Jag bara konstaterade att alla filer jag kopierat in till FreeBSD har fått å ä ö ersatt av "?".

Kanske har en lösning på gång här ifall nån är intresserad....hoppas det iallafall

http://www.freebsd.se/forum/viewtopic.php?forum=1&showtopic=4...

CCNA sedan juni 2006

Trädvy Permalänk
Hedersmedlem
Registrerad
Jul 2001

Börja med att ordna det rätt i terminalen, livet blir mycket lättare då.

keymap="swedish.iso" font8x14="iso-8x14" font8x16="iso-8x16" font8x8="iso-8x8"

i din /etc/rc.conf

export INPUTRC=/etc/inputrc

i din /etc/profile

set input-meta on set output-meta on set convert-meta off set meta-flag on

i din /etc/inputrc

Bienvenido a la maldad

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Aphex
Börja med att ordna det rätt i terminalen, livet blir mycket lättare då.

keymap="swedish.iso" font8x14="iso-8x14" font8x16="iso-8x16" font8x8="iso-8x8"

i din /etc/rc.conf

export INPUTRC=/etc/inputrc

i din /etc/profile

set input-meta on set output-meta on set convert-meta off set meta-flag on

i din /etc/inputrc

Stort tack, ska testa detta
Keymap Swedish ISO har jag dock redan, valde det och massa annat swedish, western european etc etc under installationen, men det verkar ändå inte som man får svenska tecken. Kanske dom där font-grejerna som fattas.
Mycket spännande om detta ska fungera

EDIT: rc.conf var redan rätt. La till raden i profile samt skapade den sista filen för den hade jag inte alls. Ska boota om och testa nu....håll tummarna

EDIT2: Nej men självklart, det hade ju varit FÖR bra om det hade funkat
Ingen skillnad utanför X, fortfarande ?.
Samma från terminalfönster inne i X, fast där kan jag iallafall skriva å ä ö (vet inte om jag kunde det tidigare dock).

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Gislaved
Registrerad
Jan 2003

Det går att ändra nått i sambas conf för att den skall hantera filnamn med svenska tecken också, minns inte det i huvudet dock. Har kört med det iaf så det funkar..

En del av mina bildlänkar hostas på egen maskin, är bildlänkarna trasiga, ha tålamod.

Trädvy Permalänk
Hedersmedlem
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Seb74
Keymap Swedish ISO har jag dock redan, valde det och massa annat swedish, western european etc etc under installationen

Du skall inte ha någon "screenmap". kolla i rc.conf så du inte valt det.
sen fungerar rc.conf så att om samma inställning finns med flera gånger, så gäller den som står sist. undersök om det kan vara problemet.

Bienvenido a la maldad

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Karaff, menar du att lägga till följande i smb.conf?

character set = iso8859-1 valid chars = 206:217 204:216 224:231 32

Aphex, stort tack för hjälpen. Vore väldans trevligt att få till å ä ö i terminalen (antar att det då kanske funkar automatiskt i Samba, eller om det inte har nån betydelse alls kanske är mer troligt iofs, men vore ju praktiskt iallafall).
screenmap har jag tydligen valt, ska testa ta bort det. Här är min rc.conf. Tar bort och bootar om nu så får vi se

# -- sysinstall generated deltas -- # Sat Sep 3 16:21:01 2005 # Created: Sat Sep 3 16:21:01 2005 # Enable network daemons for user convenience. # Please make all changes to this file, not to /etc/defaults/rc.conf. # This file now contains just the overrides from /etc/defaults/rc.conf. font8x14="iso-8x14" font8x16="iso-8x16" font8x8="iso-8x8" hostname="server.hemma" ifconfig_rl0="DHCP" keymap="swedish.iso" keyrate="normal" linux_enable="YES" moused_enable="YES" scrnmap="iso-8859-1_to_cp437" sshd_enable="YES" usbd_enable="YES" samba_enable="YES" mysql_enable="YES" # Add the following lines to /etc/rc.conf to enable apache2: apache2_enable="YES" # apache2ssl_enable (bool): Set to "NO" by default.

EDIT: Lite bättre minsann, utan screenmap. Nu kan jag skriva å ä ö i terminalen. Skapar jag en fil som heter "blå" så kan jag ta bort den med "rm blå", men den skapade filen visas fortfarande som "bl?", men som sagt kan jag nu iallafall skriva å ä ö så kanske att det bör gå att få Samba att visa det rätt så att XP kan använda Samba-sharen precis som det ska vara. Om det sedan visas som ? när man väl är inne i BSD är ingen katastrof egentligen, men lite trist är det ju.

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Gislaved
Registrerad
Jan 2003

Exakt.

En del av mina bildlänkar hostas på egen maskin, är bildlänkarna trasiga, ha tålamod.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av Karaff
Exakt.

Perfekt
Får hoppas det funkar då också....kan tyvärr inte testa förren nya datorerna kommer, och datorbutiken har tvärslut på alla sina AMD-processorer så jag vetefan när det blir

Men jag hoppas att Samba kommer klara att visa (och skriva) å ä ö till filnamnen i BSD-sharen, och att det sedan fortfarande visas som "?" när man väl kikar i BSD's terminal det är ju faktiskt (nästan) skit samma.

CCNA sedan juni 2006