OSX - Problem med svenska tecken vid montering av NFS-share

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Okt 2001

OSX - Problem med svenska tecken vid montering av NFS-share

Hej
Jag har monterat en NFS-share som ligger på en dator körandes debian från min MacBook Pro men alla svenska specialtecken, dvs åäö, blir till ? och det resulterar i att filerna i katalogerna innehållandes åäö blir oåtkomliga.

Så hur löser jag detta problem?
Ska det lösas från osx eller från linux/debian?
Vilken teckenkodning är bäst att använda?

MVH Niclas

Har bytt namn från: nulleman ~ Blogg: http://skorpion.se
MacBook Pro: 15.4' ~ 1.83GHz ~ 1512MB RAM ~ 80GB HDD
Medlem i signaturen blodtörstiga Appleanvändare

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2002

OS X använder iaf unicode hur du än vrider och vänder på saken..

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2004

bäst teckenkodning e nog köra samma på båda "sidor", annars lär man garanterat få konverterings probs.

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Okt 2001

okej, så då skall jag använda utf-8
Men om jag kollar manualen för mount så hittar jag inget argument för att montera ett filsystem med ext3 med utf-8. Någon som vet hur jag gör då?

/Niclas

Har bytt namn från: nulleman ~ Blogg: http://skorpion.se
MacBook Pro: 15.4' ~ 1.83GHz ~ 1512MB RAM ~ 80GB HDD
Medlem i signaturen blodtörstiga Appleanvändare

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004
Citat:

Ursprungligen inskrivet av skorpion
okej, så då skall jag använda utf-8
Men om jag kollar manualen för mount så hittar jag inget argument för att montera ett filsystem med ext3 med utf-8. Någon som vet hur jag gör då?

/Niclas

iocharset=utf8 vet jag funkar på fat diskar iaf, men med ext3 tror jag att du bara behöver ändra till en utf8 locale.

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Okt 2001

Tar upp den här tråden igen för att höra om någon har stött på samma problem och löst det?
För jag har fortfarande problem, dock inte exakt lika. Nu så ser jag iaf åäö oavsett om jag döpt filerna i OSX eller Debian. Så det är inga frågetecken nu som det var förrut.
Men trots att OS X kan läsa filerna (med åäö) som är monterade från en NFS-utdelning på Debian så går dem tex inte att lägga till i iTunes eller ens att kopiera någonstans i Finder.

Något som däremot fungerar i OSX med dessa filer är att visa info i Finder och spela upp musiken under översikt. Samt att kopiera filen i Terminal, men då terminal inte riktigt gilalr åäö så gör den om kommandot såhär:

cp Music/musik/Blue\ \303\226yster\ Cult/Imaginos/01.\ Blue\ \303\226yster\ Cult\ -\ I\ am\ the\ one\ you\ warned\ me\ of.mp3 Desktop/

Så är det någon som har en lösning på detta irriterande problem?

MVH Niclas

Har bytt namn från: nulleman ~ Blogg: http://skorpion.se
MacBook Pro: 15.4' ~ 1.83GHz ~ 1512MB RAM ~ 80GB HDD
Medlem i signaturen blodtörstiga Appleanvändare

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av skorpion
Tar upp den här tråden igen för att höra om någon har stött på samma problem och löst det?
För jag har fortfarande problem, dock inte exakt lika. Nu så ser jag iaf åäö oavsett om jag döpt filerna i OSX eller Debian. Så det är inga frågetecken nu som det var förrut.
Men trots att OS X kan läsa filerna (med åäö) som är monterade från en NFS-utdelning på Debian så går dem tex inte att lägga till i iTunes eller ens att kopiera någonstans i Finder.

Något som däremot fungerar i OSX med dessa filer är att visa info i Finder och spela upp musiken under översikt. Samt att kopiera filen i Terminal, men då terminal inte riktigt gilalr åäö så gör den om kommandot såhär:

cp Music/musik/Blue\ \303\226yster\ Cult/Imaginos/01.\ Blue\ \303\226yster\ Cult\ -\ I\ am\ the\ one\ you\ warned\ me\ of.mp3 Desktop/

Så är det någon som har en lösning på detta irriterande problem?

MVH Niclas

Har samma problem när jag kör sshfs eller ftpfs emot min Ubuntuserver, den kör allt på UTF-8. Bokstäver etc. ser helt rätt ut, men filer som har åäö, eller ligger i en mapp med åäö går inte att spela upp/öppna på något vis.

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Mar 2003

Jag skulle tro att det är det här som är problemet, men jag har inte försökt fixa det själv än så jag vet inget säkert. OS X använder NFD och Linux oftast NFC.

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011

Återuppväcker denna efter 9 ÅR i hibernation...

Någon som vet om detta är löst än fr.o.m El Capitan?
Jag mountar en NFS share från min server (linux debian) på min Mac, och Finder kan se filer/kataloger med åäö, men kan inte öppna dem i någon applikation. Dock kan jag kopiera dem i terminalen till en fil som inte innehåller åäö och sedan använda den.

Har alltså inga problem med åäö att mounta samma share på min andra linux klient, så det ser ut att vara ett macproblem.

Vore rätt pinsamt om Apple inte fixat detta ännu!

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011

Om det hjälper någon så hittade jag lösningen. Lägg till option 'nfc' i mount-kommandot.