could not open default cursor font 'cursor'

Trädvy Permalänk
Medlem
Plats
örebro
Registrerad
Aug 2005

could not open default cursor font 'cursor'

ubuntu dapper

Xorg.0.log går bra tills:
Fatal Server Error:
could not open default cursor font 'cursor'

följt av att X dör

jag installerade och tog bort paketet artwiz-cursor med apt-get & dpkg --remove , --purge

nu är saker lite sönder, och jag tror att det ligger här:

$ dpkg-divert --list:
....
diversion of /usr/share/X11/fonts/misc/cursor.pcf.gz to /usr/share/X11/fonts/misc/cursor.pcf.gz-artwiz by artwiz-cursor

ta bort:
$dpkg-divert --truename *cursor*
cursor.pcf.gz-artwiz

$ dpkg-divert --remove cursor.pcf.gz-artwiz
No diversion `any diversion of cursor.pcf.gz-artwiz', none removed <- motsägelsefullt

okejokej:
http://xprint.mozdev.org/docs/Xprint_FAQ.html#id2879698
Q:

Xprt refuses to start with the message "Fatal server error: could not open default font 'fixed'" or "Fatal server error: could not open default cursor font 'cursor'".
A:

All Xservers at least two fonts as the minimum: One fixed-width font ("fixed") and one font for the cursor ("cursor"). Be sure that the font path contains these fonts.

var hittar jag dessa fonts online/hur installerar jag-?

(defmacro lisp-bootstrap (expr) expr)

Trädvy Permalänk
Medlem
Plats
Söderhamn
Registrerad
Okt 2004

Jag råkade ut för exakt samma sak när jag lekte med fluxbox i dapper, strulade med det i flera dagar men fick ingen ordning alls på det och ingen annan hade råkat ut för det då heller, orkade inte hålla på så jag kastade in dapper igen helt enkelt och sparade min gamla /home och sådant.

Jag fick känslan av att det var nånting som pajade någonstans, men lyckades inte hitta vad det var då för inget jag gjorde eller försökte med löste problemet eller ens påverkade det.

i7-3960X, Asus Sabertooth X79, Asus GTX970, Bequiet Silent Loop 120, Corsair Vengence 32GB, Corsair HX650, Samsung 840 EVO 250Gb, Intel 520 120Gb, 1+2 Tb HDD, Dell U2515H

Trädvy Permalänk
Medlem
Plats
örebro
Registrerad
Aug 2005
Citat:

Ursprungligen inskrivet av PMJ
Jag kastade in dapper igen helt enkelt och sparade min gamla /home och sådant.

OK, om det nu fungerar, kan du:

tar -cvvf till_mig.tar /usr/X11R6/lib/X11/fonts/misc/

och ladda upp någonstans?

(defmacro lisp-bootstrap (expr) expr)

Trädvy Permalänk
Medlem
Plats
sthlm
Registrerad
Okt 2003

Du kan ju annars installera om X.org server och dess andra paket.

Så borde det fixas.

Trädvy Permalänk
Medlem
Plats
örebro
Registrerad
Aug 2005
Citat:

Ursprungligen inskrivet av zyk
Du kan ju annars installera om X.org server och dess andra paket.

Så borde det fixas.

mmm fungerar nu
kopierade in gamla mappen från en ubuntu 5.04 live cd

(defmacro lisp-bootstrap (expr) expr)