Trädvy Permalänk
Medlem
Registrerad
Jun 2005

Ubuntu Internet

Hej!

Har precis installerat Ubuntu 6.06. Har lite problem att få igång internet. Det fungerar hur bra som helst med Live CD men av någon anledning vägrar den få kontakt när jag bootar från HD och den "riktiga" installationen. Kör med statisk IP och har konfigurerat eth0 med IP-adresser och DNS-servers där jag förövrigt fick ange password. Så långt gick det bra.

Är det någon rättighet eller liknande som måste sättas (jag loggar in som den användaren som skapas under installation)? Någonting med nätverkskortet (borde inte va eftersom det funkar med Live CD)? Tycker det är skumt iaf.

Behöver nog inte tillägga att jag e noob... men tacksam för svar!

// R

Trädvy Permalänk
Medlem
Plats
Trollhättan
Registrerad
Apr 2005

testa i nätverksinställningarna att inaktivera kortet och sen aktivera det igen. Kanske kan fungera.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

hjälpte inte. inte heller med de (många) förslag som ges på ubuntus forum som jag testade inatt. f*n va less man blir. grr!

ska testa med att köra in lite uppdateringar och plugga ur modemet. annars får det nog bli en annan dist/XP, tyvärr.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Jag hjälper gjärna till, men då vill jag att du skickar en länk till (eller skriver ner) de saker du testat, så jag slipper föreslå att du gör saker som du redan gjort.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

Det tackar jag för!

Funkade icke:
http://ubuntuforums.org/showthread.php?t=186430

Hittade dessa nu (sitter på jobbet). Förstår dock inte riktigt de sista inläggen i resp:
http://www.ubuntuforums.org/showthread.php?t=146846&page=2&hi...
http://www.ubuntuforums.org/showthread.php?t=201030&highlight...

Låter lite långsökt, hittade nu:
http://www.ubuntuforums.org/showthread.php?t=205466&highlight...
http://www.ubuntuforums.org/showthread.php?t=211253&highlight...

I övrigt är nog det mesta till hjälp. Kan mycket väl ha missat någon grundinställning. Förutom ovanstående har jag ensast konfigurerat via Menyn/Networking/

Har förövrigt ett realtek nätverkskort.

// R

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Lite smågrejer du kan roa dig med tills dess att jag kommer hem till min Ubuntuburk och kan bilda mig en uppfattning om konfigurationsverktygen;

Jag vill att du bootar från LiveCD'n och postar texten från följande kommando här: dmesg, lspci, lsmod och ifconfig

Det kan hända att några av dem bara finns i sökvägen för adminanvändaren, så då får du köra dem med "sudo" framför.

Därefter vill jag att du gör samma sak fast när du bootat från hårddisk. Här kan det vara praktiskt med t.ex ett USB-minne eller annan form av skrivbart media för att lagra textmassorna från dessa program så att du inte behöver skriva av dem för hand.

Säg till om du inte hänger med.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005
Trädvy Permalänk
Medlem
Registrerad
Okt 2002

Enda jag kan komma att tänka på är dina routes eller möjligtvis proxy-inställningar.
Visa outputen från "sudo route", det kanske står något där.
Kolla även så att du inte har några skumma inställningar i webbläsaren under proxy.
Kan du pinga internethosts med "ping www.google.com" t ex? Eller är det bara webbläsaren som inte fungerar?

http://blinkenshell.org - Gratis shellkonton. Inklusive webbhost med PHP & MySQL.
http://www.blinkenlights.se/ - En site om programmering och spelutveckling på svenska

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

destination gateway genmask flags metric ref use iface
82.182.79.0 * 255.255.255.0 U 0 0 0 eth0
default 82.182.79.1 0.0.0.0 UG 0 0 0 eth0

vad ska matcha vad här om man jämför med de uppgifter jag anger via det grafiska gränssnittet i menyn under network settings?

EDIT:
I Mozilla har jag "direct connection".
Kan inte pinga adresser.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Kan du pinga din gateway? I ditt fall blir det 82.182.79.1

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

nope, verkar inte så!

meny/network tools/ping ger:
packages transmitted:2, packets loss: 100%

körde även i terminalen och den stannar här:
ping <adress> (<adress>) 56(84) bytes of data

kör man med nätverkskabeln urpluggad så står det "unreachable". skillnaden säger väl inte så mycket iofs.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Sant. Det ser ju nästan ut som om det är någon form av brandväggsregel som är uppsatt (men det låter högst otroligt).

Kör "sudo iptables -L" och berätta vad det står.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

chain INPUT (policy ACCEPT)
target / prot opt source / destination

chain FORWARD (policy ACCEPT)
target / prot opt source / destination

chain OUTPUT (policy ACCEPT)
target / prot opt source / destination

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Det ser helt normalt ut.

Jag förstår att du gick bet på detta. Jag har aldrig varit med om något liknande. Konfigurationsmässigt ser allt bra ut.

Du har inte något annat nätverkskort som du kan testa med? Det hade varit väldigt intressant att se om det kanske är en bug i drivrutinen eller hårdvaran som orsakar problemet.

Trädvy Permalänk
Medlem
Registrerad
Jun 2005

tyvärr inget kort att testa med, men det går väl att beställa. känns dock lättare att byta dist, pallar inte så många dagar utan att nörda på nätet

det är så sjukt skumt. verkar ju va fler som har ungefär samma problem men så hopplöst när det inte finns någon direkt lösning.

tack iaf för din hjälp!

Trädvy Permalänk
Medlem
Plats
Haninge
Registrerad
Feb 2005

Har du testat att dra ut n'a't kabeln n'a'r Ubuntu har startat helt?
F'o'r jag hadde samma problem, fick dra ut och sedan in kabeln sá fort internet f'o'rsvann. Efter kernel uppdateringen sá fungerar internetet perfekt.
F'o'rutom detta med att á 'a' och 'o' som inte fungerar, det fungerar i text baserade grejjen innan man startat gnome. Kanske albatrosk kan hj'a'lpa mig med det?
Men testa det, dra ur kabeln och sett iden, och skynda dig att test surfa.
Fungerade f'o'r mig som sagt.

Cooler Master Cosmos S | Corsair HX 750W | Asus P7P55D Evo | Core i5 750 @ 3.89ghz | Noctua U12P SE | Asus 7970 DCII | 8GB G.skill 2133Mhz

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Inga svenska tecken i GNOME? Troligtvis finns det ett verktyg i GNOME för att välja rätt teckenuppsättning, men om du vill göra det "på gammalt hederligt vis" så gör som följande:

1. Öppna upp /etc/X11/xorg.conf med valfi texteditor. Tänk på att du måste ha adminrättigheter för att redigera /etc/X11/xorg.conf, så starta editorn med sudo framför. Exempel: sudo gedit /etc/X11/xorg.conf
2. Leta reda på en InputDevice-sektionen för ditt tangentbord. Enklast är nog att söka efter "kbd" eller "XkbModel".
3. När du hittat den, se vad XkbModel och XkbLayout står inställda på. För svenskt tangentbord bör de stå som pc105 respektive se. Exempel:

Section "InputDevice" Identifier "Keyboard0" Driver "kbd" Option "XkbModel" "pc105" Option "XkbLayout" "se" EndSection

4. Sista steget är att starta om X. När du sparat och avslutat texteditorn så trycker du enklast ALT+CTRL+Backspace

Trädvy Permalänk
Medlem
Plats
Haninge
Registrerad
Feb 2005

Nr jag gjorde sá blev det tv'a'rt om. Alla tangenter fungerade inte f'o'rutom 'a' och 'o', sá det blev lite svárt att logga in.
Sáh'a'r stár det i min xorg.

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
Option "XkbVariant" "sv-latin1"
EndSection

endrade XkbVariant till se och det fungerade inte.
Har haft denna config hela tiden och det fungerar ju ner man har "dos" lege.
Alla tangenter fungerar, men so fort man startar upp Ubuntu helt, fron login skermen so fungerar inte á 'a' och 'o'.

Cooler Master Cosmos S | Corsair HX 750W | Asus P7P55D Evo | Core i5 750 @ 3.89ghz | Noctua U12P SE | Asus 7970 DCII | 8GB G.skill 2133Mhz

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Vad händer när du trycker p å, ä eller ö?

Plocka bort raden med XkbVariant och se var det leder.

Anledningen till att det fungerar i textläge men inte i X (grafiskt läge) är att det är två olika miljöer med två olika inställningar. Konsolen (textläget) använder alltså inte xorg.conf.

Trädvy Permalänk
Medlem
Plats
Haninge
Registrerad
Feb 2005

for upp detta om jag endrar i tangentbord i system/installningar.

Fel vid aktivering av XKB-konfiguration.
Det kan ske under diverse omständigheter:
- en bugg i biblioteket libxklavier
- en bugg i X-servern (verktygen xkbcomp, xmodmap)
- X-server med inkompatibel implementation av libxkbfile

Versionsdata för X-servern:
The X.Org Foundation
70000000

Om du rapporterar detta som ett fel ber vi dig ta med:
- Resultatet av xprop -root | grep XKB
- Resultatet av gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd.

Nu blir jag fundersam.

Nu fungerar ju åäö.
Kommer det att göra det hela tiden eller försvinner det om jag startar om datorn?
Och jag inte inte vad jag gjorde.
Jo, jag bockade av sweden som tangentbords layout. så att jag inte har någon standard.
Skumt.
Jag tackar för lånet i denna tråd RazFlasch.

Cooler Master Cosmos S | Corsair HX 750W | Asus P7P55D Evo | Core i5 750 @ 3.89ghz | Noctua U12P SE | Asus 7970 DCII | 8GB G.skill 2133Mhz