Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Problem med Postfix

Har återupptagit arbetet med att fixa en mailserver, och har kommit lite längre känns det som, men problemfritt är det ju verkligen inte.

Problemet är att jag inte får några svar när jag kör "telnet localhost 25"

simon@LinuxServer:~$ telnet localhost 25 Trying 127.0.0.1... Connected to localhost.localdomain. Escape character is '^]'. ehlo workaround.org

workaround.org har jag tidigare kört ehlo via port 25, och det har fungerat utmärkt, men nu får jag som sagt inget svar när jag skriver så. Självklart har jag pingat workaround.org, och fått svar, så felet ligger inte där. Detta kanske är en väldigt dum fråga, men måste jag ha port 25 öppen i min brandvägg åt något håll för att detta ska funka?

Dessutom visar min postfix-logg att något inte står rätt till (felen börjar komma när man ansluter till localhost via telnet, så något händer ju). Någon som kan tolka loggen för mig som oförstående?

Jul 12 13:09:05 localhost postfix/smtpd[25937]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:09:06 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25937 exit status 1 Jul 12 13:09:06 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:10:06 localhost postfix/smtpd[25938]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:10:07 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25938 exit status 1 Jul 12 13:10:07 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:11:07 localhost postfix/smtpd[25939]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:11:08 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25939 exit status 1 Jul 12 13:11:08 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:12:08 localhost postfix/smtpd[25940]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:12:09 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25940 exit status 1 Jul 12 13:12:09 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:13:09 localhost postfix/smtpd[25941]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:13:10 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25941 exit status 1 Jul 12 13:13:10 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:14:10 localhost postfix/smtpd[25942]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:14:11 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25942 exit status 1 Jul 12 13:14:11 localhost postfix/master[25908]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling Jul 12 13:15:11 localhost postfix/smtpd[25943]: fatal: bad boolean configuration: disable_vrfy_command = yes, Jul 12 13:15:12 localhost postfix/master[25908]: warning: process /usr/lib/postfix/smtpd pid 25943 exit status 1

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Det ser onekligen ut som om din postfix inte förstår "disable_vrfy_command". Det är också därför den "throttlar" och du inte får något svar när du försöker kommunicera med den.

Jag kör version 2.2.8, och där fungerar det bra. Det är inte så att du kopierat färdig konfiguration från en annan version av postfix?

En snabbfix är helt enkelt att kommerntera bort disable_vrfy_command från main.cf, men det innebär i sin tur att din postfix-daemon kommer att acceptera vrfy från utomstående.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Tusen tack för hjälpen!

När jag tittade in i main.cf för att kommentera ut raden såg jag att det smugit sig in ett illvilligt kommatecken (,) efter "=yes". När jag tog bort detta kom jag vidare!

Nästa problem:

Jul 12 17:40:23 localhost postfix/smtpd[26700]: connect from localhost.localdoma in[127.0.0.1] Jul 12 17:42:18 localhost postfix/smtpd[26700]: B95D7CB5AE: client=localhost.loc aldomain[127.0.0.1] Jul 12 17:42:36 localhost postfix/cleanup[26707]: B95D7CB5AE: message-id=<200607 12154051.B95D7CB5AE@newtoasted.no-ip.org> Jul 12 17:42:36 localhost postfix/qmgr[26657]: B95D7CB5AE: from=<xxxxxxxx@bredband.net>, size=398, nrcpt=1 (queue active) Jul 12 17:42:36 localhost postfix/virtual[26709]: B95D7CB5AE: to=<simon@newtoast ed.no-ip.org>, relay=virtual, delay=105, status=deferred (maildir delivery faile d: create /var/spool/mail/virtual/simon/tmp/1152718956.P26709.localhost.localdom ain: Permission denied) Jul 12 17:42:36 localhost postfix/virtual[26709]: warning: maildir access proble m for UID/GID=5000/5000: create /var/spool/mail/virtual/simon/tmp/1152718956.P26 709.localhost.localdomain: Permission denied Jul 12 17:42:36 localhost postfix/virtual[26709]: warning: perhaps you need to c reate the maildirs in advance Jul 12 17:42:40 localhost postfix/smtpd[26700]: disconnect from localhost.locald omain[127.0.0.1]

(de skumma mellanrummen är bara för att mitt terminalfönster var för litet, de exsisterar inte i "verkligheten" så att säga)

Nu kommer en fråga som visar tydligt vilken linux-n00b jag är: Jag ser att problemet är ett rättighetsproblem, så min fråga är alltså:

Hur gör jag för att användaren/gruppen med UID/GID 5000 ska få fulla rättigheter till mappen "/var/spool/mail"? Jag förstår att jag kan logga in som användaren, och köra chown, och sen chmod 700, men det ger ju inte gruppen fulla rättigheter.. Hur gör jag helt enkelt så att användare med UID 5000 och gruppen med GID 5000 äger filen, så att jag kan chmodda 770 sen?

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Ajdå, jag missade också kommatecknet

Jag använder inte själv maildir (ja, jag är gammeldags) men rimligen borde en liten variation på det du skriver fungera.

Som root, kör "mkdir /var/spool/mail/virtual", "chown 5000:5000 /var/spool/mail/virtual" och sätt rättigheterna med "chmod 770 /var/spool/mail/virtual". Då blir UID och GID 5000 ägare till katalogen och får fulla rättigheter, medans ingen annan får göra någonting alls med den.

Visar det sig att du måste ge alla läs/skrivrättigheter till den katalogen så går det att lösa senare, men det lär du märka

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Jag såg inte att du svarat, så jag pillade tills jag kommit fram till exakt det du skriver, och nu funkar det också

Är på steget att testa IMAP-delen med courier nu, håll tummarna

Edit:

Imap funkar, och jag kan ta emot mail jag skickar internt (eller vad jag ska kalla det, telnet localhost 25, ehlo workaround.org, mail from: <kalle@anka.se>, rcpt to: simon@newtoasted.no-ip.org, data, hej, quit), och likaså kan jag genom Squirrelmail skicka mail, men jag kan inte skicka mail från t ex hotmail till simon@newtoasted.no-ip.org.

Var ska jag leta fel?

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
/root
Registrerad
Jul 2001

Jag är inte speciellt insatt i hur detta fungerar på någon punkt, men jag gissar på att du måste ha ett MX-record för din domän. Möjligt att det går att ställa in i inställningarna för din no-ip-domän, om inte får du nog tyvärr skaffa en "riktigt" domän.

"to conquer others is to have power, to conquer yourself is to know the way"
Blogg / Browser/OS-sniffer

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Ah, ok

Så om jag som jag planerat köper "mitefternamn.se" hos crystone.se, så får jag där en möjlighet att sätta ett MX-record?

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Precis som dr slizer säger så kan det vara så att Hotmails servrar kräver ett MX-record. Det är dock ett ganska ovanligt krav, och jag körde en hemmatestmailserver i några år utan MX utan att det krånglade. De flesta mailservrar försöker med domänen om de inte kan göra ett MX-uppslag.

Väl värt ett försök är det ändå att lägga till ett MX-record.

En annan sak; det är väl inte så att din internetleverantör/webhost blockerar inkommande port 25? Testa att gå in på den utifrån och se vad som händer.

EDIT: Nä, du kan ju skicka brev, så vad skulle de vinna på att ha utgående öppen men inte inkommande? Dumt tänkt av mig,

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Först och främst, tack för er hjälp!

Jo, det är så att Bredbandsbolaget blockerar port 25, så allt skickas via smtp.bredband.net som relay host.

Som det är nu har jag ingen riktig domän, utan bara ett dyndns-namn. Tror ni det skulle fungera bara jag registrerar ett .se domännamn för 69 kr om året? Jag skulle väldigt gärna vilja ha namn@efternamn.se nämnligen

Se gärna min andra tråd om domäner o dyl: http://www.sweclockers.com/forum/showthread.php?s=&threadid=6...

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Men Bredbandsbolaget blockar inte inkommande port 25, åtminstone inte på mitt abonnemang, så det förklarar inte varför du inte fick något från hotmail.

Tar domänbiten i domäntråden.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Nej, det stämmer, var lite förvirrad där ett tag

Skulle gissa på att det är något med domänbiten som krånglar, och att det borde gå att lösa åtminstone delvis genom att registrera en domän med DNS hos Crystone? Eller tror du att jag är helt ute och cyklar då?

Hur som helst, tusen tack för din hjälp hittills, jag uppskattar det verkligen!

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Mail är en ren vetenskap för sig själva.

Men men... ja bästa är att skaffa en domän och peka ett MX record mot din maskin där hemma (som hellst ska ha ett FQDN, t.ex mail.nyrostad.net)

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

maDa:

Jo, jag har märkt det

Domän hade jag tänkt registrera idag, men hur fixar jag ett FQDN? Ingår det på något sätt? Eller är det server-side?

EDIT:

Kom förresten på detta:

Är det någon som vet om CrystoneDNS har någon dynDNS? Blir lite krångligt annars med min dynamiska IP..

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

FQDN är ett komplett domännamn (nyrostad) med värd (mail) och topdomän (net), t.ex. mail.nyrostad.net precis som maDa skrev.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Nov 2005

Jo, så långt är jag med, men var talar jag om för internet/servern att min server heter "mail"?

Workstation: i7 2600k | P8Z68-V Pro | 16 Gb RAM | MSI Radeon 390 | NEC PA241W
Portabelt: Surface Pro 3 | Samsung Galaxy S6 Edge
Fotoväska: Nikon D800E | Nikkor AF-S 24-70/2,8 G ED | Nikkor AF-S 85+50/1,8 G

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Det ställer du både på din server (med t.ex. /etc/hosts) och i din DNS (CrystoneDNS i ditt fall).