Ubuntu nätverk slutar fungera.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2004

Ubuntu nätverk slutar fungera.

Hejsan. Jag har precis installerat Ubuntu 6.06 på min flickväns dator. Allting fungerar perfekt, förutom nätverket. Det fungerar inte alls!

Jag sitter bakom en D-link router. I nätverket finns det också en windowsdator som kommer ut på internet perfekt.

När jag försöker pinga router (192.168.0.1) så får jag fram Destination Host Unreachable på varje paket. Kör jag arp -v så hittar den ingenting.

Kör jag ifconfig eth0 så verkar allting fungera. Link active osv... Allt ser helt ok ut!

Om jag kör mii-tool och byter från 10Mb FD till 100Mb FD och sen tillbaka till 10Mb FD så fungerar allt perfekt, i EXAKT 60 sekunder. Det går att pinga allt, jag kan surfa, arp visar min router osv.

Efter 60 sekunder dör allting, och det blir som innan, inget går att pinga och arp slutar hitta något.

Vet någon vad felet kan vara?

Tack på förhand

"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety." - Benjamin Franklin

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Det ser ut som en väldigt buggig nätverksdrivrutin. Vad är det för nätverkskort, och vilken drivrutin använder det?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2004

Jag har ett "21x4x DEC-Tulip compatible 10/100 Ethernet".

Var hittar man drivern? Inne på enhetshanteraren står det:
info.linux.driver - strlist - tulip

"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety." - Benjamin Franklin

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Okt 2004

Det finns en del olika drivisar som funkar på diverse 21x4x-kort.

För att se exakt vilket kort så kan du köra "lspci".

Om du vet hur så föreslår jag att du testar de4x5 och dmfe istället för tulip, och ser om det blir någon skillnad.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2004

När jag kör lspci får jag fram "0000:01:09.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 31)".

Tyvärr har jag ingen aning om hur man byter drivrutier, ungefär hur gör man?

Edit: Allt fixades genom att byta till dmfe drivrutinerna, för att göra det så gjorde jag såhär:

ifdown eth0
rmmod tulip
rmmod dmfe
modprobe dmfe
ifup eth0

Tack för hjälpen!

"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety." - Benjamin Franklin