Kompilera aMSN med tcl/tk 8.5

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Dec 2003

Kompilera aMSN med tcl/tk 8.5

Försöker få igång aMSN Black version men jag måste kompilera amsn med tcl/tk 8.5 annars krashar det.

Jag kör ubuntu och eftersom tcl/tk 8.5 ej finns som stable så finns det ej under apt-get så jag installerade dem manuellt. Nu måste jag bara kompilera aMSN med tcl/tk 8.5 sen bör det funka.

Så frågan lyder hur kompilerar du aMSN med tcl/tk 8.5 i ubuntu?

Trädvy Permalänk
Medlem
Plats
/etc
Registrerad
Apr 2006

tcl/tk är interprederat(?) språk. Du ska inte kompilera saker skrivna i det. Se bara till att tcl/tk är korrekt installerat och rulla på.

Opera user | 3.6 GHz AMD Phenom II X4 | 6144MB RAM | AMD ATI HD7870 2GB | Det är jag det.
Linux, Eating apple and smashing Windows.

Trädvy Permalänk
Medlem
Plats
Norrland
Registrerad
Dec 2003

Jag vet aMSN använder sig av tcl och tk. Men dom använder sig ej av tcl/tk 8.5 eftersom det är fortfarande i beta versionen(?)

Jag har dragit in tcl/tk 8.5 men när jag byter "genvägar" för wish och tclsh så whinar den och säger "Segmentation fault".
Snackade med en utvecklare för live skin som black version är baserat på och han sa:
Because you have not compiled aMSN against tcl/tk 8.5... thats why "Segmentation fault"

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2003

På amsn.sourceforge.net finns source. Ta senaste utvecklingsversionen. Packa upp.. när du skriver ./configure kontrollerar du att den använder sig av tcl/tk 8.5.
sedan make
sen ./amsn

sudo make install - om det fungerar att starta med ./amsn

Det finns en guide för att installera tcl/tk 8.5 avsedd för antialiasing i amsn. om det inte skulle fungera:
http://amsn.sourceforge.net/wiki/tiki-index.php?page=Installa...