Lite strul efter att jag kompilerat ny kärna.

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2005

Lite strul efter att jag kompilerat ny kärna.

Tänkte test att kompilera en ny kärna.. men får det inte riktigt att fungera..
när jag väljer att boota med min nya kärna säger den följande..

Mouting root filesystem
Mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

nån som vet vad jag kan tänkas gjort fel?

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Apr 2002

Säker på att du kompilerade stöd för de saker du använder?
I detta fall, ext3 kanske?

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av BigBen
Säker på att du kompilerade stöd för de saker du använder?
I detta fall, ext3 kanske?

hade med stöd för ext3 vad jag kan se..

missade lite fel ifs.. så här såg det ut..

Scanning logical volumes
Reading all physical volumes. This may take a while...
No volume groups found
Activating logical volumes
Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally! (pid 295)
Creating root devices
Mouting root filesystem
Mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

Trädvy Permalänk
Medlem
Registrerad
Jul 2005

Kan det vara så att din hårddisk dog plötsligt? Bootar den gamla kerneln? Testa att kompilera om den igen.

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av Neoecs
Kan det vara så att din hårddisk dog plötsligt? Bootar den gamla kerneln? Testa att kompilera om den igen.

Det är en virtuell maskin (vm-ware), den gammla kerneln bootar alldeles utmärkt ja.. har testat kompilera om den..

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2003

Kör du med configfil specifik för din dist? (har det till fc4 iaf) .. eller "vanilla" eller vad det heter?
Använder du grub? (eller hur gör man när man bootar vmware?) Isåfall kan du kolla i /boot/grub/menu.1st att nya kerneln har samma root som den gamla..

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2005
Citat:

Ursprungligen inskrivet av nosnahoj
Kör du med configfil specifik för din dist? (har det till fc4 iaf) .. eller "vanilla" eller vad det heter?
Använder du grub? (eller hur gör man när man bootar vmware?) Isåfall kan du kolla i /boot/grub/menu.1st att nya kerneln har samma root som den gamla..

Mjae, det vet jag inte.. har både testat med en ny och samma configfil till den gammla kärnan..

Jo, använder grub.. att boota vm-ware är som att boota vilken dator som helst bara det att du ser allt i ett fönster på skärmen ist för direkt på skärmen

jo, dom har samma root..

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Apr 2002

Kan det vara nåt strul i /etc/fstab kanske?
Kolla så att allt ser OK ut kan ju inte skada iaf.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Mar 2003
Citat:

Ursprungligen inskrivet av Enron
Mjae, det vet jag inte.. har både testat med en ny och samma configfil till den gammla kärnan..

Jo, använder grub.. att boota vm-ware är som att boota vilken dator som helst bara det att du ser allt i ett fönster på skärmen ist för direkt på skärmen

jo, dom har samma root..

ok.. fungerar det om du kompilerar en "ny" kärna med annat namn av exakt samma version som den gamla? eller det kanske du har gjort innan..?
Isåfall vet du ju om det är nya kärnan (felaktig configfil?) som orsakar problemet, eller om det är något annat knas. Borde ju iofs vara nya kärnan omdu har kompilerat om förut..men jag tycker inte det felet borde uppkomma alls om man har gjort helt rätt?