Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Nov 2004

Ubuntu - Paketproblem

Nu har jag stött på lite problem här på söndagsmorgonen. Jag vill ha installerat libgtk2.0-dev men det vill sig inte riktigt.

Output från "sudo apt-get install libgtk2.0-dev":

Reading package lists... Done Building dependency tree... Done You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies: libgtk2.0-0: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is to be i nstalled libgtk2.0-bin: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is to be installed libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.8.17-1ubuntu5) but 2.8.18-0ubuntu2 is to be installed Depends: libatk1.0-dev (>= 1.6.1-2) but it is not going to be i nstalled Depends: libxext-dev but it is not going to be installed Depends: libxinerama-dev but it is not going to be installed Depends: libxi-dev but it is not going to be installed Depends: libxrandr-dev but it is not going to be installed Depends: libxcursor-dev but it is not going to be installed Depends: libxfixes-dev but it is not going to be installed libpango1.0-common: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is to be installed libvte4: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is to be insta lled E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s olution).

Output från "sudo apt-get -f install":

Reading package lists... Done Building dependency tree... Done Correcting dependencies... failed. The following packages have unmet dependencies: libgtk2.0-0: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is installed libgtk2.0-bin: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is installed libpango1.0-common: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is installed libvte4: Depends: libpango1.0-0 (>= 1.12.3) but 1.12.2-0ubuntu3 is installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies

Har ni något tips på vad man kan göra åt problemet?

Tack i förhand!

/// EDIT ///

Det löste sig visst på något magiskt sätt när jag satt och fifflade med helt orelaterade paket. Trevligt värre!

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

nu vet jag inte ifall det här funkar, å du gör det på egen risk,

men "apt-get autoclean" "apt-get clean"
tror det är så, då rensar den bort alla paket som bara ligger, så kan du testa att installera om paketet igen, men som sagt, jag vet inte