Problem med teckenkodning via ssh från mac till linuxserver.

Trädvy Permalänk
Medlem
Plats
Boden
Registrerad
Maj 2004

Problem med teckenkodning via ssh från mac till linuxserver.

Tja!

Nappade direkt på Googlah's generösa erbjudande om shell på hans server. inget funkar ordenligt. Har fixat så att hemsidorna blir rätt genom att använda en .htaccsess fil.

Men nu till irssi problemet.

jag har gjort följande:

Citat:

mewmins MacOS X-åäö-i-Terminal.app-guide

Jag ska skärmskotta den här guiden för att göra den mer pedagogisk.

1. Öppna menyn Terminal (brevid äpplet längst upp) för Terminal.app
Välj menyn Window settings -> Display -> Western (ISO Latin 1)

För er som kör på svenska blir det Fönsterinställningar -> Skärmutseende -> Västerländsk (ISO Latin 1)
(längst ner under Teckenuppsättningskodning)

2. Avmarkera Emulation -> Escape non-ascii characters
Svenska: Emulering -> Escape ICKE ASCII-tecken

Klicka sedan på "Använd inställningar som förval"

3. Lägg in detta i din ~/.inputrc och starta om bash:

set convert-meta off
set input-meta on
set output-meta on

Du får skapa den med t.ex "pico .inputrc", klistra in texten, avsluta med
ctrl+x, spara som .inputrc i din hemkatalog (/Users/dittnamnhär/)

Där steg 3 gjordes på servern efter Vacums inrådan. Så nu har jag följande problem:

När jag trycker på delte knappen på mitt tangetbord i terminalen på servern (altså när jag har ssh'at och kommit in i promten) så dyker det upp ett tilde tecken "~". Men här funkar backspace utmärkt.

Öppnar jag en applikation tex irssi, eller nano, så funkar inte backspace men delete funkar. Ska dock tilläggas att i applikationerna så kan jag få backspace funktion med ctrl+h.

Jag skulle gärna upskatta lite hjälp med detta

Macbook Vit | Macbook Unibody | D80 | iPod Touch | iPhone 3GS

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Jan 2006

Låter onekligen skumt. Nån annan som kan tänka sig veta vad som ligger bakom?

Gigabyte-P35-DS4 | Intel Core 2 Quad Q6600 [3 GHz] | 2x1GB Corsair XMS-6400@800Mhz | Nvidia Geforce 460 GTX [975/2000 MHz] | Intel 320 Series 80 GB SSD | | SETI@Home Team: Sweclockers.com

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Jul 2005

För att ändara BS knappen så ge kommandot:

stty erase "tryck på backspace"

Sedan kan du lägga in den raden i din .profile

Kriga mot min brute: http://gunnard.se.mybrute.com om du vågar :D

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Feb 2002

Välj Window Settings i Terminalen
Gå ner till keyboard
Bocka i Delete Key sends backspace

Trädvy Permalänk
Medlem
Plats
Boden
Registrerad
Maj 2004

har löst det tack vare sidde's lösning, fast VaCum var före... :), och sen så ska jag testa GunnarD's förslag nu, man ska stoppa det på macen va?

Macbook Vit | Macbook Unibody | D80 | iPod Touch | iPhone 3GS