Trädvy Permalänk
Medlem
Registrerad
Mar 2006

Vaio + Kubuntu?

Hejsan

Jag har precis installerat Kubuntu på min nya sony vaio. Jag postade ett meddelande på ett engelsktalande forum, och jag tänkte klistra in den texten rakt av utifall det finns någon som är engelsktalande som skulle läsa det här

I'll post all of my questions, and I appreciate any help I can get with any of them:

1) How do I get my WiFi to work? I've googled and really tried, but I just can't figure it out. All the pages I've read have been discussing what to do if the WiFi doesn't work at all, but the thing is that Kubuntu sees the WiFi card, and I'm even able to scan the area for networks. I just can't connect to a network, not even the ones without a key. I've tried Network Manager, but I haven't gotten it to work. It seems that NM is meant for Gnome, and I use KDE.

2) How do I know if Kubuntu understands that I have a Dual Core processor? If it doesn't, how do i fix this?

3) How do I get the "fn" and "S1" and "S2" keys to work?

4) How do I do to make the Stamina/Speed switch to work?

5) How do I know that I get the most out of my nVidia graphics card? Is there a test-program?

6) How do I activate Sony Vaio under System Settings / Laptops & Power / sony vaio laptop?

7) I've installed javac, but what should I do to be able to write just "javac" in order to use the java compiler (right now I have to write /home/alex/jdk1.5.0_08/bin/javac. I think I have to change/add a path somewhere, but where and how?)

Cool How do I remove "tapping counts as click" on the pad?

9) How should I approach the problem of drivers when connecting a new device? For example, I've just bought a scanner/printer (Canon PIXMA MP500) and I can't get it to work with my laptop.

10) Once I get the wireless to work, how do get the WIRELESS ON/OFF switch to function?

Here is the computer I've bought:
http://www.dustin.se/DacsaPortal/?ProdID=5010095762

And here is my lspci:
0000:00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 03)
0000:00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
0000:00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
0000:00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
0000:00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
0000:00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
0000:00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
0000:00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
0000:00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controllers cc=IDE (rev 02)
0000:00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
0000:06:00.0 Network controller: Intel Corporation: Unknown device 4222 (rev 02)
0000:07:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 Fast Ethernet Controller (rev 15)
0000:09:04.0 CardBus bridge: Texas Instruments: Unknown device 8039
0000:09:04.1 FireWire (IEEE 1394): Texas Instruments: Unknown device 803a
0000:09:04.2 Mass storage controller: Texas Instruments: Unknown device 803b

And here is what I get with uname -a:
Linux alex-laptop 2.6.15-26-386 #1 PREEMPT Thu Aug 3 02:52:00 UTC 2006 i686 GNU/Linux

Well, that's about it for now. I just spewed out all the questions I had (of course I've googled all of them quite a lot). And as I said before, I really appreciate all the help I can get with any of the above questions.

Thanks a lot!

Man är aldrig IRL, bara AFK.

Trädvy Permalänk
Medlem
Plats
Örebro universitet
Registrerad
Dec 2001

1: har du satt essid?
2: kan finnas här http://www.linux.se/doc/swe/SMP-HOWTO-se-3.html
3: kompilera om kärnan, tror det ligger under acpi
4: menar du cpu-skalning? testa med powernowd
5: glxgears fungerar bra
6:
7: lägg till den i din path: PATH=$PATH;/home/alex/jdk1.5.0_08/bin/javac
detta kan man även göra i din .bashrc i hemmappen (antar att du kör bash)

8: tapping tas som klick, håll fingret på plattan lite längre så ska det fungera

9:kolla med tail /var/log/messages så att den hittas, sedan så får du googla på det som kommer fram. (http://gentoo-wiki.com/Canon_Pixma_Series) på google
cups är också ett hett tips

10:

Sempron 3100+ GF3ti200 1024MB RAM WinXP
XP1600+ "A7V8X" 512MB ram FX5200(GF5) Debian Testing (Openbox)
Acer XP1800+ (bärbar)Debian Gnome

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2001

Tapping grejjade jag genom att editera /etc/X11/xorg.conf med följande tillägg

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "MaxTapTime" "0"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"

EndSection